You are not logged in.

#1 2018-07-11 10:36:17

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Hello guys,
First off all, thanks a lot for your time, I really appreciate it!
Also, I'm new to this forum, and I hope this topic relates to Kernel and Hardware ...

So well I broke my system, currently not bootable. (However have a live version on an USB Stick)
It all started with me trying to install a .deb package, because there was no version for arch. Therefor I installed dpkg and tried to install my desired package. However the installation failed duo missing dependencies. So I think here is where I broke my system. Because the package I was trying to install needed a library similar to libc (not sure anymore about the exact name, maybe something like glib or so ..., I probably could find it out if necessary) So I downloaded the needed package and installed it with dpkg. That installation failed and after that my system was not working probably anymore. My desktop (KDE Plasma 5) couldn't launch any applications anymore so I rebooted. And then I was greeted to my surprise with a nice error message:
relocation error: /usr/lib/libc.so.6: symbol _dl_exception_create, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with time reference
followed with:
Kernel panic - not syncing: Attempted to kill init! exitcode=0x0007f00
I'm running the newest kernel version (I think it is 4.17.2-1, I think further information to my system is irrelevant)

What I have done so far:
I booted into a liveCD (also Arch) and looked around a bit.
/usr/lib/libc.so.6 and ld-linux-x86-64.so.2 still exist with, anything else would probably be odd.
Also I have red in a forum that I could try to mount and chroot my system over a liveCD and then reinstall the libc package, however when I try to chroot my system, I get the same error message as above ...

So well, I would be glad if anyone could help me, I don't want to reinstall my system ...
Thanks in advance!

Offline

#2 2018-07-11 10:50:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,256

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

That's a horrifying idea. Do not ever mix unrelated package management systems. You could've checked if a PKGBUILD existed and/or ask for help creating one. You just overwrote a core library with an incompatible version from another system it wasn't intended for.
Boot into a live disk and reinstall glibc and any other package similarily replaced with the pacman --sysroot option. You might also want to read https://wiki.archlinux.org/index.php/Pa … 9.22_error

Also there's a lot of maybes and eventualities in your post, find out exactly what you installed and remove them using dpkg and reinstall the correct repo versions.

How did you install Arch?

Mod Note, not a kernel issue, moving to NC

Offline

#3 2018-07-11 11:13:26

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

I was trying to install a printer utility ... So I guess asking Canon to create a PKGBUILD would lead nowhere. Yeah I thought so from the beginning, but trying to set up a network printer while needing to print some important stuff got me desperate somehow ...
But well as I stated I can't boot my system anymore and trying to chroot it from a livecd gives me the same error message. So I can neither reinstall anything with pacman nor remove something with dpkg.

I installed Arch normally, using the official guide from this website

Offline

#4 2018-07-11 11:17:11

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,256

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

You don't have to chroot, you can use pacman's --sysroot option. That will use the pacman on your live disk to install packages on your main system.

In principle you want to do this, just not specifically for pacman but for the relevant core libraries involved (from what we know so far just, glibc) https://wiki.archlinux.org/index.php/Pa … an_upgrade

As for canon printer drivers: https://aur.archlinux.org/packages/?O=0&K=canon Are you sure that that was nowhere in this list? In addition to that, many canon printers have good open drivers available as part of  the gutenprint package.

Last edited by V1del (2018-07-11 12:10:47)

Offline

#5 2018-07-11 12:32:39

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Alright, that with chroot was my bad, sry.
So well, I was able to mount my drive as stated in the link, however when I now try to reinstall glibc, I get the following error:
error: GPME error: Invalid crypto engine
error: glibc: missing required signature
:: File /var/cache/pacman/pkg/glibc-2.27-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PKG signature))
And then followed with:
error: failed to commit transaction (invalid or corrupted package (PKG signature))
Errors occured, no packages were upgraded.
This btw. happens by every package I try to upgrade. This error was discribed at the packman link as well, however I can't find any part files

Offline

#6 2018-07-11 13:31:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,213

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

post the command you tried.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2018-07-11 13:51:01

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

pacman --sysroot /mnt -S glibc

Offline

#8 2018-07-11 14:16:34

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

You ran `pacman --sysroot /mnt -S glibc` from the install media with the filesystems of the target system mounted under /mnt but without running chroot?

Offline

#9 2018-07-11 14:18:38

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Yeah exactly, I might have to mention that im still somewhat new to linux

Offline

#10 2018-07-11 14:22:18

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

See List_of_applications#Pastebin_clients to post from the console to a pastebin.
Please post the output of `pacman --debug --sysroot /mnt -S glibc` to a pastebin and link the the post.
Edit:
Also the output of findmnt after running the above.

Last edited by loqs (2018-07-11 14:25:03)

Offline

#11 2018-07-11 14:54:14

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Alright,
Pacman: https://ptpb.pw/dUK9 (not sure why the debug lines are not there)
Findmnt: https://ptpb.pw/po5u

Offline

#12 2018-07-11 14:58:16

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

pacman --debug --sysroot /mnt -S glibc 2>&1 | curl -F c=@- https://ptpb.pw

This should redirect stderr as well

Offline

#13 2018-07-11 15:07:30

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

This one just does nothing ...

Offline

#14 2018-07-11 15:18:54

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

It did not provide a ptpb.pw link or the link was to a blank page?  If you use

pacman --debug --sysroot /mnt -S glibc 2>&1

Does that produce the same output on the console as

pacman --debug --sysroot /mnt

Offline

#15 2018-07-11 15:24:11

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

pacman --debug --sysroot /mnt -S glibc 2>&1
Does the same as
pacman --debug --sysroot /mnt -S glibc
However
pacman --debug --sysroot /mnt -S glibc 2>&1 | curl -F c=@- https://ptpb.pw
Does nothing, just one empty new line pops up

Offline

#16 2018-07-11 15:24:54

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

And
pacman --debug --sysroot /mnt
Outputs not the same

Offline

#17 2018-07-11 15:32:21

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

pacman --debug --sysroot /mnt -S glibc 2>&1 > output.txt #check output.txt contains the expected output
cat output.txt | curl -F c=@- https://ptpb.pw

Please try the above

Offline

#18 2018-07-11 15:37:31

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Text file has the same context as the first pastebin link, so no debug text either

Offline

#19 2018-07-11 15:55:08

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

pacman --debug --sysroot /mnt -S glibc &> output.txt #check output.txt contains the expected output
cat output.txt | curl -F c=@- https://ptpb.pw

This version should work I hope
Edit

pacman --debug --sysroot /mnt -S glibc |& curl -F c=@- https://ptpb.pw

should also work on zsh and bash

Last edited by loqs (2018-07-11 16:00:37)

Offline

#20 2018-07-11 16:05:37

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

That one worked, https://ptpb.pw/h_82

Offline

#21 2018-07-11 16:12:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,994

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Instead of all of that, you could have just read the error in the first place. It tells you exactly what the problem is and how to fix it.

Offline

#22 2018-07-11 16:25:29

manuel2258
Member
Registered: 2018-07-11
Posts: 12

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

Okey, now I feel stupid ...
I simply removed dpkg with pacman and reinstalled glibc afterwards.
Now my PC boots and works once again.
Thanks a lot to anyone who helped me, you saved me the pain of reinstalling the os and every program I got running.
As I'm new to this forum, how can I tag it as solved?
Have a great day!

Offline

#23 2018-07-11 16:40:41

loqs
Member
Registered: 2014-03-06
Posts: 5,819

Re: Relocation Error: /usr/lib/libc.so.6 | System not starting anymore

@Scimmia this error?

error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck

@manuel2258
You can mark the thread as solved by editing the first post and prepending [SOLVED] to the title.

Last edited by loqs (2018-07-11 16:50:45)

Offline

Board footer

Powered by FluxBB