You are not logged in.

#1 2018-07-18 12:05:34

Tharbad
Member
Registered: 2016-02-27
Posts: 239

[SOLVED] gpg ERR 167772472

Hi,

I searched the internet before. I'm trying to add a key.

gpg --debug-all  -vvv --recv-keys 465022E743D71E39
gpg: Note: no default option file '/home/<user>/.gnupg/gpg.conf'
gpg: using character set 'utf-8'
gpg: enabled debug flags: packet mpi crypto filter iobuf memory cache memstat trust hashing ipc clock lookup extprog
gpg: DBG: [not enabled in the source] start
gpg: no running Dirmngr - starting '/usr/bin/dirmngr'
gpg: waiting for the dirmngr to come up ... (5s)
gpg: DBG: chan_3 <- # Home: /home/<user>/.gnupg
gpg: DBG: chan_3 <- # Config: /home/<user>/.gnupg/dirmngr.conf
gpg: DBG: chan_3 <- OK Dirmngr 2.2.9 at your service
gpg: connection to the dirmngr established
gpg: DBG: chan_3 -> GETINFO version
gpg: DBG: chan_3 <- D 2.2.9
gpg: DBG: chan_3 <- OK
gpg: DBG: chan_3 -> KS_GET -- 0x465022E743D71E39
gpg: DBG: chan_3 <- ERR 167772472 Try again later <Dirmngr>
gpg: keyserver receive failed: Try again later
gpg: DBG: chan_3 -> BYE
gpg: DBG: [not enabled in the source] stop
gpg: keydb: handles=0 locks=0 parse=0 get=0
gpg:        build=0 update=0 insert=0 delete=0
gpg:        reset=0 found=0 not=0 cache=0 not=0
gpg: kid_not_found_cache: count=0 peak=0 flushes=0
gpg: sig_cache: total=0 cached=0 good=0 bad=0
gpg: random usage: poolsize=600 mixed=0 polls=0/0 added=0/0
              outmix=0 getlvl1=0/0 getlvl2=0/0
gpg: rndjent stat: collector=0x0000000000000000 calls=0 bytes=0
gpg: secmem usage: 0/32768 bytes in 0 blocks

dirmngr.conf:

standard-resolver

Last edited by Tharbad (2018-07-18 20:23:04)

Offline

#2 2018-07-18 14:09:45

seth
Member
Registered: 2012-09-03
Posts: 16,569

Re: [SOLVED] gpg ERR 167772472

gpg --keyserver hkp://pool.sks-keyservers.net --recv-keys 465022E743D71E39

?

Online

#3 2018-07-18 15:17:40

Tharbad
Member
Registered: 2016-02-27
Posts: 239

Re: [SOLVED] gpg ERR 167772472

seth wrote:
gpg --keyserver hkp://pool.sks-keyservers.net --recv-keys 465022E743D71E39

?

gpg: keyserver receive failed: Try again later

Offline

#4 2018-07-18 16:10:04

seth
Member
Registered: 2012-09-03
Posts: 16,569

Re: [SOLVED] gpg ERR 167772472

Just install the key from a file: https://github.com/polygamma.gpg
The failed receive is weird, though.

gpg --keyserver hkp://pool.sks-keyservers.net --search-keys jonny.westphalen
dig pool.sks-keyservers.net

Online

#5 2018-07-18 17:20:43

Tharbad
Member
Registered: 2016-02-27
Posts: 239

Re: [SOLVED] gpg ERR 167772472

seth wrote:
gpg --keyserver hkp://pool.sks-keyservers.net --search-keys jonny.westphalen

gpg: error searching keyserver: Try again later
gpg: keyserver search failed: Try again later

dig pool.sks-keyservers.net

; <<>> DiG 9.13.0 <<>> pool.sks-keyservers.net
;; global options: +cmd
;; connection timed out; no servers could be reached

I prefer to solve this problem. Before I thought it's part of 2.1.7 bug. Unfortunately I'm wrong.

Offline

#6 2018-07-18 18:13:34

loqs
Member
Registered: 2014-03-06
Posts: 11,864

Re: [SOLVED] gpg ERR 167772472

dig @8.8.8.8 pool.sks-keyservers.net

Offline

#7 2018-07-18 19:40:44

Tharbad
Member
Registered: 2016-02-27
Posts: 239

Re: [SOLVED] gpg ERR 167772472

loqs wrote:
dig @8.8.8.8 pool.sks-keyservers.net
; <<>> DiG 9.13.0 <<>> @8.8.8.8 pool.sks-keyservers.net
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17132
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 10, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;pool.sks-keyservers.net.       IN      A

;; ANSWER SECTION:
pool.sks-keyservers.net. 2999   IN      A       91.121.117.144
pool.sks-keyservers.net. 2999   IN      A       193.164.133.100
pool.sks-keyservers.net. 2999   IN      A       204.61.209.238
pool.sks-keyservers.net. 2999   IN      A       91.134.124.120
pool.sks-keyservers.net. 2999   IN      A       149.28.165.222
pool.sks-keyservers.net. 2999   IN      A       5.135.158.148
pool.sks-keyservers.net. 2999   IN      A       84.200.66.125
pool.sks-keyservers.net. 2999   IN      A       144.76.43.40
pool.sks-keyservers.net. 2999   IN      A       95.179.141.230
pool.sks-keyservers.net. 2999   IN      A       212.51.156.190

;; Query time: 71 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Jul 18 20:54:37 IDT 2018
;; MSG SIZE  rcvd: 212

I use DHCP and it's dns is 8.8.8.8 so it should get the same result as before. But it's not the case, is it?

Last edited by Tharbad (2018-07-18 19:42:13)

Offline

#8 2018-07-18 19:53:26

seth
Member
Registered: 2012-09-03
Posts: 16,569

Re: [SOLVED] gpg ERR 167772472

No. Your global DNS is not 8.8.8.8 - and that's why the key receive fails.

How exactly do you configure your network?

Online

#9 2018-07-18 20:11:37

Tharbad
Member
Registered: 2016-02-27
Posts: 239

Re: [SOLVED] gpg ERR 167772472

seth wrote:

No. Your global DNS is not 8.8.8.8 - and that's why the key receive fails.

How exactly do you configure your network?

In the router. It's appears it was wrong. However nothing changed.

networkctl status enp0s3 
● 2: enp0s3
       Link File: /usr/lib/systemd/network/99-default.link
    Network File: /etc/systemd/network/25-wired.network
            Type: ether
           State: routable (configured)
            Path: pci-0000:00:03.0
          Driver: e1000
          Vendor: Intel Corporation
           Model: 82540EM Gigabit Ethernet Controller (PRO/1000 MT Desktop Adapter)
      HW Address: 08:00:27:ca:5f:a8 (PCS Systemtechnik GmbH)
         Address: 192.168.2.60
                  fe80::a00:27ff:feca:5fa8
         Gateway: 192.168.2.2
             DNS: 8.8.8.8
                  192.168.2.2

dig without @8.8.8.8 still refuses. What's missing?

Offline

#10 2018-07-18 20:15:11

seth
Member
Registered: 2012-09-03
Posts: 16,569

Re: [SOLVED] gpg ERR 167772472

You probably forgot to smylink systemd's NIH special extra resolver config to the one everyone else is using.
https://wiki.archlinux.org/index.php/Sy … CP_network

Online

#11 2018-07-18 20:22:41

Tharbad
Member
Registered: 2016-02-27
Posts: 239

Re: [SOLVED] gpg ERR 167772472

seth wrote:

You probably forgot to smylink systemd's NIH special extra resolver config to the one everyone else is using.
https://wiki.archlinux.org/index.php/Sy … CP_network

That solved it. Thanks

Offline

Board footer

Powered by FluxBB