You are not logged in.

#1 2018-07-18 20:21:11

neonb88
Member
Registered: 2018-07-18
Posts: 2

error: could not open file /mnt/var/cache/pacman/pkg/lz

Hi, I'm using the bootstrap method ( `/tmp/root.x86_64/bin/arch-chroot /tmp/root.x86_64/` ) mentioned [here](https://wiki.archlinux.org/index.php/In … g_a_chroot).  I suspect the problem is I'm not setting the mount location properly.  I've tried numerous things, but I'm a newbie.  So I'm not sure how to fix it.

Am I supposed to do `sudo mount [loc] /mnt` before or after chroot?  I did it before AND after, but the first time I ran it I hadn't changed the mount from within chroot.  Thanks in advance for any help

  Here is some output from various commands I've tried:

[root@n-ThinkPad-T420 /]# pacman -S base


:: There are 49 members in group base:
:: Repository core
   1) bash  2) bzip2  3) coreutils  4) cryptsetup  5) device-mapper  6) dhcpcd  7) diffutils  8) e2fsprogs  9) file  10) filesystem  11) findutils
   12) gawk  13) gcc-libs  14) gettext  15) glibc  16) grep  17) gzip  18) inetutils  19) iproute2  20) iputils  21) jfsutils  22) less  23) licenses
   24) linux  25) logrotate  26) lvm2  27) man-db  28) man-pages  29) mdadm  30) nano  31) netctl  32) pacman  33) pciutils  34) perl  35) procps-ng
   36) psmisc  37) reiserfsprogs  38) s-nail  39) sed  40) shadow  41) sysfsutils  42) systemd-sysvcompat  43) tar  44) texinfo  45) usbutils
   46) util-linux  47) vi  48) which  49) xfsprogs

Enter a selection (default=all): 
warning: bash-4.4.023-1 is up to date -- reinstalling
warning: bzip2-1.0.6-7 is up to date -- reinstalling
warning: coreutils-8.29-1 is up to date -- reinstalling
warning: cryptsetup-2.0.3-2 is up to date -- reinstalling
warning: filesystem-2018.1-2 is up to date -- reinstalling
warning: findutils-4.6.0-2 is up to date -- reinstalling
warning: gcc-libs-8.1.1+20180531-1 is up to date -- reinstalling
warning: glibc-2.27-3 is up to date -- reinstalling
warning: pacman-5.1.0-2 is up to date -- reinstalling
warning: shadow-4.5-4 is up to date -- reinstalling
warning: util-linux-2.32-3 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (58) groff-1.22.3-7  libaio-0.3.111-1  libpipeline-1.5.0-1  linux-firmware-20180606.d114732-1  mkinitcpio-24-2  mkinitcpio-busybox-1.28.4-1
              mpfr-4.0.1-1  openresolv-3.9.0-1  thin-provisioning-tools-0.7.6-1  bash-4.4.023-1  bzip2-1.0.6-7  coreutils-8.29-1  cryptsetup-2.0.3-2
              device-mapper-2.02.179-1  dhcpcd-7.0.5b-1  diffutils-3.6-1  e2fsprogs-1.44.3-1  file-5.33-3  filesystem-2018.1-2  findutils-4.6.0-2
              gawk-4.2.1-1  gcc-libs-8.1.1+20180531-1  gettext-0.19.8.1-2  glibc-2.27-3  grep-3.1-1  gzip-1.9-1  inetutils-1.9.4-5  iproute2-4.17.0-1
              iputils-20161105.1f2bb12-2  jfsutils-1.1.15-5  less-530-1  licenses-20171006-1  linux-4.17.6-1  logrotate-3.14.0-1  lvm2-2.02.179-1
              man-db-2.8.3-2  man-pages-4.16-1  mdadm-4.0-1  nano-2.9.8-1  netctl-1.17-1  pacman-5.1.0-2  pciutils-3.6.1-1  perl-5.26.2-2
              procps-ng-3.3.15-1  psmisc-23.1-1  reiserfsprogs-3.6.27-1  s-nail-14.9.10-1  sed-4.5-1  shadow-4.5-4  sysfsutils-2.1.0-10
              systemd-sysvcompat-239.0-2  tar-1.30-1  texinfo-6.5-1  usbutils-010-1  util-linux-2.32-3  vi-1:070224-3  which-2.21-2
              xfsprogs-4.17.0-1

Total Download Size:   212.93 MiB
Total Installed Size:  723.39 MiB
Net Upgrade Size:      477.02 MiB

:: Proceed with installation? [Y/n] y
error: could not determine cachedir mount point /var/cache/pacman/pkg
error: failed to commit transaction (not enough free disk space)
Errors occurred, no packages were upgraded.
pacstrap /mnt base




==> Creating install root at /mnt
==> Installing packages to /mnt
warning: option --root is deprecated; use --sysroot instead
:: Synchronizing package databases...
 core is up to date
 extra                                                           1650.6 KiB   651K/s 00:03 [####################################################] 100%
 community                                                          4.5 MiB  2.00M/s 00:02 [####################################################] 100%
:: There are 49 members in group base:
:: Repository core
   1) bash  2) bzip2  3) coreutils  4) cryptsetup  5) device-mapper  6) dhcpcd  7) diffutils  8) e2fsprogs  9) file  10) filesystem  11) findutils
   12) gawk  13) gcc-libs  14) gettext  15) glibc  16) grep  17) gzip  18) inetutils  19) iproute2  20) iputils  21) jfsutils  22) less  23) licenses
   24) linux  25) logrotate  26) lvm2  27) man-db  28) man-pages  29) mdadm  30) nano  31) netctl  32) pacman  33) pciutils  34) perl  35) procps-ng
   36) psmisc  37) reiserfsprogs  38) s-nail  39) sed  40) shadow  41) sysfsutils  42) systemd-sysvcompat  43) tar  44) texinfo  45) usbutils
   46) util-linux  47) vi  48) which  49) xfsprogs

Enter a selection (default=all): 
resolving dependencies...
looking for conflicting packages...

Packages (133) acl-2.2.53-1  archlinux-keyring-20180627-1  argon2-20171227-3  attr-2.4.48-1  ca-certificates-20170307-1
               ca-certificates-cacert-20140824-4  ca-certificates-mozilla-3.38-1  ca-certificates-utils-20170307-1  cracklib-2.9.6-1  curl-7.61.0-1
               db-5.3.28-4  dbus-1.12.8-1  expat-2.2.5-1  gdbm-1.16-1  glib2-2.56.1-1  gmp-6.1.2-1  gnupg-2.2.9-1  gnutls-3.5.19-1  gpgme-1.11.1-1
               groff-1.22.3-7  hwids-20180518-1  iana-etc-20180221-1  iptables-1.6.2-2  json-c-0.13.1-1  kbd-2.0.4-1  keyutils-1.5.10-2  kmod-25-1
               krb5-1.16.1-1  libaio-0.3.111-1  libarchive-3.3.2-2  libassuan-2.5.1-1  libcap-2.25-1  libcap-ng-0.7.9-1  libelf-0.171-1
               libffi-3.2.1-2  libgcrypt-1.8.3-1  libgpg-error-1.32-1  libidn-1.34-2  libidn2-2.0.5-1  libksba-1.3.5-1  libldap-2.4.46-1
               libmnl-1.0.4-1  libnftnl-1.1.1-1  libnghttp2-1.32.0-1  libnl-3.4.0-1  libpcap-1.8.1-2  libpipeline-1.5.0-1  libpsl-0.20.2-1
               libsasl-2.1.26-13  libseccomp-2.3.3-1  libsecret-0.18.6-1  libssh2-1.8.0-2  libsystemd-239.0-2  libtasn1-4.13-1  libtirpc-1.0.3-2
               libunistring-0.9.10-1  libusb-1.0.22-1  libutil-linux-2.32-3  linux-api-headers-4.16.1-1  linux-firmware-20180606.d114732-1
               lz4-1:1.8.2-2  mkinitcpio-24-2  mkinitcpio-busybox-1.28.4-1  mpfr-4.0.1-1  ncurses-6.1-3  nettle-3.4-1  npth-1.6-1  openresolv-3.9.0-1
               openssl-1.1.0.h-1  p11-kit-0.23.12-1  pacman-mirrorlist-20180710-1  pam-1.3.1-1  pambase-20171006-1  pcre-8.42-1  pcre2-10.31-1
               pinentry-1.1.0-4  popt-1.16-9  readline-7.0.005-1  sqlite-3.24.0-1  systemd-239.0-2  thin-provisioning-tools-0.7.6-1  tzdata-2018e-1
               xz-5.2.4-1  zlib-1:1.2.11-2  bash-4.4.023-1  bzip2-1.0.6-7  coreutils-8.29-1  cryptsetup-2.0.3-2  device-mapper-2.02.179-1
               dhcpcd-7.0.5b-1  diffutils-3.6-1  e2fsprogs-1.44.3-1  file-5.33-3  filesystem-2018.1-2  findutils-4.6.0-2  gawk-4.2.1-1
               gcc-libs-8.1.1+20180531-1  gettext-0.19.8.1-2  glibc-2.27-3  grep-3.1-1  gzip-1.9-1  inetutils-1.9.4-5  iproute2-4.17.0-1
               iputils-20161105.1f2bb12-2  jfsutils-1.1.15-5  less-530-1  licenses-20171006-1  linux-4.17.6-1  logrotate-3.14.0-1  lvm2-2.02.179-1
               man-db-2.8.3-2  man-pages-4.16-1  mdadm-4.0-1  nano-2.9.8-1  netctl-1.17-1  pacman-5.1.0-2  pciutils-3.6.1-1  perl-5.26.2-2
               procps-ng-3.3.15-1  psmisc-23.1-1  reiserfsprogs-3.6.27-1  s-nail-14.9.10-1  sed-4.5-1  shadow-4.5-4  sysfsutils-2.1.0-10
               systemd-sysvcompat-239.0-2  tar-1.30-1  texinfo-6.5-1  usbutils-010-1  util-linux-2.32-3  vi-1:070224-3  which-2.21-2
               xfsprogs-4.17.0-1

Total Download Size:     0.32 MiB
Total Installed Size:  862.34 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
error: could not open file /mnt/var/cache/pacman/pkg/lz4-1:1.8.2-2-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/lz4-1:1.8.2-2-x86_64.pkg.tar.xz.part: Invalid argument
warning: failed to retrieve some files
error: could not open file /mnt/var/cache/pacman/pkg/zlib-1:1.2.11-2-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/zlib-1:1.2.11-2-x86_64.pkg.tar.xz.part: Invalid argument
warning: failed to retrieve some files
error: could not open file /mnt/var/cache/pacman/pkg/vi-1:070224-3-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/vi-1:070224-3-x86_64.pkg.tar.xz.part: Invalid argument
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.
==> ERROR: Failed to install packages to new root

System info:

> uname -a

Linux n-ThinkPad-T420 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 08:53:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Last edited by neonb88 (2018-07-18 21:58:42)

Offline

#2 2018-07-18 20:25:58

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,112
Website

Re: error: could not open file /mnt/var/cache/pacman/pkg/lz

Please use code tags when pasting to the boards: https://wiki.archlinux.org/index.php/Co … s_and_code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2018-07-18 21:59:08

neonb88
Member
Registered: 2018-07-18
Posts: 2

Re: error: could not open file /mnt/var/cache/pacman/pkg/lz

Thanks, looks much better

Offline

#4 2018-08-14 07:10:29

Macore
Member
Registered: 2018-08-14
Posts: 2

Re: error: could not open file /mnt/var/cache/pacman/pkg/lz

I've been having the same problems the last few days. I went to create a quick Arch box while at DefCon and I am getting the same 'Invalid Argument' errors. I have tried using pacstrap from Arch Live CD, Black Arch Live CD, and an existing Arch install and all get the same error for the base package:

error: could not open file /mnt/var/cache/pacman/pkg/vi-1:070224-3-x86_64.pkg.tar.xz.part: Invalid argument

Other ones I've seen:

error: could not open file /mnt/var/cache/pacman/pkg/libshout-1:2.4.1-3-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/libspiro-1:0.5.20150702-2-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/redland-1:1.0.17-4-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/rasqal-1:0.9.33-2-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/ffmpeg-1:4.0.2-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/libx264-2:152.20171224-2-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/gnome-desktop-1:3.28.2-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/gjs-1:1.52.3-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/cantarell-fonts-1:0.101-1-any.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/gnome-desktop-1:3.28.2-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/librsvg-2:2.42.6-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/graphite-1:1.3.11-1-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/minizip-1:1.2.11-3-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/grub-2:2.02-7-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/zlib-1:1.2.11-3-x86_64.pkg.tar.xz.part: Invalid argument
error: could not open file /mnt/var/cache/pacman/pkg/lz4-1:1.8.2-2-x86_64.pkg.tar.xz.part: Invalid argument

Now a little background -- I was just trying to make a quick bootable Arch USB. Since I have to use Windows mainly, and they can't always read Ext2 or better, I was going for FAT32 for the USB drive so I could use it on either platform and transfer files. These all seem to break when using FAT

mkfs.fat -F 32 /dev/sdxy

The solution? Use EXT2. Worked for me.
I am curious why this is happening. I'll test some other partition types, I haven't had time since I just figured it out while writing this reply. I wonder if exFAT will work, too... I guess I'll know in a few. Let me know if this helped.

And hello all, long time listener, first time poster.

--Macore

Offline

#5 2018-08-14 07:14:15

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,367

Re: error: could not open file /mnt/var/cache/pacman/pkg/lz

All those files that had problems had a ':' in the filename which is probably an illegal character in a FAT filename

Offline

#6 2018-08-14 07:28:43

Macore
Member
Registered: 2018-08-14
Posts: 2

Re: error: could not open file /mnt/var/cache/pacman/pkg/lz

Ahha... yeah that'd do it

Offline

Board footer

Powered by FluxBB