You are not logged in.

#1 2018-07-24 11:26:11

ANx
Member
Registered: 2018-07-21
Posts: 4

sp5100-tco: Watchdog hardware is disabled

Hello Everyone,

I'm getting the following error from dmesg:

[    5.767923] sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver
[    5.768018] sp5100-tco sp5100-tco: Using 0xfed80b00 for watchdog MMIO address
[    5.768029] sp5100-tco sp5100-tco: Watchdog hardware is disabled

I already searched for such/similar parameter on my UEFI/BIOS settings and no luck. I'm using AMD Ryzen 7 2700 + ASUS ROG Strix x470-I. To be honest, I have no clue what this is related with.

Have you seem this before?

Regards,
ANX

Last edited by ANx (2018-07-24 14:09:55)

Offline

#2 2018-07-24 15:00:59

ANx
Member
Registered: 2018-07-21
Posts: 4

Re: sp5100-tco: Watchdog hardware is disabled

According to https://community.amd.com/thread/230025, if I understand correctly, Watchdog functionality is only available for motherboards that are IPMI compliant, that is not the case of ASUS ROG Strix x470-I - the one I have. I proceeded by simple disabling this kernel module from loading.

# cat << EOF > /etc/modprobe.d/sp5100_tco.conf 
blacklist sp5100_tco
EOF

Still not confident that I proceeded correctly, so I would appreciate someone’s opinion on the findings and blacklisting solution.

Last edited by ANx (2018-07-27 14:56:29)

Offline

#3 2018-07-29 01:00:09

WFV
Member
From: right here right now ℶ
Registered: 2013-04-23
Posts: 243

Re: sp5100-tco: Watchdog hardware is disabled

If it works then you proceeded correctly. What does the log show after reboot? If it's not working try blacklisting in the kernel parameters.
Otherwise dmseg appears to record the module loads and finds its hardware disabled.

EDIT1: kernel parameters (blacklisting) link

Last edited by WFV (2018-10-23 18:33:16)

Offline

#4 2018-10-15 11:48:32

ANx
Member
Registered: 2018-07-21
Posts: 4

Re: sp5100-tco: Watchdog hardware is disabled

Thanks for your reply, the solution was really blacklisting it since my motherboard is not IPMI compliant.

WFV wrote:

If it works then you proceeded correctly. What does the log show after reboot? If it's not working try blacklisting in the kernel parameters.
Otherwise dmseg appears to record the module loads and finds its hardware disabled.

Offline

#5 2019-03-09 16:25:11

webcapcha
Member
Registered: 2019-02-14
Posts: 18

Re: sp5100-tco: Watchdog hardware is disabled

I have similar logs, so I added the same blacklist in /etc/modprobe.d/sp5100_tco.conf
But since that desktop shutting down about 20-30 seconds.

Is it supposed to be so?

Offline

Board footer

Powered by FluxBB