You are not logged in.

#1 2006-08-09 13:03:45

huz
Member
Registered: 2006-08-09
Posts: 11

xfce doesn't start, gnome too

hi there,
i'm new here and I'm also new on archlinux wink

I've recently bougth an Athlon 64 3000+ and I want to use a 64bit distro to run calculus programs as Octave (never used calculus programs under linux, but I presume that they are faster than other appz on win/linux 32bit)

I've installed base system through CD, and with Pacman I downloaded nvidia drivers and configured X11 by XF86Config file, i think that there are no errors here.

I read italian/english tutorials for install xfce4-svn, and with pacman I do all... but when I type startx... It seems to start but few second later: 

/opt/xfce4/bin/xfce4-session: no such file or directory

/opt/xfce4/bin/xfce4-session: Success!

waiting for X server to shut down FreefontPath: FPE "usr/share/fonts/misc"
refcount is 2, should be 1; fixing

root@liquid /: #

if I type xfce4-session:

/opt/xfce4/etc/xdg/xfce4/xinitrc: line 49: /opt/xfce4/bin/xfce4-session: No such file or directory

so I downloaded gnome and gnome-extra, added some daemons as tutorial, but when I type gnome-session:

gnome-session: error while loading shared libraries: libcairo2.so.2: wrong ELF class: ELFCLASS32

here there are problems with 64bit?

where I do wrong?
thanks in advance

Offline

#2 2006-08-09 14:48:24

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: xfce doesn't start, gnome too

No. Xfce is fine here. No errors were reported for Gnome.

For Xfce4 just type "startxfce4". It will probably give you better error messages. Check your /var/log/Xorg.0.log! I guess you haven't installed all needed packages. Same for Gnome. I run Xfce  and use kdm without any problems.

Anyway this is not 64bit related.

Offline

#3 2006-08-09 15:03:29

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: xfce doesn't start, gnome too

I have experienced this problem. I cannot quite remember how I resolved it.


What the beep was that?

Offline

#4 2006-08-09 16:56:28

huz
Member
Registered: 2006-08-09
Posts: 11

Re: xfce doesn't start, gnome too

thanks for answers, important is that is not 64bit related issue.

here in italy, all are good but no one can help you... smile
Thanks a lot, I'll check xorg.0.log

Offline

#5 2006-08-09 17:46:00

huz
Member
Registered: 2006-08-09
Posts: 11

Re: xfce doesn't start, gnome too

in the log i have only warnings about monitor EDID and xorg sets 75 dpi instead higher values, i think.

it seems all ok.

if i type startxfce4 i get this error:

Agent pid 2642
/opt/xfce4/etc/xdg/xfce4/xinitrc: line 49: /opt/xfce4/bin/xfce4-session: No such file or directory
Agent pid 2642 killed

i'm doing a reinstall of xfce but i think that will not work

Offline

#6 2006-08-09 17:48:26

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: xfce doesn't start, gnome too

I think it is a 64 bit issue. I would suggest uninstalling xfce4 and key bits of gnome; and then reinstalling. E.g. try running gmone with xfce4 temporarily uninstalled.

I did something like this to fix my system. I reckon there is a configuration file that gets bady written at some stages.

Remember, that gnome and xfce4 seem to have some overlapping features; and I guess something overlaps adversely!

Geoff


What the beep was that?

Offline

#7 2006-08-09 18:02:01

huz
Member
Registered: 2006-08-09
Posts: 11

Re: xfce doesn't start, gnome too

I'll try immediately...
also kde wont start sad

edit: kde running
I presume that I'll stay ok KDE for now

Offline

#8 2006-08-09 19:58:35

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: xfce doesn't start, gnome too

huz wrote:

/opt/xfce4/etc/xdg/xfce4/xinitrc: line 49: /opt/xfce4/bin/xfce4-session: No such file or directory
Agent pid 2642 killed

Try to "touch /opt/xfce4/bin/xfce4-session" ;-)

Offline

#9 2006-08-10 00:02:20

huz
Member
Registered: 2006-08-09
Posts: 11

Re: xfce doesn't start, gnome too

AndyRTR wrote:
huz wrote:

/opt/xfce4/etc/xdg/xfce4/xinitrc: line 49: /opt/xfce4/bin/xfce4-session: No such file or directory
Agent pid 2642 killed

Try to "touch /opt/xfce4/bin/xfce4-session" ;-)

the file points to this path,
I look into this dir, and the file xfce4-session exists, but if I type: xfce4-session

no such file or directory sad
the file exist! I do not understand how linux works tongue

Anyway, on KDE firefox doesn't start, gaim doesn't start, nvidia control panel doesn't start. mmh... good tongue

Offline

#10 2006-08-10 01:15:23

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: xfce doesn't start, gnome too

Try to "touch /opt/xfce4/bin/xfce4-session" Wink

Inside a terminal (xterm or konsole or whatever) and after the # prompt enter

"touch /opt/xfce4/bin/xfce4-session".

You need to do this as root, I think.

HTH

BTW. "touch" is a command. Have a look at $ man touch. Yeah, I've learnt about linux and unix over about three years.


What the beep was that?

Offline

#11 2006-08-10 07:48:12

huz
Member
Registered: 2006-08-09
Posts: 11

Re: xfce doesn't start, gnome too

I'm sorry, I didn't know about it. thanks, I'll try after lunch.
Thanks a lot to all!

Offline

#12 2006-08-10 09:44:07

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: xfce doesn't start, gnome too

Another option, in this situation, is building another arch64 partition and leaving your present one in abeyance. This is a good way to learn, too.

You can make a separate partition for /var/abs/pacman and copy into it the contents of the "old" /var/abs/pacman/pkg. You then go into /etc/fstab and mount that partition.

e.g. /dev/sda8 /var/cache/pacman reiserfs defaults 0 0
 
This would help with having the pkg's onboard, rather than downloading them all over again.

OK, I am really going off topic, because this is "new user" stuff. But again, arch64 is not quite as robust as arch32.

Geoff


What the beep was that?

Offline

Board footer

Powered by FluxBB