You are not logged in.

#1 2018-08-23 18:04:22

kyiami
Member
Registered: 2018-08-23
Posts: 9

[SOLVED] Dropped into emergency shell after trying to install Arch

So I'm having some problems with installing Arch Linux on my computer. I've been following the official tutorial, but every time I boot up I get an error. I don't get the same screen I've seen in other Arch installs: mine just gives me two options:

Arch Linux

and

Reboot into firmware interface

(although I don't know if that has to do with anything). When I select the Arch Linux option, it spits out these lines:

: : running early hook [udev]
starting version 239
: : running hook [udev]
: : Triggering uevents. . .
Waiting 10 seconds for device /dev/disk/by-uuid/214856c5-6dfa-40d0-b528-9cac4de7d227 . . . 
ERROR: device 'UUID=214856c5-6dfa-40d0-b528-9cac4de7d227' not found. Skipping fsk.
: : mounting 'UUID=214856c5-6dfa-40d0-b528-9cac4de7d227' on real root
You are now being dropped into an emergency shell. 
sh: can't access tty; job control turned off
[rootfs ]#

Now, I have no clue what I'm doing wrong. I verified that it was on UEFI with

ls /sys/firmware/efi/efivars

, set up wifi with

wifi-menu

, and set the clock with

timedatectl set-ntp true

.
I then formatted the disk with fdisk, making a 1G EFI System partition, an 80G partition, a 2G swap partition (type: linux swap) and a 155G partiton for home. My commands for that were as follows:

fdisk /dev/nvme0n1
g
n
default
default
+1G
y
type
1
n
default
default
+80G
y
n
default
default
+2G
type
default
19
n
default
default
default
w

I then formatted my 1G partition with

mkfs.vfat -F32 /dev/nvme0n1p1

. After that, I formatted my 60G and 155G with

mkfs.ext4 /dev/nvme0n1p2

and

mkfs.ext4 /dev/nvme0n1p4

I then did

mkswap /dev/nvme0n1p3

to my 2G swap partition.
Then I got into the mounting part. I mounted my 60G drive at /mnt, and my 1G at boot and my 155G at home.

mount /dev/nvme0n1p2 /mnt
mkdir /mnt/boot
mkdir /mnt/home
mount /dev/nvme0n1p1 /mnt/boot
mount /dev/nvme0n1p4 /mnt/home

Then I did

swapon /dev/nvme0n1p3

.
I edited my mirrorlist to prioritize closer mirrors geographically, and saved it with

nano /etc/pacman.d/mirrorlist

. Then I pulled down packages with

pacstrap /mnt base

.
Once those finished, I genfstab -U /mnt >> /mnt/etc/fstab and checked it to make sure the UUIDs were correct. I arch-chroot /mnt then set the clock:

ln -sf /usr/share/zoneinfo/America/Los_Angeles /etc/localtime

and

hwclock --systohc

Then I

nano /etc/locale.gen

and uncommented en_US.UTF-8 UTF-8.
I created a file called locale.conf nano /etc/locale.conf and added 'LANG=en_US.UTF-8' to it.
I set my hostname by going to

nano /etc/hostname

and putting my hostname in that file.
I then

nano /etc/hosts

and added '

127.0.0.1 localhost
::1 localhost
127.0.1.1 myhostname.localdomain myhostname

' to hosts. Then I set the password with

passwd

.
Now, I looked at the bootloader list and thought that systemd-boot would be the easiest to configure. My commands for installing it were

bootctl --path=/boot install
nano /boot/loader/loader.conf

(where I replaced everything with '

default arch
timeout 4
editor no

'
I might want to mention that I commented out a line that looked like

default 595e7481f9164634a52f72307508e37c-*

I installed intel-ucode with

pacman -S intel-ucode

. Then I nanoed

nano /boot/loader/entries/arch.conf

and created a file with the following lines: '

title Arch Linux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root=UUID=214856c5-6dfa-40d0-b528-9cac4de7d227 rw

'
After all that, I exited out with exit and rebooted. My computer gave me the error at the top of this post. I was adviced to run mount /dev/nvme0n1p2 /new_root and then ^D which promptly gave me a kernel panic.
I have no clue what's going wrong. Could any of you help me?


EDIT: just learned i don't need code /code on every line

Last edited by kyiami (2018-08-31 23:35:20)

Offline

#2 2018-08-23 18:12:09

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,131
Website

Re: [SOLVED] Dropped into emergency shell after trying to install Arch

Boot from the live media, chroot in and compare the output of `blkid` with your arch.conf options entry.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2018-08-23 20:01:42

InternetUnexplorer
Member
Registered: 2018-08-23
Posts: 1

Re: [SOLVED] Dropped into emergency shell after trying to install Arch

As mentioned on the systemd-boot wiki page:

The root partition can be identified with its LABEL or its PARTUUID.

Try changing "UUID" to "PARTUUID" in your arch.conf, and see if that works:

options root=PARTUUID=214856c5-6dfa-40d0-b528-9cac4de7d227

Offline

#4 2018-08-24 02:20:04

kyiami
Member
Registered: 2018-08-23
Posts: 9

Re: [SOLVED] Dropped into emergency shell after trying to install Arch

jasonwryan wrote:

Boot from the live media, chroot in and compare the output of `blkid` with your arch.conf options entry.

They are the same.

Offline

#5 2018-08-24 03:50:47

kyiami
Member
Registered: 2018-08-23
Posts: 9

Re: [SOLVED] Dropped into emergency shell after trying to install Arch

InternetUnexplorer wrote:

As mentioned on the systemd-boot wiki page:

The root partition can be identified with its LABEL or its PARTUUID.

Try changing "UUID" to "PARTUUID" in your arch.conf, and see if that works:

options root=PARTUUID=214856c5-6dfa-40d0-b528-9cac4de7d227

I changed UUID to PARTUUID and set it to the output of

blkid -s PARTUUID -o value /dev/nvme0n1p2

. That seemed to have fixed it!

Offline

Board footer

Powered by FluxBB