You are not logged in.

#1 2018-08-28 07:34:25

MafiaInc
Member
From: Sofia, Bulgaria
Registered: 2016-11-25
Posts: 7
Website

Keyboard settings or notably "repeat" settings are discard after ssh

Hello,

Really wired and strange issue. When I run a specific ssh command to make a local port forwarding via ssh: "ssh -f -N -L 10.0.0.1:57843:192.168.100.100:9091 -i /some/private/key username@10.0.0.1 -p 57843" (NOTE: The target address is created via tuntap in tun mode if that matters.)
So when I run this command immediately after that I lose some KDE keyboard settings, notably "keyboard repeat" stops working. So I have to run "kcmshell5 kcm_keyboard" and turn off and on keyboard repeat settings and apply.

First I thought it happens randomly and later I realized it's connected to this command that I execute on a daily basis to achieve this port forwarding at my office. I don't even know what KDE process to debug in order to help with catching this issue, I tired to change the port I'm using for listening, no change. It been a long time since this issue appeared, and I don't even hope anymore that it would get fixed through the regular updates. I couldn't find such or similar bug reported before, I would like to first get feedback here before attempting to submit a bug report about it. This happens on my desktop machine which was installed about two years ago with Arch. I make updates every day so I'm up to the recent versions of all packages, currently with 4.18.5-arch1-1-ARCH kernel.

Cheers,
Martin


-- Me not hungry

Offline

#2 2018-08-28 08:09:15

seth
Member
Registered: 2012-09-03
Posts: 8,473

Re: Keyboard settings or notably "repeat" settings are discard after ssh

"xkbset r"?
Why an ssh command would impact your keyboard repetition is beyond me, though. The only thing I could imagine is that there's some reset on the USB, re-adding the keyboard? Check dmesg & xorg log.

Offline

#3 2018-08-28 16:57:28

MafiaInc
Member
From: Sofia, Bulgaria
Registered: 2016-11-25
Posts: 7
Website

Re: Keyboard settings or notably "repeat" settings are discard after ssh

You are right "xkbset r" works for enabling the repeat settings again, now I cant do && xkbset r after the ssh command. Thanks for that hint! Beside that unfortunately there is nothing in Xorg.0.log nor in dmesg. Still looking for a way how to catch that, may be I cold run strace or something (dbus-monitor, looking for something specific?) on the process responsible for that setting if you know which one is it (I'm using Plasma 5.13.4 and KDE Framework 5.49.0?, Xorg server : 1.20.1-1)?


-- Me not hungry

Offline

#4 2018-08-28 18:53:14

seth
Member
Registered: 2012-09-03
Posts: 8,473

Re: Keyboard settings or notably "repeat" settings are discard after ssh

Any process could trigger that - it's ultimately a feature of the X11 server that all GUI clients talk to.
I'd try a different terminal emulator (guessing you're using konsole? Try eg. xterm) to isolate the culprit., but I've really no idea why or how ssh would impact X11.

Offline

#5 2018-09-25 11:58:52

MafiaInc
Member
From: Sofia, Bulgaria
Registered: 2016-11-25
Posts: 7
Website

Re: Keyboard settings or notably "repeat" settings are discard after ssh

Some update:
I found that this keyboard repeat blocking comes from ForwardX11 option. So if I disable that "-x" my settings remain unchanged. It seems like my X Server is inheriting some settings from the remote X11 Server. Is there a way I could selectively stop that?


-- Me not hungry

Offline

#6 2018-09-25 14:39:35

seth
Member
Registered: 2012-09-03
Posts: 8,473

Re: Keyboard settings or notably "repeat" settings are discard after ssh

It's less "inheriting"; there's no remote X11 server, resp. it's completely irrelevant - you allow remote X11 clients to talk to your local X11 server.
Some remote X11 client will make this call, ie. if you'd remotely call "xkbset -r", that would turn off the autorepeat on your local display server - of course it doesn't have to be something as stupid as such call in some remote login script, but from your OP it would seem that something X11 related is executed on the remote login automatically. That something™ will alter your keyboard settings.

Offline

Board footer

Powered by FluxBB