You are not logged in.

#1 2018-09-07 23:13:59

Lumpiasty
Member
Registered: 2018-07-27
Posts: 6

[SOLVED] TP-Link WN-951N MAC changes every reboot

Hi!
I just installed TP-Link WN-951N WiFi card to my Arch Linux router wanting to "include" access point in it. At first i had trouble when starting hostapd, but when I was trying to fix it (I can temporarily resolve this by executing rfkill unblock wlan) I noticed something strange: after reboot MAC of WiFi card changed. I updated that configuration file, but after rebooting it happened again. And it does every time. Before reboot:

wlp14s7: unavailable
        "Qualcomm Atheros AR922X"
        wifi (ath9k), DA:9F:92:9B:CD:53, hw, mtu 1500

After reboot:

wlp14s7: unavailable
        "Qualcomm Atheros AR922X"
        wifi (ath9k), 1A:F7:FD:65:27:9B, hw, mtu 1500

So my question is: What the ....? I haven't ever tried to use any of MAC changing tools on this PC. Thanks in advance for help

Last edited by Lumpiasty (2018-09-09 20:08:39)

Offline

#2 2018-09-08 01:02:08

progandy
Member
Registered: 2012-05-17
Posts: 3,182

Re: [SOLVED] TP-Link WN-951N MAC changes every reboot

NetworkManager may do it
https://wiki.archlinux.org/index.php/Ne … domization

Try to use the mac you can get with ethtool or boot with networkmanager completely disabled to get the original mac.

ethtool -P wlp14s7

Edit: Or try to use "interface-name:wlp14s7" instead of "mac:..." to ignore the device.

Last edited by progandy (2018-09-08 01:08:53)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2018-09-09 20:08:23

Lumpiasty
Member
Registered: 2018-07-27
Posts: 6

Re: [SOLVED] TP-Link WN-951N MAC changes every reboot

I'll use "interface-name:wlp14s7" trick.
I noticed it also stopped randomizing MAC, so it had to be NetworkManager.

Problem solved, thanks for your help.

Offline

Board footer

Powered by FluxBB