You are not logged in.

#1 2006-08-13 09:37:35

Pajaro
Member
Registered: 2004-04-21
Posts: 876

eth0 and eth1 switched on every reboot

Hi,

I have 2 network cards. One that comes with the mobo which is connected to the internet and another one that I use to share my internet connection.

My problem: when I reboot, randomly eth0 and eth1 get switched: now eth0 is the mobo card, and now it is the pci card.

How can I avoid this issue? or, if not, how can I make the initscripts to set the configurations to the appropiated cards based on the actual device name instead on eth0 and eth1 (also iptables).

You may need this information: I have to use the kernel26-fallback.img to have the kernel recognizing my hds.

Thank you.

Offline

#2 2006-08-13 09:47:24

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: eth0 and eth1 switched on every reboot

Hi

You must write the modules for the cards in the moduls Array in rc.conf, in the order you will have, eg first the modul for eth0 ...

MODULES=(nvram ibm_acpi speedstep-centrino cpufreq-ondemand ipw3945)


Have you tried to turn it off and on again?

Offline

#3 2006-08-13 15:24:30

Pajaro
Member
Registered: 2004-04-21
Posts: 876

Re: eth0 and eth1 switched on every reboot

Thank you,

i am going to try

Offline

#4 2006-08-13 17:35:56

Pajaro
Member
Registered: 2004-04-21
Posts: 876

Re: eth0 and eth1 switched on every reboot

that didn't work, but it seems that the random behaivour is stable now. So by now i can keep on work

Offline

#5 2006-08-13 17:39:23

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: eth0 and eth1 switched on every reboot

Pajaro wrote:

that didn't work, but it seems that the random behaivour is stable now. So by now i can keep on work

:shock:  normally, this must work


Have you tried to turn it off and on again?

Offline

#6 2006-08-13 17:43:16

Pajaro
Member
Registered: 2004-04-21
Posts: 876

Re: eth0 and eth1 switched on every reboot

O_O then... hmm ...solved?

Offline

#7 2006-08-13 19:23:54

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: eth0 and eth1 switched on every reboot

If it's not solved, this might help:
http://wiki.archlinux.org/index.php/Ude … _Each_Boot

Offline

#8 2006-08-13 19:52:05

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: eth0 and eth1 switched on every reboot

Um.. if the random behavior is stable now, doesn't that mean it worked?


I am a gated community.

Offline

#9 2006-08-13 19:59:35

Pajaro
Member
Registered: 2004-04-21
Posts: 876

Re: eth0 and eth1 switched on every reboot

only if changes stay there after removing them O_o

Offline

Board footer

Powered by FluxBB