You are not logged in.

#1 2018-09-14 23:53:01

discord
Member
Registered: 2013-02-06
Posts: 7

using pip from archlinux : No module named 'pkg_resources'

I recently wanted to install a python package via pip, specifically presto-python-client. Then I installed python-pip. Then I tried installing the package:

```
pip install presto-python-client
Traceback (most recent call last):
  File "/usr/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
ModuleNotFoundError: No module named 'pkg_resources'
```

And also the same error via sudo.

Then I read elsewhere that pkg_resources was part of setup_tools so installed python-setuptools.

However I still got the same error.

Offline

#2 2018-09-15 06:20:55

yan12125
Member
Registered: 2017-11-01
Posts: 9

Re: using pip from archlinux : No module named 'pkg_resources'

You may have messed up your Python installation. Try to reinstall all Python packages, or at least python, python-setuptools and python-pip.

Offline

#3 2018-09-16 02:39:55

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,543

Re: using pip from archlinux : No module named 'pkg_resources'

It should be entirely impossible to install python-pip without having setuptools be automatically installed as a dependency...

Did you do a partial update? Do you have part of your system installed as python3.7 and part of your system held back on python3.6?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB