You are not logged in.

#1 2018-09-18 13:18:56

j1simon
Member
From: Denmark
Registered: 2016-01-28
Posts: 166

error: megasync: unsupported signature format

I have added the Megasync repository for Arch in my pacman.conf:

...
 [DEB_Arch_Extra]
SigLevel = Optional TrustAll
Server = https://mega.nz/linux/MEGAsync/Arch_Extra/$arch

But when I install/upgrade some package of that repository, pacman shows this error: "error: megasync: unsupported signature format"

It installs the package but I don't understand that error. The repository signature is downloaded:

$ sudo pacman -Sy
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 DEB_Arch_Extra                                                   4,2 KiB  1040K/s 00:00 [###################################################] 100%
 DEB_Arch_Extra.sig                                             280,0   B  0,00B/s 00:00 [###################################################] 100%

Last edited by j1simon (2018-09-18 13:19:39)

Offline

#2 2018-09-18 15:19:53

eschwartz
Fellow
Registered: 2014-08-08
Posts: 4,097

Re: error: megasync: unsupported signature format

Do they host this somehow via the OpenSUSE Build Service? If so, the OBS "support" for pgp-signed repositories is broken.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB