You are not logged in.

#1 2018-10-24 15:04:15

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Restarting GDM

Hi! My GDM crashes and restart my session after full upgrade.

I was trying to downgrade accountsservice, but no results sad

$ systemctl status gdm.service 
● gdm.service - GNOME Display Manager
Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2018-10-24 12:18:25 CEST; 4h 33min ago
Main PID: 482 (gdm)
Tasks: 3 (limit: 4915)
Memory: 8.5M
CGroup: /system.slice/gdm.service
└─482 /usr/bin/gdm

paź 24 12:18:25 archlinux systemd[1]: Started GNOME Display Manager.
paź 24 12:18:34 archlinux gdm-autologin][598]: gkr-pam: no password is available for user
paź 24 12:18:36 archlinux gdm-autologin][598]: pam_unix(gdm-autologin:session): session opened for user piotr by (uid=0)
paź 24 12:18:37 archlinux gdm[482]: GLib-GObject: invalid unclassed pointer in cast to 'GObject'
paź 24 12:18:37 archlinux gdm[482]: GLib-GObject: g_object_add_weak_pointer: assertion 'G_IS_OBJECT (object)' failed
paź 24 12:26:18 archlinux gdm[482]: GLib-GObject: g_object_weak_unref: couldn't find weak ref 0x7f70679f7690(0x55ef037ff038)
paź 24 13:14:53 archlinux gdm-password][10834]: pam_unix(gdm-password:session): session opened for user piotr by (uid=0)
paź 24 13:16:44 archlinux gdm-password][12761]: pam_unix(gdm-password:session): session opened for user piotr by (uid=0)
paź 24 13:16:54 archlinux gdm[482]: Child process -12596 was already dead.
paź 24 16:47:17 archlinux gdm-password][2345]: pam_unix(gdm-password:session): session opened for user piotr by (uid=0)

There's a logs:
https://justpaste.it/2waxp

Last edited by Rotepi (2018-10-24 15:54:59)

Offline

#2 2018-11-03 11:35:59

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

Anybody can help me? sad

Offline

#3 2018-11-03 12:09:40

a821
Member
From: My Location
Registered: 2012-10-31
Posts: 140

Re: Restarting GDM

Well, it's been over a week... what have you tried? what have you learn from your research? what does google say?...

Please note: https://wiki.archlinux.org/index.php/Co … ct#Bumping

Offline

#4 2018-11-03 13:15:35

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Restarting GDM

I was trying to downgrade accountsservice

There's no trace of that in the pasted log.

Does it work w/o autologin?
Also "man coredumpctl" for a complete backtrace.

Offline

#5 2018-11-03 15:45:47

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

Before this i had problem with libmozjs-60.so.0. There's a link: https://bbs.archlinux.org/viewtopic.php?id=237588
I was reinstall my Linux but problem again exist
Coredumps show this:

           PID: 678 (gnome-shell)
           UID: 1000 (piotr)
           GID: 1000 (piotr)
        Signal: 11 (SEGV)
     Timestamp: Sat 2018-11-03 16:32:34 CET (9min ago)
  Command Line: /usr/bin/gnome-shell
    Executable: /usr/bin/gnome-shell
 Control Group: /user.slice/user-1000.slice/session-2.scope
          Unit: session-2.scope
         Slice: user-1000.slice
       Session: 2
     Owner UID: 1000 (piotr)
       Boot ID: fa1c2c4edf634c2b8ee3162075cc0ba5
    Machine ID: 90da6ad47aa349e786e4032ddf93a9e0
      Hostname: arch
       Storage: /var/lib/systemd/coredump/core.gnome-shell.1000.fa1c2c4edf634c2b8ee3162075cc0ba5.678.1541259154000000.lz4
       Message: Process 678 (gnome-shell) of user 1000 dumped core.
                
                Stack trace of thread 733:
                #0  0x00007fedffdbdc66 n/a (libmozjs-60.so.0)

Last edited by Rotepi (2018-11-03 15:46:54)

Offline

#6 2018-11-03 15:52:59

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Restarting GDM

That thread seems utterly unrelated, this is not a complete backtrace, you didn't elaborate on the autologin condition or the accountsservice situation and "reinstall my Linux" is no usable description of anything, since it skips "how" and whether you maintained eg. existing (3rd party) GDM extensions.

Offline

#7 2018-11-05 13:02:25

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

At this time autologin option is disabled and still GDM crash. Now i have clean Arch Linux with Gnome

Last edited by Rotepi (2018-11-05 13:03:25)

Offline

#8 2018-11-05 13:21:53

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Restarting GDM

We're still missing a complete backtrace, esp. w/o autologin.

Offline

#9 2018-11-07 10:59:34

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

My coredump file after decompressing have 700 mb of size... How can I paste it here?

Offline

#10 2018-11-07 11:40:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,799

Re: Restarting GDM

You have to post a complete backtrace not the entire dump in and of itself: https://wiki.archlinux.org/index.php/Co … _core_dump

Online

#11 2018-11-07 12:51:56

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

@V1del Thanks for help
There's a backtrace:

[piotr@arch ~]$ coredumpctl info 17364
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.
           PID: 17364 (gnome-shell)
           UID: 1000 (piotr)
           GID: 1000 (piotr)
        Signal: 11 (SEGV)
     Timestamp: Wed 2018-11-07 11:58:21 CET (1h 51min ago)
  Command Line: /usr/bin/gnome-shell
    Executable: /usr/bin/gnome-shell
 Control Group: /user.slice/user-1000.slice/session-53.scope
          Unit: session-53.scope
         Slice: user-1000.slice
       Session: 53
     Owner UID: 1000 (piotr)
       Boot ID: da996686778f49cd9beab0a1ed45c6b1
    Machine ID: 90da6ad47aa349e786e4032ddf93a9e0
      Hostname: arch
       Storage: /var/lib/systemd/coredump/core.gnome-shell.1000.da996686778f49cd9beab0a1ed>
       Message: Process 17364 (gnome-shell) of user 1000 dumped core.
                
                Stack trace of thread 17413:
                #0  0x00007fc4ca9edc66 n/a (libmozjs-60.so.0)
[piotr@arch ~]$ coredumpctl gdb 17364
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.
           PID: 17364 (gnome-shell)
           UID: 1000 (piotr)
           GID: 1000 (piotr)
        Signal: 11 (SEGV)
     Timestamp: Wed 2018-11-07 11:58:21 CET (1h 51min ago)
  Command Line: /usr/bin/gnome-shell
    Executable: /usr/bin/gnome-shell
 Control Group: /user.slice/user-1000.slice/session-53.scope
          Unit: session-53.scope
         Slice: user-1000.slice
       Session: 53
     Owner UID: 1000 (piotr)
       Boot ID: da996686778f49cd9beab0a1ed45c6b1
    Machine ID: 90da6ad47aa349e786e4032ddf93a9e0
      Hostname: arch
       Storage: /var/lib/systemd/coredump/core.gnome-shell.1000.da996686778f49cd9beab0a1ed45c6b1.17364.1541588301000000.lz4
       Message: Process 17364 (gnome-shell) of user 1000 dumped core.
                
                Stack trace of thread 17413:
                #0  0x00007fc4ca9edc66 n/a (libmozjs-60.so.0)

GNU gdb (GDB) 8.2
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/gnome-shell...(no debugging symbols found)...done.
[New LWP 17413]
[New LWP 17364]
[New LWP 17366]
[New LWP 17367]
[New LWP 17370]
[New LWP 17415]
[New LWP 17369]
[New LWP 17371]
[New LWP 18471]
[New LWP 17403]
[New LWP 17412]
[New LWP 17414]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fc4ca9edc66 in ?? () from /usr/lib/libmozjs-60.so.0
[Current thread is 1 (Thread 0x7fc4b050b700 (LWP 17413))]
(gdb) bt
#0  0x00007fc4ca9edc66 in  () at /usr/lib/libmozjs-60.so.0
#1  0x00007fc4ca9effe5 in  () at /usr/lib/libmozjs-60.so.0
#2  0x00007fc4ca9f0d24 in  () at /usr/lib/libmozjs-60.so.0
#3  0x00007fc4ca9f2698 in  () at /usr/lib/libmozjs-60.so.0
#4  0x00007fc4ca9f296e in  () at /usr/lib/libmozjs-60.so.0
#5  0x00007fc4ca9f2c5a in  () at /usr/lib/libmozjs-60.so.0
#6  0x00007fc4ca7a716c in  () at /usr/lib/libmozjs-60.so.0
#7  0x00007fc4ca7a0e0c in  () at /usr/lib/libmozjs-60.so.0
#8  0x00007fc4ca79c42a in  () at /usr/lib/libmozjs-60.so.0
#9  0x00007fc4cf488a9d in start_thread () at /usr/lib/libpthread.so.0
#10 0x00007fc4cf3b8b23 in clone () at /usr/lib/libc.so.6

Offline

#12 2018-11-07 15:46:26

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Restarting GDM

Segfaults in some private libmozjs code. Grrrrr…eat.
You'll have to build the js60 package w/ debug enabled to get a better idea about what's going on.

Are you absolutely sure this is a "clean"  installation w/o custom extensions/configs and all packages up to date? => pacman log?
Wild guess: i18n, did you set the system locale to some russian? Does it work w/ en_US.utf8?

Offline

#13 2018-11-07 17:08:05

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

5 minutes after when I complete installation GNOME my GNOME restarted session... I have set system locale set to polish UTF8 and en_US.utf8. There's a pacman.log:

[2018-11-03 13:53] [PACMAN] Running 'pacman -r /mnt -Sy --cachedir=/mnt/var/cache/pacman/pkg --noconfirm base'
[2018-11-03 13:53] [PACMAN] synchronizing package lists
[2018-11-03 13:57] [ALPM] transaction started
[2018-11-03 13:57] [ALPM] installed amd-ucode (20181018.d877533-1)
[2018-11-03 13:57] [ALPM] installed linux-api-headers (4.17.11-1)
[2018-11-03 13:57] [ALPM] installed tzdata (2018g-1)
[2018-11-03 13:57] [ALPM] installed iana-etc (20180913-1)
[2018-11-03 13:57] [ALPM] installed filesystem (2018.8-1)
[2018-11-03 13:57] [ALPM] installed glibc (2.28-5)
[2018-11-03 13:57] [ALPM] installed gcc-libs (8.2.1+20180831-1)
[2018-11-03 13:57] [ALPM] installed ncurses (6.1-4)
[2018-11-03 13:57] [ALPM] installed readline (7.0.005-1)
[2018-11-03 13:57] [ALPM] installed bash (4.4.023-1)
[2018-11-03 13:57] [ALPM] installed bzip2 (1.0.6-8)
[2018-11-03 13:57] [ALPM] installed attr (2.4.48-1)
[2018-11-03 13:57] [ALPM] installed acl (2.2.53-1)
[2018-11-03 13:57] [ALPM] installed gmp (6.1.2-1)
[2018-11-03 13:57] [ALPM] installed libcap (2.25-1)
[2018-11-03 13:57] [ALPM] installed gdbm (1.18-1)
[2018-11-03 13:57] [ALPM] installed db (5.3.28-4)
[2018-11-03 13:57] [ALPM] installed perl (5.28.0-1)
[2018-11-03 13:57] [ALPM] installed openssl (1.1.1-1)
[2018-11-03 13:57] [ALPM] installed coreutils (8.30-1)
[2018-11-03 13:57] [ALPM] installed libgpg-error (1.32-1)
[2018-11-03 13:57] [ALPM] installed libgcrypt (1.8.4-1)
[2018-11-03 13:57] [ALPM] installed lz4 (1:1.8.3-1)
[2018-11-03 13:57] [ALPM] installed xz (5.2.4-1)
[2018-11-03 13:57] [ALPM] installed libsystemd (239.2-1)
[2018-11-03 13:57] [ALPM] installed device-mapper (2.02.181-1)
[2018-11-03 13:57] [ALPM] installed popt (1.16-9)
[2018-11-03 13:57] [ALPM] installed libutil-linux (2.32.1-2)
[2018-11-03 13:57] [ALPM] installed json-c (0.13.1-2)
[2018-11-03 13:57] [ALPM] installed argon2 (20171227-3)
[2018-11-03 13:57] [ALPM] installed cryptsetup (2.0.5-1)
[2018-11-03 13:57] [ALPM] installed expat (2.2.6-1)
[2018-11-03 13:57] [ALPM] installed dbus (1.12.10-2)
[2018-11-03 13:57] [ALPM] installed libmnl (1.0.4-1)
[2018-11-03 13:57] [ALPM] installed libnftnl (1.1.1-1)
[2018-11-03 13:57] [ALPM] installed libnl (3.4.0-1)
[2018-11-03 13:57] [ALPM] installed libusb (1.0.22-1)
[2018-11-03 13:57] [ALPM] installed libpcap (1.9.0-1)
[2018-11-03 13:57] [ALPM] installed iptables (1:1.8.0-1)
[2018-11-03 13:57] [ALPM] installed zlib (1:1.2.11-3)
[2018-11-03 13:57] [ALPM] installed cracklib (2.9.6-1)
[2018-11-03 13:57] [ALPM] installed e2fsprogs (1.44.4-1)
[2018-11-03 13:57] [ALPM] installed libsasl (2.1.26-13)
[2018-11-03 13:57] [ALPM] installed libldap (2.4.46-2)
[2018-11-03 13:57] [ALPM] installed keyutils (1.5.11-1)
[2018-11-03 13:57] [ALPM] installed krb5 (1.16.1-1)
[2018-11-03 13:57] [ALPM] installed libtirpc (1.1.4-1)
[2018-11-03 13:57] [ALPM] installed pambase (20171006-1)
[2018-11-03 13:57] [ALPM] installed pam (1.3.1-1)
[2018-11-03 13:57] [ALPM] installed kbd (2.0.4-1)
[2018-11-03 13:57] [ALPM] installed kmod (25-1)
[2018-11-03 13:57] [ALPM] installed hwids (20180518-1)
[2018-11-03 13:57] [ALPM] installed libunistring (0.9.10-1)
[2018-11-03 13:57] [ALPM] installed libidn2 (2.0.5-1)
[2018-11-03 13:57] [ALPM] installed libelf (0.174-1)
[2018-11-03 13:57] [ALPM] installed libseccomp (2.3.3-1)
[2018-11-03 13:57] [ALPM] installed shadow (4.6-1)
[2018-11-03 13:57] [ALPM] installed libcap-ng (0.7.9-1)
[2018-11-03 13:57] [ALPM] installed util-linux (2.32.1-2)
[2018-11-03 13:57] [ALPM] installed pcre2 (10.32-1)
[2018-11-03 13:57] [ALPM] installed audit (2.8.4-2)
[2018-11-03 13:57] [ALPM] installed systemd (239.2-1)
[2018-11-03 13:57] [ALPM-SCRIPTLET] Initializing machine ID from random generator.
[2018-11-03 13:57] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/getty.target.wants/getty@tty1.service /usr/lib/systemd/system/remote-fs.target.
[2018-11-03 13:57] [ALPM-SCRIPTLET] :: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your
[2018-11-03 13:57] [ALPM-SCRIPTLET]    bootloader to replace sysvinit with systemd, or install systemd-sysvcompat
[2018-11-03 13:57] [ALPM] installed dhcpcd (7.0.8-1)
[2018-11-03 13:57] [ALPM] installed diffutils (3.6-1)
[2018-11-03 13:57] [ALPM] installed file (5.35-1)
[2018-11-03 13:57] [ALPM] installed findutils (4.6.0-2)
[2018-11-03 13:57] [ALPM] installed mpfr (4.0.1-1)
[2018-11-03 13:57] [ALPM] installed gawk (4.2.1-1)
[2018-11-03 13:57] [ALPM] installed pcre (8.42-1)
[2018-11-03 13:57] [ALPM] installed libffi (3.2.1-2)
[2018-11-03 13:57] [ALPM] installed glib2 (2.58.1+67+g17519e039-1)
[2018-11-03 13:57] [ALPM] installed gettext (0.19.8.1-2)
[2018-11-03 13:57] [ALPM] installed grep (3.1-1)
[2018-11-03 13:57] [ALPM] installed less (530-1)
[2018-11-03 13:57] [ALPM] installed gzip (1.9-1)
[2018-11-03 13:57] [ALPM] installed inetutils (1.9.4-5)
[2018-11-03 13:57] [ALPM] installed iproute2 (4.19.0-1)
[2018-11-03 13:57] [ALPM] installed iputils (20180629.f6aac8d-2)
[2018-11-03 13:57] [ALPM] installed jfsutils (1.1.15-6)
[2018-11-03 13:57] [ALPM] installed licenses (20171006-1)
[2018-11-03 13:57] [ALPM] installed linux-firmware (20181018.d877533-1)
[2018-11-03 13:57] [ALPM] installed mkinitcpio-busybox (1.29.3-1)
[2018-11-03 13:57] [ALPM] installed zstd (1.3.6-1)
[2018-11-03 13:57] [ALPM] installed libarchive (3.3.3-1)
[2018-11-03 13:57] [ALPM] installed mkinitcpio (25-1)
[2018-11-03 13:57] [ALPM] installed linux (4.18.16.arch1-1)
[2018-11-03 13:57] [ALPM] installed logrotate (3.14.0-1)
[2018-11-03 13:57] [ALPM] installed libaio (0.3.111-1)
[2018-11-03 13:57] [ALPM] installed thin-provisioning-tools (0.7.6-1)
[2018-11-03 13:57] [ALPM] installed lvm2 (2.02.181-1)
[2018-11-03 13:57] [ALPM] installed groff (1.22.3-7)
[2018-11-03 13:57] [ALPM] installed libpipeline (1.5.0-1)
[2018-11-03 13:57] [ALPM] installed man-db (2.8.4-1)
[2018-11-03 13:57] [ALPM] installed man-pages (4.16-2)
[2018-11-03 13:57] [ALPM] installed mdadm (4.0-1)
[2018-11-03 13:57] [ALPM] installed nano (3.1-1)
[2018-11-03 13:57] [ALPM] installed openresolv (3.9.0-1)
[2018-11-03 13:57] [ALPM] installed netctl (1.18-1)
[2018-11-03 13:57] [ALPM] installed libtasn1 (4.13-1)
[2018-11-03 13:57] [ALPM] installed p11-kit (0.23.14-1)
[2018-11-03 13:57] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/sockets.target.wants/p11-kit-server.socket /usr/lib/systemd/user/pulseaudio.socket.
[2018-11-03 15:59] [ALPM] installed pulseaudio-bluetooth (12.2-2)
[2018-11-03 15:59] [ALPM] installed gnome-bluetooth (3.28.2-1)
[2018-11-03 15:59] [ALPM] installed libplist (2.0.0+11+gec9ba8b-2)
[2018-11-03 15:59] [ALPM] installed libusbmuxd (1.0.10+13+gc724e70-1)
[2018-11-03 15:59] [ALPM] installed usbmuxd (1.1.0+28+g46bdf3e-1)
[2018-11-03 15:59] [ALPM] installed libimobiledevice (1.2.0+66+g5a85432-2)
[2018-11-03 15:59] [ALPM] installed upower (0.99.9-1)
[2018-11-03 15:59] [ALPM] installed gnome-session (3.30.1-1)
[2018-11-03 15:59] [ALPM] installed libcanberra-pulse (0.30+2+gc0620e4-1)
[2018-11-03 15:59] [ALPM] installed alsa-plugins (1.1.7-3)
[2018-11-03 15:59] [ALPM] installed pulseaudio-alsa (2-4)
[2018-11-03 15:59] [ALPM] installed geocode-glib (3.26.0-1)
[2018-11-03 15:59] [ALPM] installed libgweather (3.28.2-1)
[2018-11-03 15:59] [ALPM] installed jansson (2.11-1)
[2018-11-03 15:59] [ALPM] installed libnm (1.14.5dev+17+gba83251bb-1)
[2018-11-03 15:59] [ALPM] installed gnome-settings-daemon (3.30.1.2-1)
[2018-11-03 15:59] [ALPM] installed gnome-themes-extra (3.28-1)
[2018-11-03 15:59] [ALPM] installed libgdm (3.30.1-1)
[2018-11-03 15:59] [ALPM] installed startup-notification (0.12-5)
[2018-11-03 15:59] [ALPM] installed zenity (3.30.0-1)
[2018-11-03 15:59] [ALPM] installed libxkbcommon-x11 (0.8.2-1)
[2018-11-03 15:59] [ALPM] installed pipewire (0.2.3-1)
[2018-11-03 15:59] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/sockets.target.wants/pipewire.socket /usr/lib/systemd/user/xdg-user-dirs-update.service.
[2018-11-03 15:59] [ALPM] installed xdg-user-dirs-gtk (0.10+9+g5b7efc6-1)
[2018-11-03 15:59] [ALPM] installed cdrtools (3.02a09-1)
[2018-11-03 15:59] [ALPM] installed gtk-vnc (0.9.0-1)
[2018-11-03 15:59] [ALPM] installed libgovirt (0.3.4+45+g46288e8-1)
[2018-11-03 15:59] [ALPM] installed yajl (2.1.0-2)
[2018-11-03 15:59] [ALPM] installed numactl (2.0.12-1)
[2018-11-03 15:59] [ALPM] installed augeas (1.11.0-1)
[2018-11-03 15:59] [ALPM] installed netcf (0.2.8-4)
[2018-11-03 15:59] [ALPM] installed liburcu (0.10.1-1)
[2018-11-03 15:59] [ALPM] installed rpcbind (1.2.5-2)
[2018-11-03 15:59] [ALPM] installed glusterfs (1:5.0-2)
[2018-11-03 15:59] [ALPM] installed gperftools (2.7-1)
[2018-11-03 15:59] [ALPM] installed snappy (1.1.7-1)
[2018-11-03 15:59] [ALPM] installed leveldb (1.20-1)
[2018-11-03 15:59] [ALPM] installed xmlsec (1.2.27-1)
[2018-11-03 15:59] [ALPM] installed oath-toolkit (2.6.2-5)
[2018-11-03 15:59] [ALPM] installed ceph-libs (13.2.1-2)
[2018-11-03 15:59] [ALPM] installed libiscsi (1.18.0-1)
[2018-11-03 15:59] [ALPM] installed libvirt (4.8.0-2)
[2018-11-03 15:59] [ALPM-SCRIPTLET] >>> libvirt runs qemu from nobody:kvm by default
[2018-11-03 15:59] [ALPM-SCRIPTLET] >>> change the USER if desired in /etc/libvirt/qemu.conf
[2018-11-03 15:59] [ALPM-SCRIPTLET] >>> See https://wiki.archlinux.org/index.php/Libvirt for more info
[2018-11-03 15:59] [ALPM] installed libvirt-glib (1.0.0-1)
[2018-11-03 15:59] [ALPM] installed mtools (4.0.19-1)
[2018-11-03 15:59] [ALPM] installed virglrenderer (0.7.0-1)
[2018-11-03 15:59] [ALPM] installed seabios (1.11.0-1)
[2018-11-03 15:59] [ALPM] installed jemalloc (1:5.1.0-1)
[2018-11-03 15:59] [ALPM] installed vde2 (2.3.2-11)
[2018-11-03 15:59] [ALPM-SCRIPTLET] vde config files should be placed in /etc/vde, sample files are provided.
[2018-11-03 15:59] [ALPM-SCRIPTLET] iptables and dhcpd sample files have been installed to '/usr/share/vde2'.
[2018-11-03 15:59] [ALPM-SCRIPTLET] Merge those examples, if needed to the according config files.
[2018-11-03 15:59] [ALPM] installed celt0.5.1 (0.5.1.3-4)
[2018-11-03 15:59] [ALPM] installed spice (0.14.0-2)
[2018-11-03 15:59] [ALPM] installed libcacard (2.6.1-1)
[2018-11-03 15:59] [ALPM] installed usbredir (0.8.0-1)
[2018-11-03 15:59] [ALPM] installed qemu (3.0.0-3)
[2018-11-03 15:59] [ALPM] installed phodav (2.2-2)
[2018-11-03 15:59] [ALPM] installed spice-gtk (0.35-1)
[2018-11-03 15:59] [ALPM] installed freerdp (1:2.0.0_rc3-1)
[2018-11-03 15:59] [ALPM] installed gnome-boxes (3.30.2-1)
[2018-11-03 15:59] [ALPM] installed gcab (1.0+2+gc0947f6-1)
[2018-11-03 15:59] [ALPM] installed appstream-glib (0.7.14-1)
[2018-11-03 15:59] [ALPM] installed libpackagekit-glib (1.1.11-1)
[2018-11-03 15:59] [ALPM] installed gnome-software (3.30.5-1)
[2018-11-03 15:59] [ALPM] installed libieee1284 (0.2.11-7)
[2018-11-03 15:59] [ALPM] installed net-snmp (5.8-1)
[2018-11-03 15:59] [ALPM] installed sane (1.0.27-2)
[2018-11-03 15:59] [ALPM] installed colord-sane (1.4.3-2)
[2018-11-03 15:59] [ALPM] installed simple-scan (3.30.2-1)
[2018-11-03 15:59] [ALPM] installed python-decorator (4.3.0-2)
[2018-11-03 15:59] [ALPM] installed python-traitlets (4.3.2-2)
[2018-11-03 15:59] [ALPM] installed python-ptyprocess (0.6.0-2)
[2018-11-03 15:59] [ALPM] installed python-pexpect (4.6.0-2)
[2018-11-03 15:59] [ALPM] installed python-pickleshare (0.7.5-1)
[2018-11-03 15:59] [ALPM] installed python-pygments (2.2.0-2)
[2018-11-03 15:59] [ALPM] installed python-wcwidth (0.1.7-3)
[2018-11-03 15:59] [ALPM] installed python-prompt_toolkit (1.0.15-2)
[2018-11-03 15:59] [ALPM] installed python-parso (0.3.1-2)
[2018-11-03 15:59] [ALPM] installed python-jedi (0.13.1-1)
[2018-11-03 15:59] [ALPM] installed ipython (6.5.0-2)
[2018-11-03 15:59] [ALPM] installed libxres (1.2.0-1)
[2018-11-03 15:59] [ALPM] installed libwnck3 (3.30.0-1)
[2018-11-03 15:59] [ALPM] installed accerciser (3.22.0-3)
[2018-11-03 15:59] [ALPM] installed libmad (0.15.1b-8)
[2018-11-03 15:59] [ALPM] installed cdrdao (1.2.3-10)
[2018-11-03 15:59] [ALPM] installed dvd+rw-tools (7.1-8)
[2018-11-03 15:59] [ALPM] installed brasero (3.12.2-2)
[2018-11-03 15:59] [ALPM] installed dconf-editor (3.30.2-1)
[2018-11-03 15:59] [ALPM] installed amtk (5.0.0-1)
[2018-11-03 15:59] [ALPM] installed devhelp (3.30.1-1)
[2018-11-03 15:59] [ALPM] installed libgnome-games-support (1.4.2-1)
[2018-11-03 15:59] [ALPM] installed five-or-more (3.30.0-1)
[2018-11-03 15:59] [ALPM] installed four-in-a-row (3.28.0+3+g52208eb-1)
[2018-11-03 15:59] [ALPM] installed gtksourceview4 (4.0.3-1)
[2018-11-03 15:59] [ALPM] installed libgit2 (1:0.27.5-1)
[2018-11-03 15:59] [ALPM] installed libgit2-glib (0.26.4-3)
[2018-11-03 15:59] [ALPM] installed binutils (2.31.1-3)
[2018-11-03 15:59] [ALPM] installed gcc (8.2.1+20180831-1)
[2018-11-03 15:59] [ALPM] installed compiler-rt (7.0.0-2)
[2018-11-03 15:59] [ALPM] installed clang (7.0.0-1)
[2018-11-03 15:59] [ALPM] installed ctags (5.8-6)
[2018-11-03 16:00] [ALPM] installed docbook-xml (4.5-8)
[2018-11-03 16:00] [ALPM] installed docbook-xsl (1.79.2-4)
[2018-11-03 16:00] [ALPM] installed source-highlight (3.1.8-17)
[2018-11-03 16:00] [ALPM] installed glib2-docs (2.58.1+67+g17519e039-1)
[2018-11-03 16:00] [ALPM] installed python-lxml (4.2.5-1)
[2018-11-03 16:00] [ALPM] installed python-anytree (2.4.3-2)
[2018-11-03 16:00] [ALPM] installed gtk-doc (1.29-1)
[2018-11-03 16:00] [ALPM] installed gts (0.7.6-5)
[2018-11-03 16:00] [ALPM] installed graphviz (2.40.1-13)
[2018-11-03 16:00] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - file not found
[2018-11-03 16:00] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - file not found
[2018-11-03 16:00] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - file not found
[2018-11-03 16:00] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - file not found
[2018-11-03 16:00] [ALPM] installed noto-fonts (20181024-1)
[2018-11-03 16:00] [ALPM] installed pkgconf (1.5.4-1)
[2018-11-03 16:00] [ALPM] installed vala (0.42.2-1)
[2018-11-03 16:00] [ALPM] installed m4 (1.4.18-1)
[2018-11-03 16:00] [ALPM] installed autoconf (2.69-4)
[2018-11-03 16:00] [ALPM] installed autoconf-archive (1:2018.03.13-2)
[2018-11-03 16:00] [ALPM] installed sysprof (3.30.2-1)
[2018-11-03 16:00] [ALPM] installed ostree (2018.8-1)
[2018-11-03 16:00] [ALPM] installed xdg-dbus-proxy (0.1.0-1)
[2018-11-03 16:00] [ALPM] installed xdg-desktop-portal-gtk (1.0.2-1)
[2018-11-03 16:00] [ALPM] installed xdg-desktop-portal (1.0.3-1)
[2018-11-03 16:00] [ALPM] installed flatpak (1.0.4-1)
[2018-11-03 16:00] [ALPM] installed template-glib (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed jsonrpc-glib (3.30.1-1)
[2018-11-03 16:00] [ALPM] installed python-markupsafe (1.0-2)
[2018-11-03 16:00] [ALPM] installed python-jinja (2.10-2)
[2018-11-03 16:00] [ALPM] installed python-docutils (0.14-2)
[2018-11-03 16:00] [ALPM] installed python-sphinx_rtd_theme (0.4.1-1)
[2018-11-03 16:00] [ALPM] installed python-sphinx-alabaster-theme (0.7.11-2)
[2018-11-03 16:00] [ALPM] installed python-pytz (2018.7-1)
[2018-11-03 16:00] [ALPM] installed python-babel (2.6.0-2)
[2018-11-03 16:00] [ALPM] installed python-snowballstemmer (1.2.1-3)
[2018-11-03 16:00] [ALPM] installed python-imagesize (1.1.0-1)
[2018-11-03 16:00] [ALPM] installed python-sphinxcontrib-websupport (1.1.0-2)
[2018-11-03 16:00] [ALPM] installed python-sqlalchemy (1.2.13-1)
[2018-11-03 16:00] [ALPM] installed python-whoosh (2.7.4-3)
[2018-11-03 16:00] [ALPM] installed python-sphinx (1.8.0-1)
[2018-11-03 16:00] [ALPM] installed gnome-builder (3.30.2-1)
[2018-11-03 16:00] [ALPM] installed gnome-chess (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed gnome-devel-docs (3.30.1-1)
[2018-11-03 16:00] [ALPM] installed gnome-klotski (3.22.3+1+gf33083d-1)
[2018-11-03 16:00] [ALPM] installed gnome-mahjongg (3.22.0+1+g55799c1-1)
[2018-11-03 16:00] [ALPM] installed gnome-mines (3.30.1.1-1)
[2018-11-03 16:00] [ALPM] installed geoip-database (20180403-1)
[2018-11-03 16:00] [ALPM] installed geoip (1.6.12-1)
[2018-11-03 16:00] [ALPM] installed bind-tools (9.13.3-3)
[2018-11-03 16:00] [ALPM] installed whois (5.3.2-2)
[2018-11-03 16:00] [ALPM] installed gnome-nettool (3.8.1+205+g8550eef-2)
[2018-11-03 16:00] [ALPM] installed gnome-nibbles (3.24.1-1)
[2018-11-03 16:00] [ALPM] installed gnome-robots (3.22.3+2+g985e8e4-1)
[2018-11-03 16:00] [ALPM] installed gnome-sound-recorder (3.28.1-2)
[2018-11-03 16:00] [ALPM] installed qqwing (1.3.4-3)
[2018-11-03 16:00] [ALPM] installed gnome-sudoku (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed gnome-taquin (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed gnome-tetravex (3.22.0+4+g817dbf6-1)
[2018-11-03 16:00] [ALPM] installed gnome-tweaks (3.30.1-1)
[2018-11-03 16:00] [ALPM] installed gnome-weather (3.26.0-1)
[2018-11-03 16:00] [ALPM] installed hitori (3.22.4-1)
[2018-11-03 16:00] [ALPM] installed iagno (3.28.0-1)
[2018-11-03 16:00] [ALPM] installed lightsoff (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed telepathy-idle (0.2.0-2)
[2018-11-03 16:00] [ALPM] installed telepathy-mission-control (5.16.4-3)
[2018-11-03 16:00] [ALPM] installed telepathy-logger (0.8.2-2)
[2018-11-03 16:00] [ALPM] installed polari (3.30.2-1)
[2018-11-03 16:00] [ALPM] installed quadrapassel (3.22.0-1)
[2018-11-03 16:00] [ALPM] installed swell-foop (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed tali (3.22.0-1)
[2018-11-03 16:00] [ALPM] installed python-lazy-object-proxy (1.3.1-2)
[2018-11-03 16:00] [ALPM] installed python-wrapt (1.10.11-2)
[2018-11-03 16:00] [ALPM] installed python-astroid (2.0.4-1)
[2018-11-03 16:00] [ALPM] installed python-mccabe (0.6.1-2)
[2018-11-03 16:00] [ALPM] installed python-isort (4.3.4-2)
[2018-11-03 16:00] [ALPM] installed python-pylint (2.1.1-1)
[2018-11-03 16:00] [ALPM] installed python-pyflakes (2.0.0-2)
[2018-11-03 16:00] [ALPM] installed python-pycodestyle (2.4.0-2)
[2018-11-03 16:00] [ALPM] installed python-simplejson (3.16.1-1)
[2018-11-03 16:00] [ALPM] installed rubygems (2.7.7-1)
[2018-11-03 16:00] [ALPM] installed ruby (2.5.3-1)
[2018-11-03 16:00] [ALPM] installed ruby-dbus (0.15.0-1)
[2018-11-03 16:00] [ALPM] installed ruby-ffi (1.9.25-1)
[2018-11-03 16:00] [ALPM] installed ruby-rb-inotify (0.9.10-2)
[2018-11-03 16:00] [ALPM] installed ruby-sass-listen (4.0.0-5)
[2018-11-03 16:00] [ALPM] installed ruby-rdoc (6.0.4-1)
[2018-11-03 16:00] [ALPM] installed ruby-yard (0.9.14-1)
[2018-11-03 16:00] [ALPM] installed ruby-maruku (0.7.3-3)
[2018-11-03 16:00] [ALPM] installed ruby-sass (3.5.6-1)
[2018-11-03 16:00] [ALPM] installed gnome-code-assistance (3.16.1+13+g7f81c19-1)
[2018-11-03 16:00] [ALPM] installed gedit-code-assistance (3.16.0+4+gd19b879-1)
[2018-11-03 16:00] [ALPM] installed gnome-multi-writer (3.30.0-1)
[2018-11-03 16:00] [ALPM] installed gnome-recipes (2.0.2-2)
[2018-11-03 16:00] [ALPM] installed gnome-usage (3.30.0-1)
[2018-11-03 16:00] [ALPM] transaction completed
[2018-11-03 16:00] [ALPM] running '90-linux.hook'...
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Starting build: 4.18.16-arch1-1-ARCH
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Starting build: 4.18.16-arch1-1-ARCH
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-11-03 16:00] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2018-11-03 16:00] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-11-03 16:00] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-11-03 16:00] [ALPM] running 'fontconfig.hook'...
[2018-11-03 16:00] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2018-11-03 16:00] [ALPM] running 'gio-querymodules.hook'...
[2018-11-03 16:00] [ALPM] running 'glib-compile-schemas.hook'...
[2018-11-03 16:00] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2018-11-03 16:00] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-03 16:00] [ALPM] running 'gvfsd.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-hwdb.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-sysctl.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-sysusers.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-udev-reload.hook'...
[2018-11-03 16:00] [ALPM] running 'systemd-update.hook'...
[2018-11-03 16:00] [ALPM] running 'texinfo-install.hook'...
[2018-11-03 16:00] [ALPM] running 'update-desktop-database.hook'...
[2018-11-03 16:00] [ALPM] running 'update-mime-database.hook'...
[2018-11-03 16:14] [PACMAN] Running 'pacman -Sy sudo'
[2018-11-03 16:14] [PACMAN] synchronizing package lists
[2018-11-03 16:14] [ALPM] transaction started
[2018-11-03 16:14] [ALPM] installed sudo (1.8.25.p1-1)
[2018-11-03 16:14] [ALPM] transaction completed
[2018-11-03 16:14] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-11-03 16:14] [ALPM] running 'systemd-update.hook'...
[2018-11-03 16:23] [PACMAN] Running 'pacman -Sy chromium'
[2018-11-03 16:23] [PACMAN] synchronizing package lists
[2018-11-03 16:23] [PACMAN] Running 'pacman -Sy chrome'
[2018-11-03 16:23] [PACMAN] synchronizing package lists
[2018-11-03 16:23] [PACMAN] Running 'pacman -Sy chromium'
[2018-11-03 16:23] [PACMAN] synchronizing package lists
[2018-11-03 16:24] [ALPM] transaction started
[2018-11-03 16:24] [ALPM] installed xorg-xset (1.2.4-1)
[2018-11-03 16:24] [ALPM] installed xdg-utils (1.1.3-3)
[2018-11-03 16:24] [ALPM] installed libxss (1.2.3-1)
[2018-11-03 16:24] [ALPM] installed minizip (1:1.2.11-3)
[2018-11-03 16:24] [ALPM] installed re2 (20181001-1)
[2018-11-03 16:24] [ALPM] installed chromium (70.0.3538.77-2)
[2018-11-03 16:24] [ALPM] transaction completed
[2018-11-03 16:24] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-03 16:24] [ALPM] running 'systemd-update.hook'...
[2018-11-03 16:24] [ALPM] running 'update-desktop-database.hook'...
[2018-11-03 16:30] [PACMAN] Running 'pacman -S chrome-gnome-shell'
[2018-11-03 16:30] [ALPM] transaction started
[2018-11-03 16:30] [ALPM] installed chrome-gnome-shell (10.1-2)
[2018-11-03 16:30] [ALPM] transaction completed
[2018-11-03 16:30] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-03 16:30] [ALPM] running 'systemd-update.hook'...
[2018-11-03 16:30] [ALPM] running 'update-desktop-database.hook'...
[2018-11-03 16:54] [PACMAN] Running 'pacman -S networkmanager'
[2018-11-03 16:55] [PACMAN] Running 'pacman -S networkmanager network-manager-applet nm-connection-editor'
[2018-11-03 16:55] [ALPM] transaction started
[2018-11-03 16:55] [ALPM] reinstalled networkmanager (1.14.5dev+17+gba83251bb-1)
[2018-11-03 16:55] [ALPM] reinstalled nm-connection-editor (1.8.19dev+21+geebf7f95-1)
[2018-11-03 16:55] [ALPM] installed network-manager-applet (1.8.19dev+21+geebf7f95-1)
[2018-11-03 16:55] [ALPM] transaction completed
[2018-11-03 16:55] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-03 16:55] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-03 16:55] [ALPM] running 'systemd-udev-reload.hook'...
[2018-11-03 16:55] [ALPM] running 'systemd-update.hook'...
[2018-11-03 16:55] [ALPM] running 'update-desktop-database.hook'...
[2018-11-03 17:05] [PACMAN] Running 'pacman -S pacaur'
[2018-11-03 17:08] [PACMAN] Running 'pacman -S pacaur'
[2018-11-03 17:10] [PACMAN] Running 'pacman -Sy git'
[2018-11-03 17:10] [PACMAN] synchronizing package lists
[2018-11-03 17:11] [ALPM] transaction started
[2018-11-03 17:11] [ALPM] installed perl-error (0.17027-1)
[2018-11-03 17:11] [ALPM] installed perl-timedate (2.30-5)
[2018-11-03 17:11] [ALPM] installed perl-mailtools (2.20-2)
[2018-11-03 17:11] [ALPM] installed git (2.19.1-1)
[2018-11-03 17:11] [ALPM] transaction completed
[2018-11-03 17:11] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-11-03 17:11] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-03 17:11] [ALPM] running 'systemd-sysusers.hook'...
[2018-11-03 17:11] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:11] [PACMAN] Running '/usr/bin/pacman -S --asdeps go'
[2018-11-03 17:13] [ALPM] transaction started
[2018-11-03 17:13] [ALPM] installed go (2:1.11.1-1)
[2018-11-03 17:13] [ALPM] transaction completed
[2018-11-03 17:13] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:14] [PACMAN] Running 'pacman -S make'
[2018-11-03 17:15] [ALPM] transaction started
[2018-11-03 17:15] [ALPM] installed libatomic_ops (7.6.6-1)
[2018-11-03 17:15] [ALPM] installed gc (7.6.8-1)
[2018-11-03 17:15] [ALPM] installed guile (2.2.4-1)
[2018-11-03 17:15] [ALPM] installed make (4.2.1-2)
[2018-11-03 17:15] [ALPM] transaction completed
[2018-11-03 17:15] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:15] [ALPM] running 'texinfo-install.hook'...
[2018-11-03 17:15] [PACMAN] Running 'pacman -S makepkg'
[2018-11-03 17:16] [PACMAN] Running 'pacman -S fakeroot'
[2018-11-03 17:16] [ALPM] transaction started
[2018-11-03 17:16] [ALPM] installed fakeroot (1.23-1)
[2018-11-03 17:16] [ALPM] transaction completed
[2018-11-03 17:16] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:17] [PACMAN] Running '/usr/bin/pacman -U /home/piotr/yay/yay-8.1173.0-1-x86_64.pkg.tar.xz'
[2018-11-03 17:17] [ALPM] transaction started
[2018-11-03 17:17] [ALPM] installed yay (8.1173.0-1)
[2018-11-03 17:17] [ALPM] transaction completed
[2018-11-03 17:17] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:25] [PACMAN] Running 'pacman -S archlinux-wallpaper'
[2018-11-03 17:25] [ALPM] transaction started
[2018-11-03 17:25] [ALPM] installed archlinux-wallpaper (1.4-3)
[2018-11-03 17:25] [ALPM-SCRIPTLET] ==> Wallpapers have been installed to /usr/share/archlinux/wallpaper
[2018-11-03 17:25] [ALPM] transaction completed
[2018-11-03 17:25] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:35] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/rsync'
[2018-11-03 17:35] [ALPM] transaction started
[2018-11-03 17:35] [ALPM] installed rsync (3.1.3-1)
[2018-11-03 17:35] [ALPM] transaction completed
[2018-11-03 17:35] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-03 17:35] [ALPM] running 'systemd-update.hook'...
[2018-11-03 17:35] [PACMAN] Running 'pacman -D --asdeps --config /etc/pacman.conf -- rsync'
[2018-11-03 18:26] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/webstorm/webstorm-jre-2018.2.5-1-x86_64.pkg.tar.xz'
[2018-11-03 18:26] [ALPM] transaction started
[2018-11-03 18:26] [ALPM] installed webstorm-jre (2018.2.5-1)
[2018-11-03 18:26] [ALPM] transaction completed
[2018-11-05 13:39] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/webstorm/webstorm-2018.2.5-1-x86_64.pkg.tar.xz'
[2018-11-05 13:39] [ALPM] transaction started
[2018-11-05 13:39] [ALPM] installed webstorm (2018.2.5-1)
[2018-11-05 13:39] [ALPM] transaction completed
[2018-11-05 13:39] [ALPM] running 'systemd-update.hook'...
[2018-11-05 13:39] [ALPM] running 'update-desktop-database.hook'...
[2018-11-05 13:46] [PACMAN] Running 'pacman -S -y --config /etc/pacman.conf --'
[2018-11-05 13:46] [PACMAN] synchronizing package lists
[2018-11-05 13:46] [PACMAN] Running 'pacman -S -y --config /etc/pacman.conf --'
[2018-11-05 13:46] [PACMAN] synchronizing package lists
[2018-11-05 13:53] [PACMAN] Running 'pacman -S -y --config /etc/pacman.conf --'
[2018-11-05 13:53] [PACMAN] synchronizing package lists
[2018-11-05 13:53] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/phpstorm/phpstorm-2018.2.5-1-x86_64.pkg.tar.xz'
[2018-11-05 13:53] [ALPM] transaction started
[2018-11-05 13:53] [ALPM] error: could not extract /opt/phpstorm/plugins/markdown/lib/plantuml.jar (Lzma library error:  No progress is possible)
[2018-11-05 13:53] [ALPM] error: problem occurred while installing phpstorm
[2018-11-05 13:53] [ALPM] installed phpstorm (2018.2.5-1)
[2018-11-05 13:53] [ALPM] transaction failed
[2018-11-05 13:55] [PACMAN] Running 'pacman -R --config /etc/pacman.conf -- phpstorm'
[2018-11-05 13:56] [ALPM] transaction started
[2018-11-05 13:56] [ALPM] removed phpstorm (2018.2.5-1)
[2018-11-05 13:56] [ALPM] transaction completed
[2018-11-05 13:56] [ALPM] running 'systemd-update.hook'...
[2018-11-05 13:56] [ALPM] running 'update-desktop-database.hook'...
[2018-11-05 14:28] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/gconf extra/gtk2 community/libcurl-gnutls community/libcurl-compat'
[2018-11-05 14:28] [ALPM] transaction started
[2018-11-05 14:28] [ALPM] installed gconf (3.2.6+11+g07808097-4)
[2018-11-05 14:28] [ALPM] installed gtk2 (2.24.32-1)
[2018-11-05 14:28] [ALPM] installed libcurl-gnutls (7.62.0-1)
[2018-11-05 14:28] [ALPM] installed libcurl-compat (7.62.0-1)
[2018-11-05 14:28] [ALPM] transaction completed
[2018-11-05 14:28] [ALPM] running 'gio-querymodules.hook'...
[2018-11-05 14:28] [ALPM] running 'gtk-query-immodules-2.0.hook'...
[2018-11-05 14:28] [ALPM] running 'systemd-update.hook'...
[2018-11-05 14:28] [PACMAN] Running 'pacman -D --asdeps --config /etc/pacman.conf -- gconf gtk2 libcurl-gnutls libcurl-compat'
[2018-11-05 14:32] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/spotify/spotify-1.0.92.390-1-x86_64.pkg.tar.xz'
[2018-11-05 14:32] [ALPM] transaction started
[2018-11-05 14:32] [ALPM] installed spotify (1.0.92.390-1)
[2018-11-05 14:32] [ALPM] transaction completed
[2018-11-05 14:32] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-05 14:32] [ALPM] running 'systemd-update.hook'...
[2018-11-05 14:32] [ALPM] running 'update-desktop-database.hook'...
[2018-11-06 09:46] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- cups'
[2018-11-06 09:46] [PACMAN] Running 'pacman -S cups'
[2018-11-06 09:46] [ALPM] transaction started
[2018-11-06 09:46] [ALPM] installed qpdf (8.2.1-1)
[2018-11-06 09:46] [ALPM] installed liblqr (0.4.2-2)
[2018-11-06 09:46] [ALPM] installed libraqm (0.5.0-1)
[2018-11-06 09:46] [ALPM] installed libmagick (7.0.8.14-1)
[2018-11-06 09:46] [ALPM] installed imagemagick (7.0.8.14-1)
[2018-11-06 09:46] [ALPM] installed cups-filters (1.21.3-3)
[2018-11-06 09:46] [ALPM] installed bc (1.07.1-1)
[2018-11-06 09:46] [ALPM] installed cups (2.2.8-3)
[2018-11-06 09:46] [ALPM-SCRIPTLET] >> If you use an HTTPS connection to CUPS, the first time you access
[2018-11-06 09:46] [ALPM-SCRIPTLET] >> the interface it may take a very long time before the site comes up.
[2018-11-06 09:46] [ALPM-SCRIPTLET] >> This is because the first request triggers the generation of the CUPS
[2018-11-06 09:46] [ALPM-SCRIPTLET] >> SSL certificates which can be a very time-consuming job.
[2018-11-06 09:46] [ALPM] transaction completed
[2018-11-06 09:46] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-11-06 09:46] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-06 09:46] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-06 09:46] [ALPM] running 'systemd-sysusers.hook'...
[2018-11-06 09:46] [ALPM] running 'systemd-update.hook'...
[2018-11-06 09:46] [ALPM] running 'texinfo-install.hook'...
[2018-11-06 09:46] [ALPM] running 'update-desktop-database.hook'...
[2018-11-06 09:55] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/psutils extra/a2ps'
[2018-11-06 09:55] [ALPM] transaction started
[2018-11-06 09:55] [ALPM] installed psutils (1.17-6)
[2018-11-06 09:55] [ALPM] installed a2ps (4.14-7)
[2018-11-06 09:55] [ALPM] transaction completed
[2018-11-06 09:55] [ALPM] running 'systemd-update.hook'...
[2018-11-06 09:55] [ALPM] running 'texinfo-install.hook'...
[2018-11-06 09:55] [PACMAN] Running 'pacman -D --asdeps --config /etc/pacman.conf -- psutils a2ps'
[2018-11-06 09:57] [PACMAN] Running 'pacman -S patch'
[2018-11-06 09:57] [ALPM] transaction started
[2018-11-06 09:57] [ALPM] installed patch (2.7.6-3)
[2018-11-06 09:57] [ALPM] transaction completed
[2018-11-06 09:57] [ALPM] running 'systemd-update.hook'...
[2018-11-06 09:58] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/brother-dcpj152w/brother-dcpj152w-3.0.0-1-x86_64.pkg.tar.xz'
[2018-11-06 09:58] [ALPM] transaction started
[2018-11-06 09:58] [ALPM] installed brother-dcpj152w (3.0.0-1)
[2018-11-06 09:58] [ALPM-SCRIPTLET] lpadmin -p DCPJ152W -E -v usb:/dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcpj152w_printer_en.ppd
[2018-11-06 09:58] [ALPM] transaction completed
[2018-11-06 09:58] [ALPM] running 'systemd-update.hook'...
[2018-11-06 16:48] [PACMAN] Running 'pacman -S rar'
[2018-11-06 16:49] [PACMAN] Running 'pacman -S unrar'
[2018-11-06 16:49] [ALPM] transaction started
[2018-11-06 16:49] [ALPM] installed unrar (1:5.6.8-1)
[2018-11-06 16:49] [ALPM] transaction completed
[2018-11-06 16:49] [ALPM] running 'systemd-update.hook'...
[2018-11-06 17:19] [PACMAN] Running 'pacman -S gdb'
[2018-11-06 17:19] [ALPM] transaction started
[2018-11-06 17:19] [ALPM] installed guile2.0 (2.0.14-1)
[2018-11-06 17:19] [ALPM] installed gdb-common (8.2-2)
[2018-11-06 17:19] [ALPM] installed gdb (8.2-2)
[2018-11-06 17:19] [ALPM] transaction completed
[2018-11-06 17:19] [ALPM] running 'systemd-update.hook'...
[2018-11-06 17:19] [ALPM] running 'texinfo-install.hook'...
[2018-11-06 17:22] [PACMAN] Running 'pacman -S --config /etc/pacman.conf -- extra/perl-uri'
[2018-11-06 17:22] [ALPM] transaction started
[2018-11-06 17:22] [ALPM] installed perl-uri (1.74-2)
[2018-11-06 17:22] [ALPM] transaction completed
[2018-11-06 17:22] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-11-06 17:22] [ALPM] running 'systemd-update.hook'...
[2018-11-06 17:22] [PACMAN] Running 'pacman -D --asdeps --config /etc/pacman.conf -- perl-uri'
[2018-11-06 17:22] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/elmer/elmer-1.0.2.r0.gfb6fc12-1-any.pkg.tar.xz'
[2018-11-06 17:22] [ALPM] transaction started
[2018-11-06 17:22] [ALPM] installed elmer (1.0.2.r0.gfb6fc12-1)
[2018-11-06 17:22] [ALPM] transaction completed
[2018-11-06 17:22] [ALPM] running 'systemd-update.hook'...
[2018-11-06 17:24] [PACMAN] Running 'pacman -R --config /etc/pacman.conf -- elmer'
[2018-11-06 17:24] [ALPM] transaction started
[2018-11-06 17:24] [ALPM] removed elmer (1.0.2.r0.gfb6fc12-1)
[2018-11-06 17:24] [ALPM] transaction completed
[2018-11-06 17:24] [ALPM] running 'systemd-update.hook'...
[2018-11-06 18:43] [PACMAN] Running 'pacman -S libreoffice'
[2018-11-06 18:45] [ALPM] transaction started
[2018-11-06 18:45] [ALPM] installed librevenge (0.0.4-2)
[2018-11-06 18:45] [ALPM] installed libwpd (0.10.2-1)
[2018-11-06 18:45] [ALPM] installed libwps (0.4.10-1)
[2018-11-06 18:45] [ALPM] installed raptor (2.0.15-10)
[2018-11-06 18:45] [ALPM] installed rasqal (1:0.9.33-2)
[2018-11-06 18:45] [ALPM] installed redland (1:1.0.17-4)
[2018-11-06 18:45] [ALPM] installed lpsolve (5.5.2.5-2)
[2018-11-06 18:45] [ALPM] installed libwpg (0.3.2-1)
[2018-11-06 18:45] [ALPM] installed libvisio (0.1.6-5)
[2018-11-06 18:45] [ALPM] installed liblangtag (0.6.2-1)
[2018-11-06 18:45] [ALPM] installed libetonyek (0.1.8-1)
[2018-11-06 18:45] [ALPM] installed libodfgen (0.1.7-1)
[2018-11-06 18:45] [ALPM] installed libcdr (0.1.4-5)
[2018-11-06 18:45] [ALPM] installed libmspub (0.1.4-4)
[2018-11-06 18:45] [ALPM] installed clucene (2.3.3.4-10)
[2018-11-06 18:45] [ALPM] installed libpagemaker (0.0.4-1)
[2018-11-06 18:45] [ALPM] installed libabw (0.1.2-1)
[2018-11-06 18:45] [ALPM] installed libmwaw (0.3.14-1)
[2018-11-06 18:45] [ALPM] installed libe-book (0.1.3-4)
[2018-11-06 18:45] [ALPM] installed libexttextcat (3.4.5-1)
[2018-11-06 18:45] [ALPM] installed libcmis (0.5.1-10)
[2018-11-06 18:45] [ALPM] installed libixion (0.14.1-1)
[2018-11-06 18:45] [ALPM] installed liborcus (0.14.1-1)
[2018-11-06 18:45] [ALPM] installed libtommath (1.0.1-1)
[2018-11-06 18:45] [ALPM] installed libzmf (0.0.2-5)
[2018-11-06 18:45] [ALPM] installed libnumbertext (1.0.5-1)
[2018-11-06 18:45] [ALPM] installed libfreehand (0.1.2-1)
[2018-11-06 18:45] [ALPM] installed libstaroffice (0.0.6-1)
[2018-11-06 18:45] [ALPM] installed libepubgen (0.1.1-1)
[2018-11-06 18:45] [ALPM] installed libqxp (0.0.1-4)
[2018-11-06 18:45] [ALPM] installed libreoffice-fresh (6.1.2-4)
[2018-11-06 18:45] [ALPM] transaction completed
[2018-11-06 18:45] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-06 18:45] [ALPM] running 'systemd-update.hook'...
[2018-11-06 18:45] [ALPM] running 'update-desktop-database.hook'...
[2018-11-06 18:45] [ALPM] running 'update-mime-database.hook'...
[2018-11-07 13:56] [PACMAN] Running 'pacman -R --config /etc/pacman.conf -- brother-dcpj152w'
[2018-11-07 13:56] [ALPM] transaction started
[2018-11-07 13:56] [ALPM-SCRIPTLET] lpadmin: The printer or class does not exist.
[2018-11-07 13:56] [ALPM] removed brother-dcpj152w (3.0.0-1)
[2018-11-07 13:56] [ALPM] transaction completed
[2018-11-07 13:56] [ALPM] running 'systemd-update.hook'...
[2018-11-07 13:57] [PACMAN] Running 'pacman -S -y --config /etc/pacman.conf --'
[2018-11-07 13:57] [PACMAN] synchronizing package lists
[2018-11-07 13:58] [PACMAN] Running 'pacman -R --config /etc/pacman.conf -- brother-dcpj152w'
[2018-11-07 13:58] [PACMAN] Running 'pacman -S -y --config /etc/pacman.conf --'
[2018-11-07 13:58] [PACMAN] synchronizing package lists
[2018-11-07 13:58] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/piotr/.cache/yay/brother-dcpj152w/brother-dcpj152w-3.0.0-1-x86_64.pkg.tar.xz'
[2018-11-07 13:58] [ALPM] transaction started
[2018-11-07 13:58] [ALPM] installed brother-dcpj152w (3.0.0-1)
[2018-11-07 13:58] [ALPM-SCRIPTLET] lpadmin -p DCPJ152W -E -v dnssd://Brother%20DCP-J152W._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-3c77e658b4d8 -P /usr/share/cups/model/Brother/brother_dcpj152w_printer_en.ppd
[2018-11-07 13:58] [ALPM] transaction completed
[2018-11-07 13:58] [ALPM] running 'systemd-update.hook'...

Packages which can be upgraded:

Packages (28) atkmm-2.28.0-1  brltty-5.6-6  curl-7.62.0-1
              device-mapper-2.02.182-1  ffmpeg-1:4.1-1  gdm-3.30.2-1
              go-2:1.11.2-1  gobject-introspection-runtime-1.58.0+8+gfdaa3b1a-1
              gtkmm3-3.22.3-1  harfbuzz-2.1.1-1  harfbuzz-icu-2.1.1-1
              libgdm-3.30.2-1  libgit2-1:0.27.7-1  libgit2-glib-0.27.7-1
              libreoffice-fresh-6.1.3-1  libsystemd-239.300-1  lvm2-2.02.182-1
              pangomm-2.42.0-1  pipewire-0.2.3+17+g10ce1a02-1
              python-pyparsing-2.3.0-1  python-sphinx-1.8.1-2
              python-urllib3-1.24.1-1  ruby-sass-3.6.0-1  seabios-1.11.0-3
              systemd-239.300-1  systemd-sysvcompat-239.300-1  tracker-2.1.6-2
              usbmuxd-1.1.0+48+g1cc8b34-1

Total Download Size:   237,12 MiB
Total Installed Size:  921,30 MiB
Net Upgrade Size:        1,76 MiB

After full upgrade pacman -Syu:

Reading symbols from /usr/bin/gnome-shell...(no debugging symbols found)...done.
[New LWP 730]
[New LWP 1573]
[New LWP 733]
[New LWP 775]
[New LWP 787]
[New LWP 732]
[New LWP 736]
[New LWP 735]
[New LWP 784]
[New LWP 1569]
[New LWP 737]
[New LWP 1571]
[New LWP 1572]
[New LWP 2475]
[New LWP 786]
[New LWP 785]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fd65d762f7b in js::AutoEnterOOMUnsafeRegion::crash(char const*) () from /usr/lib/libmozjs-60.so.0
[Current thread is 1 (Thread 0x7fd656e67100 (LWP 730))]
(gdb) bt 
#0  0x00007fd65d762f7b in js::AutoEnterOOMUnsafeRegion::crash(char const*) () at /usr/lib/libmozjs-60.so.0
#1  0x00007fd65d762fb1 in  () at /usr/lib/libmozjs-60.so.0
#2  0x00007fd65d76b52b in  () at /usr/lib/libmozjs-60.so.0
#3  0x00007fd65de5efef in  () at /usr/lib/libmozjs-60.so.0
#4  0x00007fd65de5f1eb in  () at /usr/lib/libmozjs-60.so.0
#5  0x00007fd65de5f3a7 in  () at /usr/lib/libmozjs-60.so.0
#6  0x00007fd65de5f421 in  () at /usr/lib/libmozjs-60.so.0
#7  0x00007fd65de6497f in  () at /usr/lib/libmozjs-60.so.0
#8  0x00007fd65de6594e in  () at /usr/lib/libmozjs-60.so.0
#9  0x00007fd65de27a25 in  () at /usr/lib/libmozjs-60.so.0
#10 0x00007fd65de46bd6 in  () at /usr/lib/libmozjs-60.so.0
#11 0x00007fd65de4722e in  () at /usr/lib/libmozjs-60.so.0
#12 0x00007fd65de474a9 in  () at /usr/lib/libmozjs-60.so.0
#13 0x00007fd6619886a0 in  () at /usr/lib/libgjs.so.0
#14 0x00007fd662211b63 in  () at /usr/lib/libglib-2.0.so.0
#15 0x00007fd662212271 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#16 0x00007fd662213f89 in  () at /usr/lib/libglib-2.0.so.0
#17 0x00007fd662214f62 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#18 0x00007fd661692310 in meta_run () at /usr/lib/libmutter-3.so.0
#19 0x00005619e1a1f3ab in  ()
#20 0x00007fd66272d223 in __libc_start_main () at /usr/lib/libc.so.6
#21 0x00005619e1a1f50e in  ()

What about this?: https://bugs.archlinux.org/task/53582

Last edited by Rotepi (2018-11-07 18:33:53)

Offline

#14 2018-11-13 21:49:13

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

After checking all possibilities I established, there's a problem with GNOME Extensions. When I disabled all Extensions the problem has disappeared, but when I enable only one of all Extensions problem exist, but with low frequency. How can I eliminate this problem without disabling extensions ?

Offline

#15 2018-11-13 22:08:49

loqs
Member
Registered: 2014-03-06
Posts: 9,077

Re: Restarting GDM

Does this issue occur with every one of the extensions you have installed if you have only one of them enabled at once?

Offline

#16 2018-11-14 05:58:00

seth
Member
Registered: 2012-09-03
Posts: 12,940

Re: Restarting GDM

Are there 3rd party extensions among them?
https://wiki.archlinux.org/index.php/GN … _the_shell

Offline

#17 2018-11-14 11:34:41

Rotepi
Member
Registered: 2018-05-31
Posts: 20

Re: Restarting GDM

Yes, there's 3rd party extensions. At this time I'm trying to determine which extensions make the problem. I realized that "Coverflow alt-tab" extension causes this problem and some of gnome official extensions

Offline

Board footer

Powered by FluxBB