You are not logged in.

#1 2018-11-01 19:51:28

PD1
Member
Registered: 2017-08-07
Posts: 5

[SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

Hang after
     [OK] Started udev Kernel Device Manager
Or black screen.

CPU: Intel Pentium CPU N3540 (Intel BYT-M)
MOTHERBOARD:  X553MA

PCI DEVICES:
    Atom processor Z36XXX/Z37XXX Series SoC (Host bridge)
    Atom processor Z36XXX/Z37XXX Series Grap (VGA compatible controller)
    Atom processor 3800 (SATA controller)
    Atom processor Z36XXX/Z37XXX (Encryption controller)
    Atom processor Z36XXX/Z37XXX (Audio device)
    Atom processor 3800 (PCI bridge)

ls /var/cache/pacman/pkg | grep linux

    linux-4.18.16.arch1-1-x86_64.pkg.tar.xz
    linux-firmware-20181018.d877533-1-any.pkg.tar.xz
    linux-headers-4.18.16.arch1-1-x86_64.pkg.tar.xz
    linux-lts-4.14.78-1-x86_64.pkg.tar.xz
    linux-lts-headers-4.14.78-1-x86_64.pkg.tar.xz
(So I don't have any earlier linux kernel versions to downgrade)

loglevel = 7

[   13.839911] mei_txe 0000:00:1a.0: can't derive routing for PCI INT A
[   13.841541] mei_txe 0000:00:1a.0: PCI INT A: not connected
[   13.882639] input: PC Speaker as /devices/platform/pcspkr/input/input13
[   bla-bla-bla] cryptd: max_cpu_qlen set to 1000
[   bla-bla-bla] fb: switching to inteldrmfb from EFI VGA

                               

After little bit of googling I see - some new hardware/kernel/firmware issue maybe? How to resolve this problem? I want to downgrade my kernel, but you can see there is nothing downgrade to.  Any ideas?


Update:
In order to full downgrade system I tried to put in mirrorlist repo dated 2018/09/01.

 echo 'Server=https://archive.archlinux.org/repos/2018/09/01/$repo/os/$arch' > /etc/pacman.d/mirrorlist
 pacman -Sy archlinux-keyring  
 pacman -Syyuu 


     package X  is corrupted (invalid or corrupted package (PGP signature)).
     Do you want to delete it? [Y/n]
     Y
     packge   Y   is corrupted (invalid or corrupted package (PGP signature))
     Do you want to delete it? [Y/n]
     Y
     packge   Z   is corrupted (invalid or corrupted package (PGP signature))
     Do you want to delete it? [Y/n]
     Y
     
error: failed to commit transaction  (invalid or corrupted package (PGP signature))

Last edited by PD1 (2018-11-21 17:05:53)

Offline

#2 2018-11-01 22:15:42

duaner
Member
Registered: 2018-10-13
Posts: 16

Re: [SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

PD1 wrote:

After little bit of googling I see - some new hardware/kernel/firmware issue maybe? How to resolve this problem? I want to downgrade my kernel, but you can see there is nothing downgrade to.  Any ideas?

Have you tried the arch linux archive? Never used it myself, but it sounds handy.

https://wiki.archlinux.org/index.php/Do … g_Packages

Offline

#3 2018-11-02 10:31:12

m-svo
Member
Registered: 2018-09-22
Posts: 3

Re: [SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

Same issue, CPU: Intel Pentium CPU N3530 , same motherboard. Also, fresh ISO from 1.11.2018 won`t boot, while 1.10 and 1.09 boots fine.

The new message in journalctl since upgrade is:

 arch kernel: rtsx_pci: probe of 0000:03:00.0 failed with error -110 
PD1 wrote:

loglevel = 7

[   13.839911] mei_txe 0000:00:1a.0: can't derive routing for PCI INT A
[   13.841541] mei_txe 0000:00:1a.0: PCI INT A: not connected
[   13.882639] input: PC Speaker as /devices/platform/pcspkr/input/input13
[   bla-bla-bla] cryptd: max_cpu_qlen set to 1000
[   bla-bla-bla] fb: switching to inteldrmfb from EFI VGA

This could be irrelevant to the issue, because I have the same log messages since September.

Offline

#4 2018-11-02 11:02:21

m-svo
Member
Registered: 2018-09-22
Posts: 3

Re: [SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

Solved for now by downgrading to linux-4.18.14, any version after that one has the issue.

PD1, you can do:

wget https://archive.archlinux.org/packages/l/linux/linux-4.18.14.arch1-1-x86_64.pkg.tar.xz
pacman -U linux-4.18.14.arch1-1-x86_64.pkg.tar.xz

If you need linux-lts, you can test different lts versions the same way.

Offline

#5 2018-11-02 11:45:05

PD1
Member
Registered: 2017-08-07
Posts: 5

Re: [SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

As,  m-svo recommended I downgraded kernel to some earlier version 4.18.14-arch1-1-ARCH  and it seems worked to me.  But with linux-lts-4.14.63-1 i got

 [bla-bla-bla] r8169 0000:03:00.2: cant disable ASPM; OS doesn't have ASPM control 

. Still i ignored it and used 4.18.

Last edited by PD1 (2018-11-21 17:04:45)

Offline

#6 2019-01-23 08:33:08

m-svo
Member
Registered: 2018-09-22
Posts: 3

Re: [SOLVED]Linux UDEV hangs at boot after update. linux-lts-4.14.78-1

PD1, looks like the issue is solved in linux-lts 4.19.16-1
So, if you prefer lts, probably it is safe to switch back.

Offline

Board footer

Powered by FluxBB