You are not logged in.

#1 2018-11-19 14:29:38

Registered: 2016-07-27
Posts: 9

[SOLVED] Soundcard stopped working after move


I recently moved and took my desktop PC with me. In it I have a Creative Labs Sound Blaster X-Fi Series soundcard (I don't know any details, this was a hand down from somebody else). Which I have been using for a few years now. After I moved last week (including the usual hour-long vibrations car travel entails) and have replugged my PC it would be stuck on the booting process. I was able to find that the sound card was the problem (I, sadly, did not write down the error message of the kernel with the debug flag, it said something about snd from which I guessed it was the soundcard).

I took the sound card out, and everything booted fine. The problem is that the onboard Realtek sound chip on the motherboard never seemed to work with Linux (at least I was unable to get it to work after days of trying to find something), so I am dependent on that sound card.

After cleaning the card and plugging it back in, the PC would boot up fine but the Sound card is not recognized as such anymore.

I use Pulse on top of Alsa and the sound card doesn't show up in pavucontrol anymore. As far as I am aware the driver should be `snd-ctxfi`. I have added it to `/etc/modules` and rebooted but no luck. The related part of `lspci -v` is

04:00.0 Non-VGA unclassified device: Creative Labs EMU20k1 [Sound Blaster X-Fi Series]
	!!! Invalid class 0000 for header type 01
	Flags: bus master, fast devsel, latency 0
	I/O ports at <ignored> [disabled]
	I/O ports at <ignored> [disabled]
	Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
	!!! Unknown I/O range types 4/5
	!!! Unknown memory range types fffb/0
	!!! Unknown prefetchable memory range types ffff/0
	Kernel modules: snd_ctxfi

And the related `dmesg` output is

[    0.443662] pci 0000:04:00.0: [1102:0005] type 01 class 0x040100
[    0.443672] pci 0000:04:00.0: ignoring class 0x040100 (doesn't match header type 01)
[    0.443820] pci 0000:04:00.0: Primary bus is hard wired to 0
[    0.443922] pci 0000:04:00.0: PCI bridge to [bus 05]
[    0.443927] pci 0000:04:00.0:   bridge window [io  0x0000-0x0fff]
[    0.443941] pci 0000:04:00.0: Primary bus is hard wired to 0
[    0.473976] pci 0000:04:00.0: not setting up bridge for bus 0000:05
[    2.515938] snd_ctxfi 0000:04:00.0: chip 20K1 model Unknown (0000:0000) is found
[    2.517447] snd_ctxfi 0000:04:00.0: XFi: Cannot get irq 0
[    2.517868] snd_ctxfi 0000:04:00.0: Something wrong!!!
[    2.518281] snd_ctxfi: probe of 0000:04:00.0 failed with error -16

I tried searching for these errors but I got to forums about, what I assume to be, hardware programming and I was not able to extrapolate that information to my soundcard problem, I might just be missing something super obvious though.

My main question is: Do I have enough evidence to say the card is broken and I need a new one, or is there anything I can do? I have taken out and put the card back in numerous times to no avail.

Last edited by Coya (2018-11-22 05:56:25)


#2 2018-11-22 05:56:46

Registered: 2016-07-27
Posts: 9

Re: [SOLVED] Soundcard stopped working after move

Well I just cleaned everything and took the soundcard out and put it back in again, for some reason it decided to work this time so just delete this thread. Don't know why it didn't work the other day.


Board footer

Powered by FluxBB