You are not logged in.

#1 2018-11-20 09:44:43

Charles Xu
Member
Registered: 2018-05-05
Posts: 1

Upgrading libreoffice-fresh (6.1.3-1 -> 6.1.3-2) makes btrfs readonly

Hi all, I upgraded libreoffice today and failed, after examing my system, I found my root with btrfs becomes read only:

 BTRFS error (device sdb2): eb 515080192 invalid extent inline ref type 0

And I rebooted. After reboot, by computer becomes normal again, but when I type pacman -Syu, the upgrade keeps corrupted and my root becoms read only again as well.

I managed to solve this problem this way:
  I have a ubuntu usb boot drive, so I booted into ubuntu
  mount root, /dev, /proc, /boot to /mnt
  chroot to /mnt
  run pacman -Syu
and after a lot of warning message, my libreoffice upgraded successfully:

warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/system/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/table/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/task/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/text/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/text/fieldmaster/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/text/textfield/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/text/textfield/docinfo/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/tiledrendering/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/ucb/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/ui/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/ui/dialogs/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/ui/test/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/uno/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/uri/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/util/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/view/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xforms/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/crypto/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/crypto/sax/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/csax/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/dom/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/dom/events/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/dom/views/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/input/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/sax/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/wrapper/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/xpath/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xml/xslt/
warning: could not get file information for usr/share/idl/libreoffice/com/sun/star/xsd/
warning: could not get file information for usr/share/idl/libreoffice/org/
warning: could not get file information for usr/share/idl/libreoffice/org/freedesktop/
warning: could not get file information for usr/share/idl/libreoffice/org/freedesktop/PackageKit/
warning: could not get file information for usr/share/libreoffice/
warning: could not get file information for usr/share/man/man1/libreoffice.1.gz
warning: could not get file information for usr/share/man/man1/lobase.1.gz
warning: could not get file information for usr/share/man/man1/localc.1.gz
warning: could not get file information for usr/share/man/man1/lodraw.1.gz
warning: could not get file information for usr/share/man/man1/loffice.1.gz
warning: could not get file information for usr/share/man/man1/lofromtemplate.1.gz
warning: could not get file information for usr/share/man/man1/loimpress.1.gz
warning: could not get file information for usr/share/man/man1/lomath.1.gz
warning: could not get file information for usr/share/man/man1/loweb.1.gz
warning: could not get file information for usr/share/man/man1/lowriter.1.gz
warning: could not get file information for usr/share/man/man1/unopkg.1.gz
warning: could not get file information for usr/share/mime-info/libreoffice.keys
warning: could not get file information for usr/share/mime-info/libreoffice.mime
warning: could not get file information for usr/share/mime/packages/libreoffice.xml
:: Running pre-transaction hooks...
(1/1) Unregistering Haskell modules...
:: Processing package changes...
( 1/22) upgrading sudo                                                                                                         [#############################################################################] 100%
( 2/22) upgrading libtiff                                                                                                      [#############################################################################] 100%
( 3/22) upgrading adwaita-icon-theme                                                                                           [#############################################################################] 100%
( 4/22) upgrading alsa-lib                                                                                                     [#############################################################################] 100%
( 5/22) upgrading hunspell                                                                                                     [#############################################################################] 100%
( 6/22) upgrading enchant      

Here is the successful upgrade log

17:06] [PACMAN] Running 'pacman -Syu'
[2018-11-20 17:06] [PACMAN] synchronizing package lists
[2018-11-20 17:06] [PACMAN] starting full system upgrade
[2018-11-20 17:06] [PACMAN] Running 'pacman -Su sudo'
[2018-11-20 17:06] [PACMAN] starting full system upgrade
[2018-11-20 17:06] [ALPM] running 'ghc-unregister.hook'...
[2018-11-20 17:06] [ALPM] transaction started
[2018-11-20 17:06] [ALPM] upgraded sudo (1.8.25.p1-1 -> 1.8.26-1)
[2018-11-20 17:06] [ALPM] upgraded libtiff (4.0.9-2 -> 4.0.10-1)
[2018-11-20 17:06] [ALPM] upgraded adwaita-icon-theme (3.30.0-1 -> 3.30.1-1)
[2018-11-20 17:06] [ALPM] upgraded alsa-lib (1.1.7-1 -> 1.1.7-2)
[2018-11-20 17:06] [ALPM] upgraded hunspell (1.6.2-1 -> 1.7.0-1)
[2018-11-20 17:06] [ALPM] upgraded enchant (2.2.3-1 -> 2.2.3-2)
[2018-11-20 17:06] [ALPM] upgraded haskell-http (4000.3.12-82 -> 4000.3.12-83)
[2018-11-20 17:06] [ALPM] upgraded haskell-http-client (0.5.13.1-27 -> 0.5.14-1)
[2018-11-20 17:06] [ALPM] upgraded haskell-http-client-tls (0.3.5.3-86 -> 0.3.5.3-87)
[2018-11-20 17:06] [ALPM] installed lib32-lz4 (1.8.3-1)
[2018-11-20 17:06] [ALPM] installed lib32-zstd (1.3.7-1)
[2018-11-20 17:06] [ALPM] upgraded lib32-libtiff (4.0.9-1 -> 4.0.10-1)
[2018-11-20 17:06] [ALPM] upgraded libreoffice-fresh (6.1.3-1 -> 6.1.3-2)
[2018-11-20 17:06] [ALPM] upgraded lnav-git (0.8.4.r46.g8b5b874-1 -> 0.8.4.r48.gaae4650-1)
[2018-11-20 17:06] [ALPM] upgraded lyx (2.3.1-1 -> 2.3.1-2)
[2018-11-20 17:06] [ALPM] upgraded netctl (1.18-1 -> 1.19-1)
[2018-11-20 17:06] [ALPM] upgraded pandoc (2.4-5 -> 2.4-6)
[2018-11-20 17:06] [ALPM] upgraded pandoc-citeproc (0.14.8.1-5 -> 0.14.8.1-6)
[2018-11-20 17:06] [ALPM] upgraded pandoc-crossref (0.3.3.0-37 -> 0.3.3.0-38)
[2018-11-20 17:06] [ALPM] upgraded python-neovim (0.3.0-1 -> 0.3.1-1)
[2018-11-20 17:06] [ALPM] upgraded tree (1.7.0-3 -> 1.8.0-1)
[2018-11-20 17:06] [ALPM] upgraded wayland-protocols (1.16-1 -> 1.17-1)
[2018-11-20 17:07] [ALPM] transaction completed
[2018-11-20 17:07] [ALPM] running 'ghc-register.hook'...
[2018-11-20 17:07] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-11-20 17:07] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-11-20 17:07] [ALPM-SCRIPTLET]   Skipped: Current root is not booted.
[2018-11-20 17:07] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-11-20 17:07] [ALPM] running 'systemd-update.hook'...
[2018-11-20 17:07] [ALPM] running 'update-desktop-database.hook'...
[2018-11-20 17:07] [ALPM] running 'update-mime-database.hook'...

Finally, my system works well. Hope developers may find out why and how to prevent this, and hope this may help someone who meet the same issue smile

Offline

#2 2018-11-26 14:43:09

ua4000
Member
Registered: 2015-10-14
Posts: 120

Re: Upgrading libreoffice-fresh (6.1.3-1 -> 6.1.3-2) makes btrfs readonly

Hi, it's very unlikely that upgrading a package results in a read-only btrfs.

You should post the complete log from the upgrade where you think something happened, not a later one.

Now I can guess only: full file-system ? dying disk ? / smart values ?,  instable power or system, (sata) cable failure...

Make a full backup and consult the wiki about btrfs file-system check and repair, also run smartmontools.

Good luck!

Offline

#3 2018-11-26 21:13:51

Condor
Member
Registered: 2017-12-01
Posts: 33

Re: Upgrading libreoffice-fresh (6.1.3-1 -> 6.1.3-2) makes btrfs readonly

I am running btrfs disks as well and have successfully upgraded libreoffice-fresh without any hiccups. The pacman errors are most likely not the cause, but an effect of other errors on the file system level.

If you are cautious (backups), head over to the btrfs.fsck documentation and try to recover from the displayed error.

Offline

Board footer

Powered by FluxBB