You are not logged in.

#1 2006-08-18 21:25:14

zsurnz
Member
From: France
Registered: 2006-03-23
Posts: 18

Radeon 7500: dlopen radeon_dri.so failed --> SOLVED

Hello,
Does anybody use ATI Radeon 7500 card with direct rendering activated ?
I have this hardware, here's the output from hwd:
------------------------
Video      : ATI|Radeon 7500 QW (AGP/PCI) server: Xorg (vesa)
Driver     : xf86-video-vesa
Monitor    : Generic Monitor  H: 28.0-96.0kHz V: 50.0-75.0Hz
------------------------
I tried to get 3D acceleration using fglrx module, using info in:
http://wiki.archlinux.org/index.php/ATI … figuration
but it doesn't appear to work, I get '(EE) no devices detected', and according to:
http://wiki.x.org/wiki/FAQErrorMessages … c745b6cfd4
I conclude that it is no suitable driver.
Trying "radeon" instead of "fglrx" module, results are much better, X works and even appears faster than with the generic vesa driver. However, I'm still unable to activate direct rendering, having the following error:
------------------------
# LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 5.0.3 radeon (screen 0)
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri//radeon_dri.so
libGL error: dlopen /usr/lib/xorg/modules/dri//radeon_dri.so failed (/usr/lib/xorg/modules/dri//radeon_dri.so: undefined symbol: _glapi_add_di
spatch)
libGL error: unable to find driver: radeon_dri.so
libGL: XF86DRIGetClientDriverName: 5.0.3 radeon (screen 0)
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri//radeon_dri.so
libGL error: dlopen /usr/lib/xorg/modules/dri//radeon_dri.so failed (/usr/lib/xorg/modules/dri//radeon_dri.so: undefined symbol: _glapi_add_di
spatch)
libGL error: unable to find driver: radeon_dri.so
display: :0  screen: 0
direct rendering: No
------------------------
Modules radeon and drm are loaded:
------------------------
# lsmod | grep radeon
radeon                113696  1
drm                    63508  2 radeon
# lsmod | grep agp
via_agp                 8320  1
agpgart                26980  2 drm,via_agp
------------------------
I guess radeon_dri.so is only for 3D acceleration, while the radeon module in the kernel is the video driver of the card ? Then I am puzzled at
the fact that hwd finds xf86-video-vesa as driver...
As I get mostly information about XFree86 rather than xorg from googling I hope to make more progress through the forum. Thanks.

Offline

#2 2006-08-18 22:35:25

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: Radeon 7500: dlopen radeon_dri.so failed --> SOLVED

I was under the impression that the 9 series down dont work with the new fglrx.
Cheak out the rage3d forum:
http://www.rage3d.com/board/forumdispla … sprune=365

Offline

#3 2006-08-19 12:10:06

JGC
Developer
Registered: 2003-12-03
Posts: 1,660

Re: Radeon 7500: dlopen radeon_dri.so failed --> SOLVED

you should add "load glx" in the xorg modules selection, then radeon_dri.so will load fine from OpenGL apps.

Offline

#4 2006-08-19 20:35:36

zsurnz
Member
From: France
Registered: 2006-03-23
Posts: 18

Re: Radeon 7500: dlopen radeon_dri.so failed --> SOLVED

Thank for your replies, I had missed the rage3d forum. On this forum as on most sites compiling data for ati/linux, Radeon 7500 is not explicitly mentioned on the lists of supported hardware, however in a few places it is reported to work. Anyway the error I get clearly is not related to hardware.

I do load the glx module, here is my xorg.conf section:
Section "Module"
        Load  "ddc"  # ddc probing of monitor
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "bitmap" # bitmap-fonts
        Load  "type1"
        Load  "freetype"
        Load  "record"
EndSection

I found a couple of reports of this error msg, e.g. there:
http://lists.x.org/archives/xorg-modula … 00617.html
Invariably it was due to a wrong version of the libGL.so.
For me I have only one updated version of this file. However it happens to belong to ati-fglrx-utils 8.27.10-3. Since I replaced the "fglrx" driver by "radeon", I wonder whether there could be another version of libGL provided by another package that would be consistent with my radeon_dri.so ?

Offline

#5 2006-08-20 08:08:53

zsurnz
Member
From: France
Registered: 2006-03-23
Posts: 18

Re: Radeon 7500: dlopen radeon_dri.so failed --> SOLVED

OK, I found the package libgl-dri that does provide indeed alternative libGL libraries.
After removing fglrx related package and installing this one, direct rendering works !
Thanks for your help !

Offline

Board footer

Powered by FluxBB