You are not logged in.

#1 2018-11-24 18:03:08

ddshore
Member
Registered: 2018-09-23
Posts: 7

Optirun won't run. Error: Could not enable discrete graphics card

Hi,

I'm using a Dell Precision 5530.  My nvidia card is:

`01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P2000 Mobile] (rev ff)`
And for my intel card I'm using
`00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b] (prog-if 00 [VGA controller])
`(i915). 

Using arch linux with kernel version:  4.18.9-arch1-1-ARCH and bumblebeed version 3.2.1. 

Whenever I try to run with optirun or primus I get this message:

[13992.517515] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
[13992.517530] [ERROR]Aborting because fallback start is disabled.

Checking dmesg I have this error whenever using it:

[13841.624122] bbswitch: enabling discrete graphics
[13841.624139] pci 0000:01:00.0: Refused to change power state, currently in D3

It seems to load fine:

[   15.056098] bbswitch: version 0.8
[   15.056101] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   15.056105] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   15.056110] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20180531/nsarguments-66)
[   15.056187] bbswitch: detected an Optimus _DSM function
[   15.056192] pci 0000:01:00.0: enabling device (0006 -> 0007)
[   15.056237] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[   15.057305] bbswitch: disabling discrete graphics
[   15.239089] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4646]
[   15.254806] ath10k_pci 0000:3b:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1028:364a
[   15.254807] ath10k_pci 0000:3b:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[   15.255145] ath10k_pci 0000:3b:00.0: firmware ver WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
[   15.269195] psmouse serio1: synaptics: queried min coordinates: x [1278..], y [1206..]

Everything seems to be installed properly, and there's no place in the BIOS to enable/disable the card. 

I've gone through the forums and have tried many solutions, but none seem to work. 

These are the solutions I have tried.

1. I've added acpi_rev_override=1 and  pcie_port_pm=off to my kernel.
2. I've tried running optirun before suspending.
3. I've added nvidia to my bumblebee.conf file under Driver
4. I've added bbswitch to my modules under mkinitcpio.conf
5. I've tried to force bbswitch to set the status of my card to on without using optirun (but it still remains off).

Are there any solutions I'm missing?  How can I get it to run?

Last edited by ddshore (2018-11-24 20:26:53)

Offline

#2 2018-11-24 18:27:07

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,407
Website

Re: Optirun won't run. Error: Could not enable discrete graphics card

Please edit your post to use code tags around your terminal outputs.

https://wiki.archlinux.org/index.php/Co … s_and_code

Also, please share which solutions you have tried.

Last edited by WorMzy (2018-11-24 18:27:43)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2018-11-24 20:27:25

ddshore
Member
Registered: 2018-09-23
Posts: 7

Re: Optirun won't run. Error: Could not enable discrete graphics card

Thanks, updated my post with the information, and corrected the code tags.  These are the solutions I tried (which I just edited into my post).

1. I've added acpi_rev_override=1 and  pcie_port_pm=off to my kernel.
2. I've tried running optirun before suspending.
3. I've added nvidia to my bumblebee.conf file under Driver
4. I've added bbswitch to my modules under mkinitcpio.conf
5. I've tried to force bbswitch to set the status of my card to on without using optirun (but it still remains off).

Offline

#4 2018-11-24 21:42:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,716

Re: Optirun won't run. Error: Could not enable discrete graphics card

Dells seem to be somewhat notorious for this, you might want to look through this thread for a plethora of different approaches that don't necessarily require bbswitch.

Offline

#5 2018-11-27 23:05:14

ddshore
Member
Registered: 2018-09-23
Posts: 7

Re: Optirun won't run. Error: Could not enable discrete graphics card

Are you talking about using nvidia-xrun?   I've looked into that, do you think that's a good option? Or is there something else?

Offline

#6 2018-11-28 03:19:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,716

Re: Optirun won't run. Error: Could not enable discrete graphics card

No, it's about suspending/activating the card with standard linux PCI powermanagement as opposed to the change bbswitch is doing. If you've got that out of the way it doesn't matter whether you use bumblebee or some other approach to access your card, it's about the initial action of disabling/enabling that has issues.

Offline

Board footer

Powered by FluxBB