You are not logged in.

#1 2018-11-27 19:52:21

hardrock
Member
Registered: 2016-12-20
Posts: 6

CUDA driver version is insufficient for CUDA runtime version

I'm trying to run some pytorch script that uses CUDA.

However I'm running into this error, I'm not sure whats wrong.

RuntimeError: cuda runtime error (35) : CUDA driver version is insufficient for CUDA runtime version at /opt/conda/conda-bld/pytorch_1524584710464/work/aten/src/THC/THCGeneral.cpp:70

I have installed CUDA 10.0.130 and nvidia drivers 415.18-4 and according to the CUDA 10 release notes, it should be enough: https://docs.nvidia.com/cuda/cuda-toolk … index.html

root@hardrock [1] hit # pacman -Ss nvidia | grep installed
extra/libvdpau 1.1.1+3+ga21bf7a-1 [installed]
extra/nvidia 415.18-4 [installed]
extra/nvidia-utils 415.18-1 [installed]
extra/opencl-nvidia 415.18-1 [installed]
community/cuda 10.0.130-2 [installed]

Offline

#2 2018-11-28 16:11:46

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,779

Re: CUDA driver version is insufficient for CUDA runtime version

/opt/conda/conda-bld/pytorch_1524584710464/work/aten/src/THC/THCGeneral.cpp:70

are you using this conda ?

Package, dependency and environment management for any language—Python, R, Ruby, Lua, Scala, Java, JavaScript, C/ C++, FORTRAN

It seems that provides the conda part of the infamous anaconda (not the snake).


$ pacman -Ss torch
community/python-pytorch 1.0rc1-5
    Tensors and Dynamic neural networks in Python with strong GPU acceleration
community/python-pytorch-cuda 1.0rc1-5
    Tensors and Dynamic neural networks in Python with strong GPU acceleration
$

We have 2 pytorch packages in community repo and the name of the second one includes cuda.
Native archlinux packages compiled from source tend to work better then things run through some framework system, try python-pytorch-cuda.

Last edited by Lone_Wolf (2018-11-28 16:14:17)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB