You are not logged in.

#1 2018-12-01 12:26:39

alexykot
Member
Registered: 2018-12-01
Posts: 9

gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

`gnome-terminal` fails to start with the following trace:

[alexykot@alexykot-T580 ~]$ gnome-terminal -v
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# Warning: DESKTOP_STARTUP_ID not set and no fallback available.
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)

The only suspicious piece seems to be the

Warning: DESKTOP_STARTUP_ID not set and no fallback available. 

As per some other threads I found this could be related to `locale`, so my localectl now shows this:

[alexykot@alexykot-T580 ~]$ localectl 
   System Locale: LANG=en_GB.UTF-8
                  LANGUAGE=en_US.UTF-8
       VC Keymap: uk
      X11 Layout: n/a

I've tried regenerating and resetting locale, no effect. I think this may be related to something else actually as this problem has started after I tried to fiddle with video drivers for my Nvidia GPU. However that was a while ago and I did not bother debugging it back then, and I don't know what to do to debug this now. Any help or leads will be appreciated.

Offline

#2 2018-12-01 16:41:39

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

strace gnome-terminal

(This is gonna be A LOT of text, but the tail might reveal the problem)

The warning is common.
What might be an issue is the shell?

gnome-terminal -e bash

Online

#3 2018-12-01 20:40:53

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

For `strace gnome-terminal` the last line of the output is

+++ exited with 0 +++

which I assume is exit code 0, i.e. no errors, and rest of the tail is not very informative. Not sure what to make out of it.

The `gnome-terminal -e bash` gives me the same output as with `-v` above except for the warning, so no leads again.

Offline

#4 2018-12-01 22:00:51

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

strace -f gnome-terminal 2>&1 | grep execve

Online

#5 2018-12-02 12:56:32

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

[alexykot@alexykot-T580 ~]$ strace -f gnome-terminal 2>&1 | grep execve
execve("/usr/bin/gnome-terminal", ["gnome-terminal"], 0x7fff15d093a8 /* 42 vars */) = 0

Offline

#6 2018-12-02 13:13:12

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

It doesn't seem to execute any child process (shell) at all.
Is there a stale gnome-terminal process?
Does "gnome-terminal --disable-factory" do anything?

If none of the above,

strace -f gnome-terminal -e /bin/bash > ~/gt.strace 2>&1

- that's going to create a fairly huge ~/gt.strace file.

Online

#7 2018-12-02 13:30:20

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

There is no other `gnome-terminal` process around, `ps aux | grep gnome-terminal` shows nothing. There is an `xfce4-terminal` process running, I'm using that terminal for now since it works fine. I would want to get rid o XFCE though as I'm not using that UI.

`gnome-terminal --disable-factory`:

# Failed to parse arguments: Option “--disable-factory” is no longer supported in this version of gnome-terminal.

sad

I've uploaded `gt.strace` to pastebin, it is big indeed.

Last edited by alexykot (2018-12-02 13:30:34)

Offline

#8 2018-12-02 14:29:46

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

There's abunch of polling timeouts and FD 7 looks like the session bus…

loginctl session-status

Online

#9 2018-12-02 15:29:11

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

[alexykot@alexykot-T580 ~]$ loginctl session-status
2 - alexykot (1000)
           Since: Sat 2018-12-01 21:14:29 GMT; 18h ago
          Leader: 1184 (gdm-session-wor)
            Seat: seat0; vc2
             TTY: tty2
         Service: gdm-password; type wayland; class user
           State: active
            Unit: session-2.scope
                  ├─ 1184 gdm-session-worker [pam/gdm-password]
                  ├─ 1198 /usr/bin/gnome-keyring-daemon --daemonize --login
                  ├─ 1202 /usr/lib/gdm-wayland-session /usr/bin/gnome-session
                  ├─ 1206 /usr/lib/gnome-session-binary
                  ├─ 1239 /usr/bin/gnome-shell
                  ├─ 1266 /usr/bin/Xwayland :0 -rootless -terminate -accessx -core -listen 4 -listen 5 -displayfd 6
                  ├─ 1305 ibus-daemon --xim --panel disable
                  ├─ 1309 /usr/lib/ibus/ibus-dconf
                  ├─ 1310 /usr/lib/ibus/ibus-extension-gtk3
                  ├─ 1312 /usr/lib/ibus/ibus-x11 --kill-daemon
                  ├─ 1387 /usr/lib/gsd-power
                  ├─ 1388 /usr/lib/gsd-print-notifications
                  ├─ 1389 /usr/lib/gsd-rfkill
                  ├─ 1390 /usr/lib/gsd-screensaver-proxy
                  ├─ 1391 /usr/lib/gsd-sharing
                  ├─ 1392 /usr/lib/gsd-sound
                  ├─ 1396 /usr/lib/gsd-xsettings
                  ├─ 1401 /usr/lib/gsd-wacom
                  ├─ 1405 /usr/lib/gsd-smartcard
                  ├─ 1410 /usr/lib/gsd-a11y-settings
                  ├─ 1412 /usr/lib/gsd-clipboard
                  ├─ 1413 /usr/lib/gsd-color
                  ├─ 1416 /usr/lib/gsd-datetime
                  ├─ 1418 /usr/lib/gsd-housekeeping
                  ├─ 1419 /usr/lib/gsd-keyboard
                  ├─ 1424 /usr/lib/gsd-media-keys
                  ├─ 1425 /usr/lib/gsd-mouse
                  ├─ 1444 /usr/lib/gsd-printer
                  ├─ 1479 /usr/lib/ibus/ibus-engine-simple
                  ├─ 1523 /usr/lib/gsd-disk-utility-notify
2 - alexykot (1000)
           Since: Sat 2018-12-01 21:14:29 GMT; 18h ago
          Leader: 1184 (gdm-session-wor)
            Seat: seat0; vc2
             TTY: tty2
         Service: gdm-password; type wayland; class user
           State: active
            Unit: session-2.scope
                  ├─ 1184 gdm-session-worker [pam/gdm-password]
                  ├─ 1198 /usr/bin/gnome-keyring-daemon --daemonize --login
                  ├─ 1202 /usr/lib/gdm-wayland-session /usr/bin/gnome-session
                  ├─ 1206 /usr/lib/gnome-session-binary
                  ├─ 1239 /usr/bin/gnome-shell
                  ├─ 1266 /usr/bin/Xwayland :0 -rootless -terminate -accessx -core -listen 4 -listen 5 -displayfd 6
                  ├─ 1305 ibus-daemon --xim --panel disable
                  ├─ 1309 /usr/lib/ibus/ibus-dconf
                  ├─ 1310 /usr/lib/ibus/ibus-extension-gtk3
                  ├─ 1312 /usr/lib/ibus/ibus-x11 --kill-daemon
                  ├─ 1387 /usr/lib/gsd-power
                  ├─ 1388 /usr/lib/gsd-print-notifications
                  ├─ 1389 /usr/lib/gsd-rfkill
                  ├─ 1390 /usr/lib/gsd-screensaver-proxy
                  ├─ 1391 /usr/lib/gsd-sharing
                  ├─ 1392 /usr/lib/gsd-sound
                  ├─ 1396 /usr/lib/gsd-xsettings
                  ├─ 1401 /usr/lib/gsd-wacom
                  ├─ 1405 /usr/lib/gsd-smartcard
                  ├─ 1410 /usr/lib/gsd-a11y-settings
                  ├─ 1412 /usr/lib/gsd-clipboard
                  ├─ 1413 /usr/lib/gsd-color
                  ├─ 1416 /usr/lib/gsd-datetime
                  ├─ 1418 /usr/lib/gsd-housekeeping
                  ├─ 1419 /usr/lib/gsd-keyboard
                  ├─ 1424 /usr/lib/gsd-media-keys
                  ├─ 1425 /usr/lib/gsd-mouse
                  ├─ 1444 /usr/lib/gsd-printer
                  ├─ 1479 /usr/lib/ibus/ibus-engine-simple
                  ├─ 1523 /usr/lib/gsd-disk-utility-notify
                  ├─ 1526 /opt/whatsie/whatsie
                  ├─ 1529 /usr/lib/firefox/firefox
                  ├─ 1535 /usr/lib/tracker-miner-apps
                  ├─ 1537 /usr/lib/evolution-data-server/evolution-alarm-notify
                  ├─ 1538 /usr/lib/tracker-miner-fs
                  ├─ 1539 /usr/bin/gnome-software --gapplication-service
                  ├─ 1546 /usr/lib/slack/slack
                  ├─ 1547 python3 /usr/lib/gnome-tweak-tool-lid-inhibitor
                  ├─ 1554 /opt/postman/app/Postman
                  ├─ 1556 telegram-desktop --
                  ├─ 1570 xfce4-terminal
                  ├─ 1576 mono --verify-all /usr/share/keepass/KeePass.exe
                  ├─ 1605 /opt/whatsie/whatsie --type=zygote --no-sandbox
                  ├─ 1654 /usr/lib/slack/slack --type=zygote --no-sandbox
                  ├─ 1660 /opt/postman/app/Postman --type=zygote --no-sandbox
                  ├─ 1700 bash
                  ├─ 1936 /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 172524 -schedulerPrefs 0001,2 -parentBuildI>
                  ├─ 1992 /opt/whatsie/whatsie --type=renderer --no-sandbox --primordial-pipe-token=6FF72C950242D7B903A642958247025E --lang=en-US --node-inte>
                  ├─ 2003 /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 82 -prefMapSize 172524 -schedulerPrefs 0001,2 -parentBuild>
                  ├─ 2038 /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 82 -prefMapSize 172524 -schedulerPrefs 0001,2 -parentBuild>
                  ├─ 2042 /usr/lib/firefox/firefox -contentproc -childID 4 -isForBrowser -prefsLen 82 -prefMapSize 172524 -schedulerPrefs 0001,2 -parentBuild>
                  ├─ 2132 /opt/whatsie/whatsie --type=renderer --no-sandbox --primordial-pipe-token=A22C1B91B0B07A3361C489717D16E354 --lang=en-US --node-inte>
                  ├─ 2246 /usr/lib/slack/slack --type=renderer --disable-pinch --force-color-profile=srgb --no-sandbox --service-pipe-token=F408284C2F1B2ACE1>
                  ├─ 2253 /usr/lib/slack/slack --type=renderer --disable-pinch --force-color-profile=srgb --no-sandbox --service-pipe-token=F05B8F9804651BA10>
                  ├─ 2328 /usr/bin/python /usr/bin/chrome-gnome-shell /usr/lib/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json chrome-gnome->
                  ├─ 2368 /opt/postman/app/Postman --type=gpu-process --no-sandbox --supports-dual-gpus=false --gpu-driver-bug-workarounds=7,24,76 --disable->
                  ├─ 2417 /opt/postman/app/Postman --type=renderer --no-sandbox --primordial-pipe-token=B562A6F220FFAE64D0DCEBF046192F2D --lang=en-US --app-p>
                  ├─ 2496 /opt/postman/app/Postman --type=renderer --no-sandbox --primordial-pipe-token=198CB19D3D7F78677F6F304868226FE4 --lang=en-US --app-p>
                  ├─ 2561 /opt/postman/app/Postman --type=renderer --no-sandbox --primordial-pipe-token=487E76EA259D13886F791F281DAB42A2 --lang=en-US --app-p>
                  ├─ 2581 /opt/postman/app/Postman --type=renderer --no-sandbox --primordial-pipe-token=A481667DB28EC25B44A095B71BADBA11 --lang=en-US --app-p>
                  ├─ 4999 /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 5220 -prefMapSize 172524 -schedulerPrefs 0001,2 -parentBui>
                  ├─13650 /usr/lib/slack/slack --type=gpu-process --no-sandbox --supports-dual-gpus=false --gpu-driver-bug-workarounds=1,9,10,27,34,70,84 --d>
                  ├─17482 loginctl session-status
                  └─17483 less

Dec 02 15:26:27 alexykot-T580 org.gnome.Shell.desktop[1239]: >                   This warning only shows for the first high keycode.
Dec 02 15:26:27 alexykot-T580 org.gnome.Shell.desktop[1239]: Errors from xkbcomp are not fatal to the X server
Dec 02 15:26:32 alexykot-T580 gdm-password][17367]: gkr-pam: unlocked login keyring
Dec 02 15:26:32 alexykot-T580 gnome-shell[1239]: System monitor applet enabling
Dec 02 15:26:32 alexykot-T580 gsd-sharing[1391]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-remote-desktop.servi>
Dec 02 15:26:32 alexykot-T580 gnome-shell[1239]: System monitor applet enabling done
Dec 02 15:26:32 alexykot-T580 gnome-shell[1239]: loading default theme (Adwaita)
Dec 02 15:27:13 alexykot-T580 org.gnome.Shell.desktop[1239]: libinput error: client bug: timer event19 debounce: offset negative (-93ms)
Dec 02 15:27:13 alexykot-T580 org.gnome.Shell.desktop[1239]: libinput error: client bug: timer event19 debounce short: offset negative (-106ms)
Dec 02 15:27:13 alexykot-T580 org.gnome.Shell.desktop[1239]: libinput error: client bug: timer event19 debounce: offset negative (-32ms)

Offline

#10 2018-12-02 21:57:18

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

What if you log into a "gnome on Xorg" session?

Online

#11 2018-12-03 10:46:45

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

Well yeah, on Xorg it just works. I do this:

[alexykot@alexykot-T580 ~]$ gnome-terminal 
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)

and it starts normally.


I think this is related to my borked video drivers setup.

This is a laptop with Intel integrated and Nvidia dedicated GPUs. I've tried to change from Intel+nouveau default setup to Nvidia proprietary (for games, yeah), it did work fine, but I found that the battery life seriously decreased comparing to Intel+nouveau PRIME and it could work only on Xorg, while I find wayland more responsive and better to work in. Either way I tried to go back to nouveau, but ended up having none of them. I've uninstalled Nvidia, but with nouveau enabled I get constant CPU soft lockups and unworkable system. So at the moment I blacklisted nouveau at kernel params in UEFI and system functions on only built-in Intel GPU with i915 driver. Clearly inferior performance, but apart from video calls and HD movies it's not really a problem.

I've spent some time trying to make nouveau work again, but with no luck. For now I can live on intel+wayland+xfce terminal and I guess I will need to resetup the system from scratch at some point in the future, probably using Bumblebee.

I'm not sure if it's worth digging further into terminal without touching the drivers problem, I think they are clearly connected. I'm happy to try, but not sure if you would want to deal with that. Either way - thanks for help, wonderful internet stranger smile

Offline

#12 2018-12-03 16:04:06

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

The weird part is that this is a wayland session yet gnome-terminal tries to acces X11.
Do you maybe have sth. like "GDK_BACKEND=x11" exported (check "env")?

Online

#13 2018-12-03 16:52:15

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

Nope, on wayland session `$GDK_BACKEND` is not defined (didn't check on Xorg).

Offline

#14 2018-12-04 16:35:00

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

I googled up (fixed) https://bugzilla.gnome.org/show_bug.cgi?id=776472 - it seems the invocation of a gnome-terminal-server is crucial and the process does not seem to be running for you and there's apparently an "X11 only" history.
You could track that process on either display server.

Online

#15 2018-12-05 23:36:47

frandieguez
Member
Registered: 2015-11-20
Posts: 3

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

Another one affected since the last update on gnome-terminal (using Wayland) 3.30.2-1


$ gnome-terminal -v      
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# Warning: DESKTOP_STARTUP_ID not set and no fallback available.
x# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

Offline

#16 2018-12-06 10:49:24

alexykot
Member
Registered: 2018-12-01
Posts: 9

Re: gnome-terminal does not start with a warning about DESKTOP_STARTUP_ID

My issue is still open, but I'm not going to do anything until my video problems are solved, as I suspect these may be connected.

Offline

Board footer

Powered by FluxBB