You are not logged in.

#1 2018-12-02 00:00:02

Registered: 2011-10-19
Posts: 66

[SOLVED] Epson Workforce 545 - Network printer

I am having trouble getting this printer working.

Cups is enabled and started
avahi .local resolution enabled

I have also installed epson-inkjet-printer-201106w, along with foomatic* and gutenprint, ghostscript, gsfonts for good measure.

Within gnome the printer does show up when trying add  printer, but I get the message "Failed to add new printer".

I know I must be missing something here but I'm not sure what. Does anyone have any idea how I might be able to get printing working. Not sure how relevant this is but the same printer just works under debian so I imagine its just some configuration that that needs to be done under Arch.

Here is the output from lpinfo -v

network http
network ipps
network lpd
network ipp
network socket
network beh
network https
network smb
network dnssd://EPSON%20WorkForce%20545._pdl-datastream._tcp.local/
network lpd://
network ipp://EPSON647E1C.local:631/Epson_IPP_Printer

In applications the Espon IPP printer does show as an option. You cannot print to it though since it seems to be stuck on Getting printer information.

Anyone have any idea what I might try next to get to the bottom of this issue?

Last edited by MikeW (2018-12-02 00:59:38)


#2 2018-12-02 01:02:02

Registered: 2011-10-19
Posts: 66

Re: [SOLVED] Epson Workforce 545 - Network printer

Got the printer working using the web interface. Adding the printer from the web interface fixed the problem. Not sure why it wasn't working using the settings app, but at least its working now.


Board footer

Powered by FluxBB