You are not logged in.

#1 2018-12-03 20:39:12

clidx
Member
Registered: 2015-04-26
Posts: 19

[SOLVED] Kernel panic, unable to mount root fs - out of the blue

I installed Arch on my new laptop. I tried putting it in standby, woke it up and restarted it. Since then it will not boot the kernel with the normal initramfs image but it WILL boot the fallback (after a delay).

The error is almost exactly the same as the one here https://forum.manjaro.org/t/kernel-pani … amfs/50470 exxcept the hex codes are very slightly different.

I tried reinstalling the kernel, rebuilding the initramfs image, nothing works. Since I didn't actually change anything - as in, I didn't update the kernel or change any boot settings which seem to be the most common causes, I'm not sure where to go with this.

The laptop is UEFI and I use rEFInd + PreLoader. rEFInd on sda1 and kernel images on sda5.

Here is some info.

swift% lsblk -f
NAME     FSTYPE      LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                                  
├─sda1   vfat        ESP         4A5A-948B                              45.9M    52% /efi
├─sda2                                                                               
├─sda3   ntfs        Acer        980C5F2E0C5F0722                                    
├─sda4   ntfs        Recovery    6CF6600EF65FD6C4                                    
├─sda5   ext2                    8fbd72f1-f97e-433c-ad92-50c28108288e   83.1M    52% /boot
├─sda6   swap                    3b934819-90a8-41e7-b751-582765cd8ad6                [SWAP]
└─sda7   crypto_LUKS             8b95609b-a3b3-4ade-945f-0686c3b96968                
  └─root btrfs       system      dac84fc0-d402-433e-a5ad-11516e3c077d   91.9G     3% /
swift% cat /boot/refind_linux.conf 
"Boot using default options"	"root=UUID=dac84fc0-d402-433e-a5ad-11516e3c077d cryptdevice=UUID=8b95609b-a3b3-4ade-945f-0686c3b96968:root:allow-discards rootflags=subvol=system rw quiet ipv6.disable=1 initrd=\intel-ucode.img"
swift% uname -a
Linux swift 4.19.4-arch1-1-ARCH #1 SMP PREEMPT Fri Nov 23 09:06:58 UTC 2018 x86_64 GNU/Linux
swift% cat /etc/fstab
# /dev/mapper/root LABEL=system
UUID=dac84fc0-d402-433e-a5ad-11516e3c077d	/         	btrfs     	rw,relatime,compress=lzo,ssd,discard,space_cache,subvol=system	0 0

# /dev/sda5
UUID=8fbd72f1-f97e-433c-ad92-50c28108288e	/boot     	ext2      	rw,relatime,block_validity,barrier,user_xattr,acl	0 2

# /dev/sda1 LABEL=ESP
UUID=4A5A-948B      	/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2

Nothing looks out of the ordinary to me, everything is where it should be. Just for some reason the full initramfs image suddenly won't boot.

Also here are my mkinitcpio hooks. None of them fail to build.
HOOKS=(base udev keyboard keymap encrypt btrfs autodetect modconf block filesystems fsck)

The linux-lts kernel doesn't boot without using the fallback image either.

Now after rerunning mkinitcpio -P a few times, it doesn't get to the point of showing me a kernel panic at all, it just gets stuck on the Acer splash screen. On my laptop the splash screen shows up briefly again in between rEFInd and Linux but it's getting stuck there now.

Last edited by clidx (2018-12-06 20:42:20)

Offline

#2 2018-12-05 16:27:20

clidx
Member
Registered: 2015-04-26
Posts: 19

Re: [SOLVED] Kernel panic, unable to mount root fs - out of the blue

Different day, slightly different error. I turned my laptop on again and even the fallback initrd won't boot. Now the encrypt hook fails to find the UUID and throws me into the emergency shell. But lo and behold, once I change it to cryptdevice=/dev/sda7:root:allow-discards it works.

I quadruple checked the UUID again. It's the right UUID... you can see it from my lsblk output and refind_linux.conf output above.

What gives? In the emergency shell, I can clearly see the UUID there by ls /dev/disk/by-uuid. And I can also manually unlock it using cryptsetup open /dev/disk/by-uuid/8b... etc. The problem is the encrypt hook won't pick up the UUID, it times out waiting for the device to "be ready". Is this worth posting upstream?

Last edited by clidx (2018-12-05 16:35:21)

Offline

#3 2018-12-06 01:21:43

velusip
Member
Registered: 2010-12-01
Posts: 18

Re: [SOLVED] Kernel panic, unable to mount root fs - out of the blue

Can you run a filesystem check (btrfsck) after manually unlocking your container?

Offline

#4 2018-12-06 20:41:11

clidx
Member
Registered: 2015-04-26
Posts: 19

Re: [SOLVED] Kernel panic, unable to mount root fs - out of the blue

That seems to have fixed it, there was a complaint about block group not having the right amount of free space or something.
I'm surprised it worked since the btrfs system is a layer below luks but glad it did, thanks.

Offline

Board footer

Powered by FluxBB