You are not logged in.

#1 2018-12-09 17:39:10

ikidd
Member
Registered: 2018-01-15
Posts: 27

4.19 upgrade: fails to load to DM, network connectivity lost

If I update off of 4.18-16, I get the above symptoms. I can get into an alternate TTY session to rollback, but I have to tether my phone for connectivity, wired and wireless connectivity isn't available.  While in TTY, it continuously throws audit: messages onscreen.  Have many, many kernel messages in log, with some weird stack dump-like sections.

Log file with lspci: https://gist.github.com/ikidd/e33b2e283 … ec7040e948

Any thoughts on what to try for troubleshooting or bug report?

Offline

#2 2018-12-09 17:44:06

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,537
Website

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

From the upgraded kernel, paste the output of `pacman -Q linux` and `uname -a`.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#3 2018-12-09 18:37:37

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Did you want me to commit the update that fails again and have to roll back or can we just go with the update version that's failing?  Here is the package list for the update that fails


Package screenshot

So it's the 4.19-1 update.

If I add

IgnorePkgs=linux linux-headers

to pacman.conf, the update will go fine, and no issues afterwards.

Last edited by ikidd (2018-12-09 18:44:29)

Offline

#4 2018-12-09 19:14:57

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Please post text not pictures of text.  What did you then do to downgrade the kernel and for pacman to fail?  Please include the output from pacman indicating the failure reason.

Offline

#5 2018-12-09 19:40:11

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

loqs wrote:

Please post text not pictures of text.  What did you then do to downgrade the kernel and for pacman to fail?  Please include the output from pacman indicating the failure reason.

Pacman doesn't fail, when I reboot with a 4.19-1 kernel having been updated, the log linked above is the result, with the described issues.

As for using a screenshot, I was stepping through day by day from Nov1 using the ALA to narrow down the packages that caused the failure.  That was by far the easiest way to record the packages in the offending update.  When it failed on Nov 14, I rolled back to the 13th, then started excluding packages and attempting updates until I had just linux and linux-headers excluded (not that I believe the headers are theissue, but I have DKMS packages that would recompile on the wrong header version).

Offline

#6 2018-12-09 19:45:47

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,537
Website

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

I want proof that the installed kernel matches the kernel you boot from when all of these services fail.


Moving to NC...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#7 2018-12-09 19:52:10

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

jasonwryan wrote:

I want proof that the installed kernel matches the kernel you boot from when all of these services fail.


Moving to NC...

I see.  I will do the needful then.

Offline

#8 2018-12-09 20:12:53

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Could you also not post journalctl output with the -x option.
Also please post the contents of every file in /etc/modprobe.d/with the.conf extension.
Edit:

Dec 09 00:54:31 desktop-arch systemd-modules-load[235]: Failed to find module 'options kvm_intel nested=1'

All the other modules load fine this appears to be a broken configuration.

Last edited by loqs (2018-12-09 20:16:17)

Offline

#9 2018-12-09 20:26:11

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

From update on Nov14 ALA:

#pacman -Q linux
linux 4.19.1.arch1-1

#uname -a
Linux desktop-arch 4.19.1-arch1-1-ARCH #1 SMP PREEMPT Sun Nov 4 16:49:26 UTC 2018 x86_64 GNU/Linux

# ls -la /etc/modprobe.d/
total 16
drwxr-xr-x   2 root root  4096 Feb 24  2017 .
drwxr-xr-x 116 root root 12288 Dec  9 13:15 ..

No files in /etc/modprobe.d

Updated gist with journalctl -b

Offline

#10 2018-12-09 20:27:45

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Just saw your update on the kernel switch, investigating.

Offline

#11 2018-12-09 20:31:41

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

https://gist.github.com/ikidd/778c72aa1 … bb0cebdb7/ is returning a 404.
Edit:
If yours is the last post in a thread please edit it rather than creating a new post.
From `man 5 modprobe.d`  the configuration file should be in one of

       /lib/modprobe.d/*.conf
       /etc/modprobe.d/*.conf
       /run/modprobe.d/*.conf

Last edited by loqs (2018-12-09 20:34:27)

Offline

#12 2018-12-09 20:35:42

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

OK, I have no idea where that is coming from, /etc/default/grub.conf is now in the gist I link last comment and does not have that switch in it.

Edit: updated gist to include the 2 files in /lib/modprobe.d, seems to be working for me, but I was probably in editing/adding these files when you tried to look

Last edited by ikidd (2018-12-09 20:41:13)

Offline

#13 2018-12-09 20:51:53

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Sorry still no success with that url.

curl https://gist.github.com/ikidd/778c72aa1f0cbb30ba70602bb0cebdb7
Not Found

Offline

#14 2018-12-09 21:04:50

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Found an intel_kvm.conf in /etc/modules-load.d from Mar.9/18.  I'm pulling that out and retrying update.  I'll be about 15 minutes.

So you figure something was deprecated in the 4.19 kernel that supported that switch?  Because I've been updating fine up until that kernel version.

Edit: pulling that conf file out didn't help, restoring to 4.18 now. And apparently my brand new github account got flagged because I dared to use it without confirming my email address.

Confs you asked for above

Last edited by ikidd (2018-12-09 21:21:08)

Offline

#15 2018-12-09 21:28:56

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Can you post an updated link to the journalctl from the 4.19 boot and also the contents of /etc/mkinitcpio.conf and /etc/modules-load.d/intel_kvm.conf

Offline

#16 2018-12-09 21:54:28

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

I removed virtualbox and virt-manager, did a "modprobe -r  kvm_intel" and then retried the update.  Continued failure.  Journalctl output and confs below.

Journalctl: https://pastebin.com/QGcaKRaa

mkinitcpio.conf: https://pastebin.com/ugZBMRHm

intel_kvm.conf: https://pastebin.com/niG9UVxJ

Note: I moved that conf out of modules.load just into ~ for backup.

Offline

#17 2018-12-09 22:13:28

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Dec 09 14:39:40 desktop-arch nxserver[512]: NX> 595 Cannot set ownership for user nx
Dec 09 14:39:40 desktop-arch nxserver[512]: NX> 595 Permission denied
Dec 09 14:39:40 desktop-arch nxserver[512]: NX> 500 ERROR: Last operation failed.
...
Dec 09 14:39:41 desktop-arch systemd[1]: Failed to start NoMachine Server daemon.

This is the only service I see failing.
There are errors from the amdgpu module but SDDM is not failing.  NetworkManager is is not failing.
If you disable sddm.service and nxserver.service then try 4.19.Y.  Are audit messages still being generated and can you from the console access the internet?

Offline

#18 2018-12-09 22:33:46

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

I've removed nxserver and retried 4.19 with sddm disabled.  Still failing, no network, and attempting to nmtui and activate any network device returns "success" but still no connectivity.

Offline

#19 2018-12-10 00:18:07

loqs
Member
Registered: 2014-03-06
Posts: 7,912

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Network issue with r8169 possibly https://bugs.archlinux.org/task/60832

Offline

#20 2018-12-10 05:25:52

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Must be in combination with something else because a fresh install at 4.19-4 on another partition works.  But I've been tearing apart this install trying to find what's taking it down and having no luck.  Tried every minor release since 4.19-1 and all do the same thing.

Edit: tried 4.19.8 from testing, unsuccessful.

Last edited by ikidd (2018-12-10 05:50:45)

Offline

#21 2018-12-10 09:31:40

seth
Member
Registered: 2012-09-03
Posts: 11,665

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

There's a bunch of amdgpu failures, try

amdgpu.dc=0 amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0

Also elaborate on "but still no connectivity"

ip a
ip r
ping 8.8.8.8

Offline

#22 2018-12-10 14:21:08

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

I'll give those a try.  By no connectivity I mean it has an address but no ping to anything except that address.

Offline

#23 2018-12-10 14:24:57

seth
Member
Registered: 2012-09-03
Posts: 11,665

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Please provide the actual output of those commands.

Offline

#24 2018-12-11 01:33:26

ikidd
Member
Registered: 2018-01-15
Posts: 27

Re: 4.19 upgrade: fails to load to DM, network connectivity lost

Away for a week, I'll bump this when I'm at that computer.

Offline

Board footer

Powered by FluxBB