You are not logged in.

#1 2018-12-15 11:50:49

robotdragonrabbit
Member
Registered: 2018-12-15
Posts: 1

wifi won't connect (Dell Latitude, Intel 9560, iwlwifi)

Hey,

I recently bought a Dell Latitude 5491 (wifi module: Intel 9560, iwlwifi), it shipped with ubuntu, the wifi worked properly, however I didn't check the drivers/settings before deleting it.

I installed Arch, networking with ethernet and Android tethering works fine, available wifi networks are listed properly, but when I try to connect to one in NetworkManager connecting won't succeed. I'm not sure how to debug it, `dmesg -w` logs this during "connecting":

[   32.721969] audit: type=1131 audit(1544874254.186:39): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   35.015994] audit: type=1111 audit(1544874256.480:40): pid=467 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=0fa28303-73e5-4068-8c06-f4b9a4a88b66 name="Puglife" pid=1779 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
[   35.028925] wlo1: authenticate with 18:a6:f7:81:d5:c2
[   35.032594] wlo1: send auth to 18:a6:f7:81:d5:c2 (try 1/3)
[   35.070534] wlo1: authenticated
[   35.071410] wlo1: associate with 18:a6:f7:81:d5:c2 (try 1/3)
[   35.075320] wlo1: RX AssocResp from 18:a6:f7:81:d5:c2 (capab=0x431 status=0 aid=2)
[   35.079024] wlo1: associated
[   35.103201] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready
[   80.022330] wlo1: deauthenticating from 18:a6:f7:81:d5:c2 by local choice (Reason: 3=DEAUTH_LEAVING)

I tried to disable 802.11n according to the wiki: https://wiki.archlinux.org/index.php/Wi … on#iwlwifi , as far as I can tell it just added a bunch of 

[   57.309663] iwlwifi 0000:00:14.3: Unhandled alg: 0x707

to the log

full `dmesg -w` output: https://pastebin.com/PVw9E2fm (with disabled  802.11n)

Maybe I'm overlooking something obvious, but I don't know much about wifi drivers, therefore I'd be thankful for any kind of help

Last edited by robotdragonrabbit (2018-12-15 11:54:56)

Offline

#2 2018-12-27 11:05:40

chrisdb
Member
Registered: 2018-05-16
Posts: 57

Re: wifi won't connect (Dell Latitude, Intel 9560, iwlwifi)

Did you check the following post:
https://bbs.archlinux.org/viewtopic.php?id=233365

Offline

Board footer

Powered by FluxBB