You are not logged in.

#1 2018-12-30 15:45:01

saurabh000345
Member
From: West Bengal, India
Registered: 2018-12-20
Posts: 5
Website

Error in installation of libenglab

I am getting the following message when trying to install libenglab:

Checking to see if a valid gsl library is installed... 2.5
      error: configure: GSL development library, version 1.8 or greater is required
==>ERROR: A failure occurred in build().
      Aborting...
Error making: libenglab

The logs clearly show that I have a gsl library of version 2.5 which is obviously greater than 1.8. What should I do about this issue?

P.S. Though I didn't take very serious notice, there was problem installing the package aoi. And the error kinda said that aoi.sh failed to pass the validation check. If you guys can help me out with that too... It'd be great! smile


Something Rather than Nothing!

Offline

#2 2018-12-30 16:09:20

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,387

Re: Error in installation of libenglab

Moving to AUR Issues.

Offline

#3 2018-12-30 16:10:46

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,635
Website

Re: Error in installation of libenglab

I would guess there was a major change in the gsl library that means that version 2 is not backwards compatible. You will probably need to make a package for an appropriate version of 1.x. Check the configure script and see what it is actually checking for.

As for your other error, if it's reproducible, let the maintainer know. The file is different to what they are expecting.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2018-12-31 01:02:05

loqs
Member
Registered: 2014-03-06
Posts: 7,294

Re: Error in installation of libenglab

https://sourceforge.net/p/englab/code/H … eps/gsl.sh
Edit:
There already was a patch in the git repository but the PKGBUILD was not using it.  Added additional patch to prevent tests being executed instead of ./tests
https://ptpb.pw/you_
Edit2:

ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied

call to ldconfig should probably be removed.
Edit3:

makepkg -odd
==> Making package: aoi 3.0.3-1 (Mon 31 Dec 2018 01:53:28 UTC)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Downloading ArtOfIllusion303-Linux.zip...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   178  100   178    0     0    500      0 --:--:-- --:--:-- --:--:--   500
100   379  100   379    0     0    352      0  0:00:01  0:00:01 --:--:--   952
100   451  100   451    0     0    357      0  0:00:01  0:00:01 --:--:--   357
100   365  100   365    0     0    186      0  0:00:01  0:00:01 --:--:--  2253
100 16.6M  100 16.6M    0     0  3527k      0  0:00:04  0:00:04 --:--:-- 7610k
  -> Found aoi.sh
==> Validating source files with md5sums...
    ArtOfIllusion303-Linux.zip ... FAILED
    aoi.sh ... Passed
==> ERROR: One or more files did not pass the validity check!

From https://sourceforge.net/projects/aoi/fi … ion/3.0.3/ ArtOfIllusion303-Linux.zip was modified in September 2018.

Last edited by loqs (2018-12-31 04:11:20)

Offline

Board footer

Powered by FluxBB