You are not logged in.

#1 2019-01-02 17:05:34

Registered: 2019-01-02
Posts: 4

WiFi LEDs not switching on HP Elitebook 830 G5

I'm having an annoying trouble with the WiFi/Bluetooth LEDs on my HP Elitebook 830 G5 laptop (The other LEDs are working well), if someone can help I'll be really grateful.
WiFi connection is good and the WiFi button also works as expected, phy0-led is present:

# cat /sys/class/leds/phy0-led/trigger


none kbd-scrolllock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock usb-gadget usb-host disk-activity disk-read disk-write ide-disk mtd nand-disk cpu cpu0 cpu1 cpu2 cpu3 panic AC-online BAT0-charging-or-full BAT0-charging BAT0-full BAT0-charging-blink-full-solid rfkill-any rfkill-none rfkill0 phy0rx phy0tx phy0assoc [phy0radio] bluetooth-power hci0-power rfkill1

phy0-led/brightness is switching (0 and 1) as expected, so:

# cat /sys/class/leds/phy0-led/brightness

returns 0 when WiFi is off and 1 when WiFi is on, even though, the LED is always at the same state (0).

hp_wmi and hp_wireless modules are loading by default, I've tried blacklisting hp_wmi with no results.
I've also tried with led_mode="1" param (iwlwifi module) but nothing...

It's working on Windows and on my old HP laptop also worked (and still working) out of the box with Arch. neutral

Edit (additional info):

$ ls /sys/class/leds
input4::capslock  input4::numlock  input4::scrolllock  phy0-led
$ uname -r

On Windows the LED works even with bluetooth off (and WiFi on), but I've also tried with bluetooth powered on (disabled by default) on Linux (bluetooth and WiFi on) and the LED still off (orange on my laptop, should be white).

Last edited by leomp12 (2019-01-02 20:04:08)


Board footer

Powered by FluxBB