You are not logged in.

#1 2019-01-03 18:26:51

isfootaken
Member
Registered: 2019-01-03
Posts: 2

[SOLVED] broadcom bcm4322 scans but can't connect

Recently after an update my wireless adapter has stopped working ( it is a broadcom bcm4322 )
I tried downgrading from the broadcom-wl to broadcom-wl-classic which temporarily fixed the problem but after rebooting
the problem persists.


Here is the relevant journalctl output.

Jan 03 23:21:54 archlinux NetworkManager[586]: <warn>  [1546550514.1260] device (wlan0): Activation: (wifi) association took too long, failing activation
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1260] device (wlan0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1266] manager: NetworkManager state is now DISCONNECTED
Jan 03 23:21:54 archlinux NetworkManager[586]: <warn>  [1546550514.1274] device (wlan0): Activation: failed for connection '=^.^= 1'
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1276] device (wlan0): supplicant interface state: inactive -> disconnected
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1279] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:54 archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1295] device (wlan0): set-hw-addr: set MAC address to 8A:53:C4:BC:D1:F4 (scanning)
Jan 03 23:21:54 archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 03 23:21:54 archlinux NetworkManager[586]: <info>  [1546550514.1969] device (wlan0): supplicant interface state: disconnected -> inactive
Jan 03 23:21:54 archlinux wpa_supplicant[609]: wlan0: Reject scan trigger since one is already pending
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7535] policy: auto-activating connection '=^.^= 1' (8b881d8d-5a3b-45a7-8c06-59d0ec648685)
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7539] device (wlan0): Activation: starting connection '=^.^= 1' (8b881d8d-5a3b-45a7-8c06-59d0ec648685)
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7540] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7543] manager: NetworkManager state is now CONNECTING
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7549] device (wlan0): set-hw-addr: reset MAC address to 00:26:82:46:C4:A7 (preserve)
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7552] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7555] device (wlan0): Activation: (wifi) access point '=^.^= 1' has security, but secrets are required.
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7555] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7557] sup-iface[0x55f6be7c48d0,wlan0]: wps: type pbc start...
Jan 03 23:21:57 archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7653] device (wlan0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7663] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7670] device (wlan0): Activation: (wifi) connection '=^.^= 1' has security, and secrets exist.  No new secrets needed.
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7671] Config: added 'ssid' value '=^.^='
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7671] Config: added 'scan_ssid' value '1'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7671] Config: added 'bgscan' value 'simple:30:-80:86400'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7672] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7672] Config: added 'auth_alg' value 'OPEN'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7672] Config: added 'psk' value '<hidden>'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.7672] Config: added 'ieee80211w' value '1'
Jan 03 23:21:57 archlinux NetworkManager[586]: <info>  [1546550517.8421] device (wlan0): supplicant interface state: inactive -> disconnected
Jan 03 23:21:57 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:21:58 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:21:59 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:00 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:01 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:02 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:03 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:04 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:05 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:06 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:07 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:08 archlinux wpa_supplicant[609]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Jan 03 23:22:09 archlinux sudo[944]:     theo : TTY=pts/0 ; PWD=/home/theo ; USER=root ; COMMAND=/usr/bin/journalctl -xe --no-pager
Jan 03 23:22:09 archlinux sudo[944]: pam_unix(sudo:session): session opened for user root by (uid=0)

Last edited by isfootaken (2019-01-03 19:18:55)

Offline

#2 2019-01-03 19:04:54

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED] broadcom bcm4322 scans but can't connect

See https://bugs.archlinux.org/task/61119

There is a downgraded version of wpa_supplicant in [testing] which should get your wireless working again.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#3 2019-01-03 19:18:36

isfootaken
Member
Registered: 2019-01-03
Posts: 2

Re: [SOLVED] broadcom bcm4322 scans but can't connect

That did the trick. Thanks!

Offline

Board footer

Powered by FluxBB