You are not logged in.

#1 2019-01-04 17:10:59

Registered: 2018-03-24
Posts: 4

[solved]Thunderbolt 2 Dock MacbookAir 7 - Problems with USB3

Hi folks,

I really need your help!
I bought a Thunderbolt 2 Dock from and I'm using it with my MBA 7.1.

The Dock has plenty ports:

After a fresh reboot the HDMI and LAN port works like a charm but the USB3 ports don't!!

A "solution" I found while searching the web was this here:

echo "1" | sudo tee /sys/bus/pci/rescan > /dev/

After this line my keyboard and mouse are working but the problem is that sometime I need to hit a button or shuffle the mouse around to wake up the usb connection.
It's like after a while the usb connections sleeps and I have to wake it up again. So I often miss the first letter of a word  etc.

I put the line via dock.service in systemd

Description=Aktiviert USB bei Thunderboltdock (restart)


ExecStart=sudo sh /home/name/.dock



echo "1" | sudo tee /sys/bus/pci/rescan > /dev/null

But this solution is working even worse than typing it manually in terminal. The connections drops randomly and is not comming back. 

I hope you can understand my poor english !!
have a great weekend and regards!!
your crimp2333

kind of solved. I updated as normal and with the new kernel the dock is recognized. LAN, HDMI, USB is working after a fresh reboot.

Last edited by crimp2333 (2019-01-25 17:06:47)


Board footer

Powered by FluxBB