You are not logged in.

#1 2019-01-06 04:18:53

Todaug
Member
Registered: 2018-10-01
Posts: 15

[SOLVED] Trouble connecting to the wifi at startup

Hello and thank you for taking the time to read my post.

I'm having some trouble connecting to the wifi when my computer just turn on, sometime it can take up to 5 minutes waiting to connect. I have installed Arch on both my desktop and my laptop and they are both having this problem. I'm currently using NetworkManager to connect to my wifi.

I did some research and found that when using KDE (which I'm using) you can fix this problem by storing the wifi password for all user but that did not help.  I also found that the problem can occur if multiple network managers are installed, such as NetworkManager and netctl, but that does not seem to be the case either.

What could be the cause of this ?

Last edited by Todaug (2019-03-08 20:59:10)

Offline

#2 2019-01-06 04:26:43

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,522

Re: [SOLVED] Trouble connecting to the wifi at startup

Moving to Newbie Corner.

Offline

#3 2019-01-06 05:47:17

leomp12
Member
Registered: 2019-01-02
Posts: 8

Re: [SOLVED] Trouble connecting to the wifi at startup

Hello,
You've checked All users may connect to this network in KDE Edit Connection (tab General configuration)?
If yes, the WiFi is connecting automatically after that 5 minutes, right? At this time you've checked NetworkManager systemd unit?

systemctl status NetworkManager

Offline

#4 2019-01-06 09:23:10

seth
Member
Registered: 2012-09-03
Posts: 11,256

Re: [SOLVED] Trouble connecting to the wifi at startup

that does not seem to be the case either

Check, don't guess:

systemctl list-unit-files --state=enabled

Offline

#5 2019-01-06 15:54:27

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

systemctl list-unit-files --state=enabled

UNIT FILE                                   STATE  
autovt@.service                             enabled
dbus-fi.w1.wpa_supplicant1.service          enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
display-manager.service                     enabled
getty@.service                              enabled
NetworkManager-dispatcher.service           enabled
NetworkManager-wait-online.service          enabled
NetworkManager.service                      enabled
ntpd.service                                enabled
sddm.service                                enabled
wpa_supplicant.service                      enabled
remote-fs.target                            enabled

Last edited by Todaug (2019-01-06 16:05:36)

Offline

#6 2019-01-06 15:59:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,723

Re: [SOLVED] Trouble connecting to the wifi at startup

Disable wpa_supplicant.service NetworkManager will start it on demand, having the systemd service enabled in addition leads to issues.

Offline

#7 2019-01-08 23:33:55

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

Ok I disable wpa_supplicant.service and unfortunately that did not solve my problem.

Offline

#8 2019-01-09 08:04:17

seth
Member
Registered: 2012-09-03
Posts: 11,256

Re: [SOLVED] Trouble connecting to the wifi at startup

Please post the output of

systemctl list-units | grep -iE '(net|wpa|dhcp|conn|iwd|wicd)'

and a complete journal ("sudo journalctl -b") after a troublesome wifi connection.

Offline

#9 2019-01-09 08:14:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,723

Re: [SOLVED] Trouble connecting to the wifi at startup

Post an entire

journalctl -b

after reproduction of the issue.

Edit: Ninja'd, I should refresh instead of replying on an older tab hmm

Last edited by V1del (2019-01-09 08:16:12)

Offline

#10 2019-01-10 21:42:53

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

This is the output of journalctl -b after I waited 2 minutes for my wifi to connect. I generated this output right after the wifi was connected.

Jan 10 16:37:22 archlinux systemd[596]: Listening on GnuPG network certificate management daemon.
Jan 10 16:37:22 archlinux systemd[596]: Listening on GnuPG cryptographic agent and passphrase cache (access for web browsers).
Jan 10 16:37:22 archlinux systemd[596]: Listening on GnuPG cryptographic agent and passphrase cache.
Jan 10 16:37:22 archlinux systemd[596]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
Jan 10 16:37:22 archlinux systemd[596]: Reached target Paths.
Jan 10 16:37:22 archlinux sddm-helper[608]: pam_kwallet5: final socket path: /run/user/1002/kwallet5.socket
Jan 10 16:37:22 archlinux systemd[596]: Listening on Sound System.
Jan 10 16:37:22 archlinux systemd[596]: Listening on p11-kit server.
Jan 10 16:37:22 archlinux systemd[596]: Listening on GnuPG cryptographic agent and passphrase cache (restricted).
Jan 10 16:37:22 archlinux systemd[596]: Starting D-Bus User Message Bus Socket.
Jan 10 16:37:22 archlinux systemd[596]: Reached target Timers.
Jan 10 16:37:22 archlinux systemd[596]: Listening on Multimedia System.
Jan 10 16:37:22 archlinux systemd[596]: Listening on D-Bus User Message Bus Socket.
Jan 10 16:37:22 archlinux systemd[596]: Reached target Sockets.
Jan 10 16:37:22 archlinux systemd[596]: Reached target Basic System.
Jan 10 16:37:22 archlinux systemd[596]: Starting Update XDG user dir configuration...
Jan 10 16:37:22 archlinux systemd[596]: xdg-user-dirs-update.service: Succeeded.
Jan 10 16:37:22 archlinux systemd[596]: Started Update XDG user dir configuration.
Jan 10 16:37:22 archlinux systemd[596]: Reached target Default.
Jan 10 16:37:22 archlinux systemd[596]: Startup finished in 24ms.
Jan 10 16:37:22 archlinux sddm-helper[610]: Adding cookie to "/home/todaug/.Xauthority"
Jan 10 16:37:22 archlinux systemd[596]: Started D-Bus User Message Bus.
Jan 10 16:37:23 archlinux klauncher[644]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QStr>
Jan 10 16:37:23 archlinux kdeinit5[649]: Initializing  "kcm_style" :  "kcminit_style"
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Activating service name='org.kde.ActivityManager' requested b>
Jan 10 16:37:23 archlinux kdeinit5[649]: Initializing  "kcm_access" :  "kcminit_access"
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Successfully activated service 'org.kde.ActivityManager'
Jan 10 16:37:23 archlinux kdeinit5[649]: Initializing  "kcm_mouse" :  "kcminit_mouse"
Jan 10 16:37:23 archlinux kaccess[665]: Xlib XKB extension major= 1  minor= 0
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Activating service name='org.kde.kglobalaccel' requested by '>
Jan 10 16:37:23 archlinux kaccess[665]: X server XKB extension major= 1  minor= 0
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Successfully activated service 'org.kde.kglobalaccel'
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Activating service name='ca.desrt.dconf' requested by ':1.11'>
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Successfully activated service 'ca.desrt.dconf'
Jan 10 16:37:23 archlinux org.kde.ActivityManager[616]: Service started, version: 7.0.0
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Activating service name='org.kde.KScreen' requested by ':1.5'>
Jan 10 16:37:23 archlinux ksmserver[674]: Qt: Session management error: networkIdsList argument is NULL
Jan 10 16:37:23 archlinux ksmserver[674]: Configuring Lock Action
Jan 10 16:37:23 archlinux dbus-daemon[616]: [session uid=1002 pid=616] Successfully activated service 'org.kde.KScreen'
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xrandr: Connected output 68 to CRTC 63
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xcb.helper: Detected XRandR 1.6
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xcb.helper: Event Base:  89
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xcb.helper: Event Error:  147
Jan 10 16:37:23 archlinux ksmserver[674]: org.kde.kf5.ksmserver: Starting autostart service  "/etc/xdg/autostart/baloo_file.desktop">
Jan 10 16:37:23 archlinux kdeinit5[647]: kscreen.kded: PowerDevil SuspendSession action not available!
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xrandr: XRandR::setConfig
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xrandr: Requested screen size is QSize(1920, 1080)
Jan 10 16:37:23 archlinux kscreen_backend_launcher[692]: kscreen.xrandr: Needed CRTCs:  1

Last edited by Todaug (2019-01-10 21:43:11)

Offline

#11 2019-01-10 21:55:32

seth
Member
Registered: 2012-09-03
Posts: 11,256

Re: [SOLVED] Trouble connecting to the wifi at startup

That's maybe the tail of the journal, see https://wiki.archlinux.org/index.php/Pastebin

Offline

#12 2019-02-18 00:28:15

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

Ok, I used an external antenna in the last month, just to see if I have the same problem with another WIFI adapter. The external antenna works perfectly and connects immediately to the WIFI as expected. Now, I'm back trying to fix my problem with my internal card. I checked the wiki page you provided me. What do you mean by the tail of the journal? I'm not sure I understand.

Offline

#13 2019-02-18 07:27:20

seth
Member
Registered: 2012-09-03
Posts: 11,256

Re: [SOLVED] Trouble connecting to the wifi at startup

It's just the last few lines.

Did you just use an external antenna or a wifi dongle (ie. a different interface/chip/driver)?

Offline

#14 2019-02-19 01:56:18

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

I used an external antenna. This one...

https://www.amazon.com/KuWFi-Outdoor-Ad … uage=en_US

Offline

#15 2019-03-08 20:58:50

Todaug
Member
Registered: 2018-10-01
Posts: 15

Re: [SOLVED] Trouble connecting to the wifi at startup

reinstalling wpa_supplicant fixed my problem. No more connection issue.

Thank you for your help :-)

Offline

Board footer

Powered by FluxBB