You are not logged in.

#1 2019-01-07 07:56:25

AleWasser
Member
Registered: 2019-01-07
Posts: 1

Problem with Mopidy-Spotify & ncmpcpp

Hey! I've just installed arch since couple of days and i've been trying to use ncmpcpp with my spotify account.
I tried these tutorials:

But i couldn't make it works. Anybody can help me?

Here i paste .conf files:

mopidy.conf

[spotify]
enabled = true
username = ****
password = ****
client_id = ****
client_secret = ****

mopidy.service

[Unit]
Description=Mopidy music server
After=avahi-daemon.service
After=dbus.service
After=network.target
After=nss-lookup.target
After=pulseaudio.service
After=remote-fs.target
After=sound.target

[Service]
User=mopidy
ExecStart=/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf
Type=simple

[Install]
WantedBy=multi-user.target

systemctl --user status mopidy

mopidy.service - Mopidy music server
   Loaded: loaded (/home/ale/.config/systemd/user/mop>
   Active: failed (Result: exit-code) since Mon 2019->
  Process: 12129 ExecStart=/usr/bin/mopidy --config />
 Main PID: 12129 (code=exited, status=216/GROUP)

Also when input mopidy in console it throws these warnings

WARNING  Found local configuration errors, the extension has been automatically disabled:
WARNING    local/media_dir must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
ERROR    Frontend (MpdFrontend) initialization error: MPD server startup failed: [Errno 98] Address already in use

I think i could solve the warnings but i can't understand the error...

Offline

#2 2019-01-10 20:51:30

prosvetlyonniy
Banned
Registered: 2019-01-06
Posts: 25

Re: Problem with Mopidy-Spotify & ncmpcpp

Check and disable all services? It seems you have a conflict with the port and therefore the program cannot occupy the address and port

Offline

#3 2019-01-11 08:23:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,723

Re: Problem with Mopidy-Spotify & ncmpcpp

You probably don't want to use the system wide config for an user service nor explicitly set an user (and don't depend on multi-user.target, you should use default.target for user services). The first tutorial you link does all of that correctly, why is your service that wildly different?

For the other problem check your other services and ensure you don't accidentally mix --user and --system services.

Offline

Board footer

Powered by FluxBB