You are not logged in.

#1 2019-01-08 01:37:18

gilium
Member
Registered: 2019-01-08
Posts: 1

Issues with Thunderbolt 3 on Aero 15x

Hello!

I recently received a Gigabyte Aero 15X as a work machine, and have run Arch from the first day I used it. I had an old Apple Thunderbolt Display from my Macbook Pro days, so I decided to try to pick up a Thunderbolt 3 to Thunderbolt 2 adapter and use it.

Here's a list of things I've tried:
-installing bolt
-installing tbt
-running BIOS and Thunderbolt firmware updates
-checking BIOS for Thunderbolt security options (there are none, but it's in user mode)
-tried both the Apple adapter as well as Startech's adapter.


When I run `boltctl list`, I see no devices with it plugged in, whether it's been plugged in since boot or after. Same with similar tbt commands. `boltctl domains` shows the controller has powered on when the adapter and display are both plugged in. The only relevant info I can find in dmesg is this:

[  558.592128] thunderbolt 0000:07:00.0: switch at 1.1 was rejected by ICM firmware because topology limit exceeded
[  559.225295] thunderbolt 0000:07:00.0: switch at 2.1 was rejected by ICM firmware because topology limit exceeded

Gigabyte only supports Windows 10 for firmware and BIOS updates, so I had to install it on a drive. While in Windows, I noticed the display was picked up, though I wasn't bothered to try to authorize it and get it set up.

This laptop is noted for some ACPI issues with GNU/Linux, so in my ignorance I imagine these two are somewhat related.

What are my next steps for troubleshooting?

Offline

Board footer

Powered by FluxBB