You are not logged in.

#1 2019-01-09 00:15:57

papodaca
Member
Registered: 2016-10-15
Posts: 5

Keyboard does not work at LUKS password prompt

As per title I cannot type the password for my encrypted drive at the early boot. This had all been working just fine until some upgrades, none were to mkinitcpio so its not clear to me what is broken. I have tried adding all the hid modules that are loaded in a boot system to fix this, no dice.

systemd-boot entry:

title   Arch Linux
linux   /vmlinuz-linux
initrd  /initramfs-linux.img
options cryptdevice=UUID=<UUID>:lvm root=/dev/mapper/root rw

mkinitcpio.conf:

MODULES=(sparse_keymap hid hid_generic mac_hid hid_multitouch intel_hid i2c_hid)
BINARIES=()
FILES=()
HOOKS=(base udev autodetect keyboard keymap modconf block encrypt lvm2 filesystems fsck)

Am I missing something obvious here?

Offline

#2 2019-01-09 04:47:16

Lupo Alberto
Member
From: Gomel, Belarus
Registered: 2013-11-25
Posts: 69

Re: Keyboard does not work at LUKS password prompt

If you edited /etc/vconsole.conf try to add consolefont in your HOOK-line.

Offline

#3 2019-01-09 08:38:12

lp
Member
Registered: 2019-01-09
Posts: 4

Re: Keyboard does not work at LUKS password prompt

I had the same problem after systemd 240 upgrade.
Booted with an external USB keyboard to insert LUKS passphrase, then reverted to systemd 239 and all works again.

Offline

#4 2019-01-09 13:58:57

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 137

Re: Keyboard does not work at LUKS password prompt

You haven't said what kind of system this is (i.e. laptop vs desktop) nor what kind of keyboard is being used (i.e. laptop keyboard or usb keyboard etc.).

With that being said - my initial suggestion is to remove all the modules you added to the MODULES() array and instead simply move the keyboard hook to before the autodetect hook in your hooks array.

This is as per the tip at the mkinitcpio wiki's section on common hooks:

Tip: For systems that are booted with different hardware configurations (e.g. laptops with external keyboard vs. internal keyboard or headless systems), it is helpful to place this hook before autodetect in order to always include all keyboard drivers. Otherwise the external keyboard only works in early userspace if it was connected when creating the image.


"the wind-blown way, wanna win? don't play"

Offline

#5 2019-01-09 14:13:09

lp
Member
Registered: 2019-01-09
Posts: 4

Re: Keyboard does not work at LUKS password prompt

Sorry you're right.
Mine is an XPS 15 9560 and only the internal keyboard isn't working and only in initramfs, after that works as usual.
Already have the keyboard hook before autodetect and in MODULES I have only i915.

I tried booting with failsafe mode that, AFAIK, doesn't have autodetect at all (correct me if I'm wrong on that...) and still doesn't work.

Nothing strange shows up in boot logs.

Last edited by lp (2019-01-09 14:13:41)

Offline

#6 2019-01-09 15:05:58

scameronde
Member
Registered: 2019-01-09
Posts: 2

Re: Keyboard does not work at LUKS password prompt

I had exactly the same problem. Downgrading systemd from 240 to 239 solved the problem.

My laptop is a Dell Precision 5530.

The issue seems to be know to the systemd developers: https://github.com/systemd/systemd/issues/11314

Offline

#7 2019-01-09 15:54:40

HalosGhost
Forum Moderator
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,790
Website

Re: Keyboard does not work at LUKS password prompt

I ran into this issue myself; I performed a quick workaround which got me back up and running on 240, but, it's not a solution, it's a workaround.

I moved the keyboard hook to be before the autodetect hook in my /etc/mkinitcpio.conf (and regenerated my initramfsS). As a result, all the keyboard drivers are loaded regardless of what hardware is detected (as I understand it).

Honestly, I'm tempted to leave it this way regardless so that functionally any keyboard will be functional all the time for me.

Edit: I see that at least one user in this thread has already tried this “fix” and had it not function. If so, (assuming the initramfsS were properly rebuilt), then I am sorry it does not function for everyone; it was all I had to do to get a working system for the moment :\

All the best,

-HG

Last edited by HalosGhost (2019-01-09 15:59:06)


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#8 2019-01-09 18:24:18

papodaca
Member
Registered: 2016-10-15
Posts: 5

Re: Keyboard does not work at LUKS password prompt

Sorry yes, I should have mentioned I was attempting to use the laptop keyboard. And like many of the others I am on a similar Dell Precision 5520. I have a workaround in place but it is not ideal at all.

Last edited by papodaca (2019-01-09 18:24:36)

Offline

#9 2019-01-09 18:26:35

lp
Member
Registered: 2019-01-09
Posts: 4

Re: Keyboard does not work at LUKS password prompt

papodaca wrote:

Sorry yes, I should have mentioned I was attempting to use the laptop keyboard. And like many of the others I am on a similar Dell Precision 5520. I have a workaround in place but it is not ideal at all.

Well, with systemd 239.370 it works again, I just downgraded and put systemd in IgnorePkg in pacman.conf.

Offline

#10 2019-01-09 20:39:34

boogy
Member
Registered: 2010-05-20
Posts: 28
Website

Re: Keyboard does not work at LUKS password prompt

Yes I can confirm that downgrading to systemd 239.370 works. I also have a Dell XPS 15 9550 and I had the same problem being unable to enter the LUKS password. Thank for your help.


Where there is a shell, there is a way

Offline

#11 2019-01-10 00:10:57

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 137

Re: Keyboard does not work at LUKS password prompt

Does it matter which init one uses, systemd vs busybox? I have a Precision 5510 and use systemd initrd (i.e. sd-encrypt and sd-lvm2 hooks) and was not affected.

Just to make sure I tried both versions (keyboard before and after autodetect in hooks array) and was able to enter my LUKS passphrase without issue each time.

$pacman -Q linux systemd
linux 4.20.arch1-1
systemd 240.0-3

$grep -v ^# /etc/mkinitcpio.conf
MODULES=(intel_agp i915)
BINARIES=()
FILES=(/etc/modprobe.d/modprobe.conf /etc/modprobe.d/i915.conf /etc/modprobe.d/itco_wdt.conf /etc/modprobe.d/scsi.conf /etc/modprobe.d/dm.conf /etc/sysctl.d/40-max-user-watches.conf)
HOOKS=(base systemd autodetect keyboard modconf block sd-encrypt sd-lvm2 filesystems)
COMPRESSION="lz4"

It looks like OP was using busybox. Also have we confirmed that the system is just not displaying the characters on the screen? (Does entering password and hitting enter allow you in even if nothing is displayed?)

--edit
Now that I think about it, coupled with the systemd bug linked above, I guess it probably has more to do with the udev hook which I currently don't use. Affected people are probably using the udev hook.

Last edited by CarbonChauvinist (2019-01-10 00:36:54)


"the wind-blown way, wanna win? don't play"

Offline

#12 2019-01-10 00:17:26

lp
Member
Registered: 2019-01-09
Posts: 4

Re: Keyboard does not work at LUKS password prompt

CarbonChauvinist wrote:

Does it matter which init one uses, systemd vs busybox? I have a Precision 5510 and use systemd initrd (i.e. sd-encrypt and sd-lvm2 hooks) and was not affected.

Busybox here, didn't try systemd initrd.

CarbonChauvinist wrote:

It looks like OP was using busybox. Also have we confirmed that the system is just not displaying the characters on the screen? (Does entering password and hitting enter allow you in even if nothing is displayed?)

Nope. First thing I tried, hitting enter, no actions at all; using an USB keyboard instead of internal one works.

Offline

#13 2019-01-10 07:24:02

scameronde
Member
Registered: 2019-01-09
Posts: 2

Re: Keyboard does not work at LUKS password prompt

HalosGhost wrote:

I moved the keyboard hook to be before the autodetect hook in my /etc/mkinitcpio.conf (and regenerated my initramfsS). As a result, all the keyboard drivers are loaded regardless of what hardware is detected (as I understand it).

-HG

I also tried this, but with no effect. With systemd - and the udev hook - the keyboard is still not working. I tried to add the relevant kernel modules to the modules section of mkinitcpio.conf, but again without an effect.
I can also confirm that the systemd bug does not only affect notebooks. After upgrading to systemd 240 my desktop pc at home did not work anymore. This time the keyboard is working, but not the graphic card (NVidia 960). Reverting to systemd 239 did fix this problem, too.

edit: spelling

Last edited by scameronde (2019-01-10 07:24:38)

Offline

#14 2019-01-10 08:21:44

sluo
Member
Registered: 2009-10-13
Posts: 7

Re: Keyboard does not work at LUKS password prompt

scameronde wrote:
HalosGhost wrote:

I moved the keyboard hook to be before the autodetect hook in my /etc/mkinitcpio.conf (and regenerated my initramfsS). As a result, all the keyboard drivers are loaded regardless of what hardware is detected (as I understand it).

-HG

I also tried this, but with no effect. With systemd - and the udev hook - the keyboard is still not working. I tried to add the relevant kernel modules to the modules section of mkinitcpio.conf, but again without an effect.
I can also confirm that the systemd bug does not only affect notebooks. After upgrading to systemd 240 my desktop pc at home did not work anymore. This time the keyboard is working, but not the graphic card (NVidia 960). Reverting to systemd 239 did fix this problem, too.

edit: spelling

You need to move keyboard/keymap in front of autodetect and remove all your modules in mkinitcpio.conf as well for the workaround. At least that helped on my Dell XPS13 9360, too.

Offline

#15 2019-01-10 09:17:11

ENOSPC
Member
Registered: 2019-01-10
Posts: 1

Re: Keyboard does not work at LUKS password prompt

I can confirm I have the exact same issue on systemd 240, and both HalosGhost's workaround and reverting to 239 solve the issue. Hardware is Lenovo ThinkPad T480.

Offline

#16 2019-01-10 12:48:04

oifbert
Member
Registered: 2013-03-30
Posts: 2

Re: Keyboard does not work at LUKS password prompt

Had the same issue with the internal keyboard on a Dell XPS 15 9560 laptop (systemd 240). The workaround by HalosGhost didn't work for me. However downgrading to systemd  239.6-1 fixed the issue for me.

Offline

#17 2019-01-10 17:49:40

wzrdtales
Member
Registered: 2017-03-14
Posts: 15

Re: Keyboard does not work at LUKS password prompt

Yup systemd broke it also for me. Have a lenovo thinkpad t580. but I also tried several external keyboards (usb), none worked.

Btw. someone should move this thread, this doesn't relates to "installation".

Last edited by wzrdtales (2019-01-10 17:52:21)

Offline

#18 2019-01-10 21:07:55

waldauf
Member
Registered: 2012-07-15
Posts: 102

Re: Keyboard does not work at LUKS password prompt

I had the same problem - Lenovo T470p. Fixed by systemd downgrading.

I also tried to add "keyboard" in HOOK in mkinitcpio.conf but didn't help.

Offline

#19 2019-01-10 21:20:10

frostschutz
Member
Registered: 2013-11-15
Posts: 811

Re: Keyboard does not work at LUKS password prompt

Did you try with the fallback image / with autodetect hook removed? Keyboard not working is almost always module related in some way.

Wrong layout would be another problem but then LUKS simply won't accept your passphrase (unless you were wise enough to add your passphrase twice, once for your native and once for regular US layout, so LUKS will accept either).

solution in another thread: https://bbs.archlinux.org/viewtopic.php … 5#p1825925

Last edited by frostschutz (2019-01-10 22:55:04)

Offline

#20 2019-01-11 02:04:22

papodaca
Member
Registered: 2016-10-15
Posts: 5

Re: Keyboard does not work at LUKS password prompt

Yes, adding the atkbd to the modules array does indeed get this working with systemd 240.

Last edited by papodaca (2019-01-11 02:09:06)

Offline

#21 2019-09-10 07:13:52

rndstr
Member
Registered: 2011-03-20
Posts: 4

Re: Keyboard does not work at LUKS password prompt

MODULES=(atkbd) does not change anything for me on systemd-243.0-1

does anyone have a download for systemd-239?

Offline

#22 2019-09-10 07:24:39

frostschutz
Member
Registered: 2013-11-15
Posts: 811

Re: Keyboard does not work at LUKS password prompt

@rndstr it would only help if your system was actually using that driver ( you can check from a live cd or anywhere the keyboard works, lsmod and see what is there and what might be missing in your initrd )

you can also try the fallback image

downgrading systemd is not really a good option

Last edited by frostschutz (2019-09-10 07:24:51)

Offline

#23 2019-09-11 01:51:53

rndstr
Member
Registered: 2011-03-20
Posts: 4

Re: Keyboard does not work at LUKS password prompt

thanks @frostschutz; the lsmod list is huge but i see `atkbd` in there:

atkbd 36864 0


fwiw i'm using a Thinkpad X1 Carbon 4th Gen and having the same issue as OP


for some reason I no longer get the boot screen where i can select the fallback image. (it's entirely possible that i disabled that somewhere but don't remember). but I also regenerated the image a couple times so i presume the fallback is in a bad state, too.

Edit: I just updated my system after booting into live usb and it seems to have fixed itself.

Last edited by rndstr (2019-09-11 02:28:15)

Offline

Board footer

Powered by FluxBB