You are not logged in.

#1 2006-08-22 13:17:54

Ole Erik
Member
Registered: 2006-08-06
Posts: 85

Package 'qt-mt', required by 'avahi-qt3', not found

i am trying to install Democracy player from aurbuild, but it keep telling me this:

Package 'qt-mt', required by 'avahi-qt3', not found

Where do i get qt-mt?

also.. The compile tells me this:

Perhaps you should add the directory containing `qt-mt.pc'
to the PKG_CONFIG_PATH environment variable

Can anyone tell me what it means by this?

Offline

#2 2006-08-22 13:26:23

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Package 'qt-mt', required by 'avahi-qt3', not found

qt-mt.pc is provided by qt. So you need to install qt.
Also you do need to have pkgconfig installed.

Offline

#3 2006-08-22 13:38:54

Ole Erik
Member
Registered: 2006-08-06
Posts: 85

Re: Package 'qt-mt', required by 'avahi-qt3', not found

Thanks! The problem is that i understood that qt-mt.pc is provided by qt. So i have allerady installed it.

pkgconfig was also installed and up to date.

Any other sulution?

Offline

#4 2006-08-22 14:02:55

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Package 'qt-mt', required by 'avahi-qt3', not found

ic, the setup script used by democracy is quite stupid. It uses pkg-config --list-all, which errors because the qt part of avahi depends on qt, which is not needed when not using kde...
Anyway, installing qt does not solve this because pkg-config --list-all looks in /usr/lib/pkgconfig, whereas the qt-mt.pc file is installed somewhere in /opt/kde/.
What you need to do is install qt, make a symlink to qt-mt.pc in /usr/lib/pkgconfig, install democracy, remove qt again if you want.

Most obvious, tell the developers of democracy to make a better installer tongue

Offline

#5 2006-08-22 14:21:59

jaboua
Member
Registered: 2005-11-05
Posts: 634

Re: Package 'qt-mt', required by 'avahi-qt3', not found

I tried democracy yesterday, after installing QT and "source /etc/profile" it compiled fine.

I'm unsure why it needs QT to compile though, as it uses GTK2 and after removing QT it still works.

Offline

#6 2006-08-22 14:23:55

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Package 'qt-mt', required by 'avahi-qt3', not found

good point I did need to do a source profile :oops:

jaboua wrote:

I'm unsure why it needs QT to compile though, as it uses GTK2 and after removing QT it still works.

because it uses 'pkg-config --list-all' which errors due to avahi if qt is not installed

Offline

#7 2006-08-22 14:46:14

Ole Erik
Member
Registered: 2006-08-06
Posts: 85

Re: Package 'qt-mt', required by 'avahi-qt3', not found

Thanks.. But it still doesnt work..
How do i make a symlink? I tried "source /etc/profile" but it didnt help..

Anyone? smile

Offline

#8 2006-08-22 14:55:18

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Package 'qt-mt', required by 'avahi-qt3', not found

maybe logging out an back in works ?


others,
symlinking is done using the command 'ln'
see the man page for details.

in this case, as root:
ln -s /opt/qt/lib/pkgconfig/qt-mt.pc /usr/lib/pkgconfig/qt-mt.pc

Offline

#9 2006-08-22 22:05:32

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Package 'qt-mt', required by 'avahi-qt3', not found

Symlinking these files is not useful, most of our PKGBUILDs have a check like this on top of the build() function:

[ -z "${QTDIR}" ] && . /etc/profile.d/qt.sh

Putting this in the PKGBUILD inside build() makes sure the QT profile is always sourced. Ideally, these things should be placed in .install files too.

Offline

Board footer

Powered by FluxBB