You are not logged in.

#1 2019-01-10 03:41:14

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Static noises from headphone jack on laptop

Whenever I plug in headphones into the audio jack on my laptop, there's a static noise. I've tried a lot (see: a LOT) of solutions from the internet. I've disabled loopback mixing, disabled the Intel power saving setting, turned off timer-based scheduling, and muted my microphone, among other things I can't recall from various forums. No dice.

I don't know what generic manufacturer made my laptop or how to find out, but it's an Intel Sandy Bridge model on the C216 chipset with a RealTek ALC662 codec. The issue happens in both Arch as well as other distros (Xubuntu 18.10, Linux Mint 19.1) I've run live. I know it's not my headphones; they work fine on everything else. It's also not general audio, as my speakers work fine.

One more piece of information. The problem only occurs when my laptop's charger is plugged in. As soon as I pull the power cable, the static noise goes away. The internet says that might be some sort of electrical interference issue, but before I buy a new power adapter and hope for the best, I figured I'd ask here first and exhaust the software side.

EDIT: The static stopped when I first unplugged my power supply, but then when I actually played a sound it started right back up. I figured I'd add this in the event it helps.

Last edited by CakeIzGood (2019-01-10 03:45:35)

Offline

#2 2019-01-10 04:56:30

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,313

Re: Static noises from headphone jack on laptop

Your edit seems to indicate the sound card is being placed in a low power mode when not running on shore power.
Do you only get static, or can you hear desired sounds with a low signal to noise ratio?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-01-10 05:04:05

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Re: Static noises from headphone jack on laptop

The sounds play at the set volume as they're supposed to, with the static also persisting. It (the noise) only stops briefly when I unplug the computer, but starts again as soon as something is played or it's plugged back in. Also, after unplugging it to stop the static and then starting it again by either playing a sound or reconnecting the charger, sometimes it will then persist even after I unplug it once more, so it's inconsistent.

Offline

#4 2019-01-11 00:40:59

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Re: Static noises from headphone jack on laptop

I've looked into solutions referring specifically to power saving, but still haven't been able to resolve it. Suggestions of config files relating to audio power saving haven't been helpful, as changing the parameters doesn't fix the noise, if the suggested file even exists. It seems to be a power saving feature of Intel HDA Audio but I'm not sure where I can change it. Turning off audio power saving in TLP didn't fix this, either. I'm really stumped. I also confirmed that the issue persists on a different pair of headphones.

Offline

#5 2019-01-11 08:08:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,860

Re: Static noises from headphone jack on laptop

What's the output of

systool -vm snd_hda_intel

, within [ code ] tags?

Last edited by V1del (2019-01-11 08:09:20)

Offline

#6 2019-01-11 20:27:40

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Re: Static noises from headphone jack on laptop

 $ systool -vm snd_hda_intel
Module = "snd_hda_intel"

  Attributes:
    coresize            = "40960"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "3"
    srcversion          = "DC29E000C145CD072265653"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    align_buffer_size   = "-1"
    bdl_pos_adj         = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    beep_mode           = "N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N"
    enable_msi          = "-1"
    enable              = "Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y"
    id                  = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    index               = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    jackpoll_ms         = "0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"
    model               = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    patch               = "(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)"
    pm_blacklist        = "Y"
    position_fix        = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    power_save          = "0"
    power_save_controller= "Y"
    probe_mask          = "-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1"
    probe_only          = "0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0"
    single_cmd          = "-1"
    snoop               = "-1"

  Sections:

Offline

#7 2019-01-11 20:43:54

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Re: Static noises from headphone jack on laptop

After running this, I also set the parameter power_save_controller to "N." Still nothing.

Offline

#8 2019-01-11 22:19:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,860

Re: Static noises from headphone jack on laptop

That at least looks like it's supposed to as in power saving is disabled, FWIW electric interference doesn't seem far off here.  Only software suggestions I have is try a UEFI/firmware update.

Offline

#9 2019-01-12 18:17:16

CakeIzGood
Member
Registered: 2019-01-10
Posts: 6

Re: Static noises from headphone jack on laptop

Hm. Alright. I'll leave this unmarked for now in case someone tosses something else into the hat, I'll look into trying to update my UEFI (though my motherboard is unsigned from a now non-extant company and I don't know who the generic manufacturer is), and maybe test Windows as painful as it is to see if it happens there too. What's odd to me is that this problem hasn't always existed, which would lead me to believe that it's not a design issue. It also appears to happen on battery power as well as with the charger plugged in. But, I'm no electrician. Maybe I'll just get a USB headset and see if that helps. If anything new develops I'll update the thread.

Offline

Board footer

Powered by FluxBB