You are not logged in.

#1 2019-01-10 07:33:07

mattkelseymk
Member
Registered: 2019-01-10
Posts: 3

[SOLVED] Package not installing correct version of libIlmImf.so

After updating my system, attempting to use ImageMagick commands such as convert began returning the following error:

error while loading shared libraries: libIlmImf-2_2.so.22: cannot open shared object file: No such file or directory

The reason for this is fairly obvious, as that version is not in /usr/lib/. The 'openexr' package delivers the lib, and downgrading that package from archive.archlinux.com just resulted in a similar error with a different version of the library.

Library seems setup fine, just openexr refuses to deliver the correct version?

$ pacman -Ql openexr | grep -i libIlmImf
openexr /usr/lib/libIlmImf-2_3.so.24
openexr /usr/lib/libIlmImf-2_3.so.24.0.0
openexr /usr/lib/libIlmImf.so
openexr /usr/lib/libIlmImfUtil-2_3.so.24
openexr /usr/lib/libIlmImfUtil-2_3.so.24.0.0
openexr /usr/lib/libIlmImfUtil.so
$ ls /usr/lib/libIlmImf* -l
lrwxrwxrwx 1 root root      23 Aug 19 04:44 /usr/lib/libIlmImf-2_3.so.24 -> libIlmImf-2_3.so.24.0.0
-rwxr-xr-x 1 root root 2942848 Aug 19 04:44 /usr/lib/libIlmImf-2_3.so.24.0.0
lrwxrwxrwx 1 root root      23 Aug 19 04:44 /usr/lib/libIlmImf.so -> libIlmImf-2_3.so.24.0.0
lrwxrwxrwx 1 root root      27 Aug 19 04:44 /usr/lib/libIlmImfUtil-2_3.so.24 -> libIlmImfUtil-2_3.so.24.0.0
-rwxr-xr-x 1 root root  157456 Aug 19 04:44 /usr/lib/libIlmImfUtil-2_3.so.24.0.0
lrwxrwxrwx 1 root root      27 Aug 19 04:44 /usr/lib/libIlmImfUtil.so -> libIlmImfUtil-2_3.so.24.0.0

Running lddtree confirms that the correct lib version is not installed.

Thanks

Last edited by mattkelseymk (2019-01-10 21:58:24)

Offline

#2 2019-01-10 07:39:00

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,586

Re: [SOLVED] Package not installing correct version of libIlmImf.so

The convert binary doesn't link, directly or indirectly, to libIlmImf. So this is caused by replacing some official package with an unsupported version.

Offline

#3 2019-01-10 07:43:23

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,843
Website

Re: [SOLVED] Package not installing correct version of libIlmImf.so

Please paste the output of `pacman -Qm`



Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2019-01-10 14:51:46

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED] Package not installing correct version of libIlmImf.so

mattkelseymk wrote:

Running lddtree confirms that the correct lib version is not installed.

But you're not going to show the output of lddtree?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2019-01-10 16:35:15

mattkelseymk
Member
Registered: 2019-01-10
Posts: 3

Re: [SOLVED] Package not installing correct version of libIlmImf.so

jasonwryan wrote:

Please paste the output of `pacman -Qm`

Output of `pacman -Qm`... Unsure what could be causing an issue. Should I sort through these looking for something delivering libIlmImf.so?

android-platform 28_r06-1
android-sdk 26.1.1-1
android-sdk-build-tools r28.0.3-1
android-sdk-platform-tools r25.0.3-1
android-studio 3.1.2.0-1
apfs-fuse-git r63.7acaf79-1
betaflight-configurator 10.4.0-2
bisq-bin 0.6.2-1
chromium-widevine 1:4.10.1192.0-2
clion 1:2018.2.4-1
clion-cmake 1:2018.2.4-1
clion-gdb 1:2018.2.4-1
clion-jre 1:2018.2.4-1
clion-lldb 1:2018.2.4-1
console-bridge 0.4.0-1
discord 0.0.5-5
eagle 9.1.3-1
eigen2 2.0.17-3
ffcast 1:2.5.0-1
flann 1.9.1-3
gegl02 0.2.0-8
gimp-gap 2.6.1-2
goland 2018.1.1-1
goland-jre 2018.1.1-1
google-chrome 70.0.3538.67-1
google-cloud-sdk 194.0.0-1
gtk-theme-arc-git 646.7da711e-1
heroku-cli 7.18.3-1
i3-gaps-git 4.13-2
j4-dmenu-desktop 2.16-1
js 24.2.0-4
js17 17.0.0-4
kubectl-bin 1.10.1-1
lcms 1.19-7
lib32-libtxc_dxtn 1.0.1-5
libc++ 7.0.0-1
libc++abi 7.0.0-1
libc++experimental 7.0.0-1
libinput-gestures 2.29-1
libtbtfwu-git r13.1797ab5-1
libtracker-sparql 1.12.3-1
libtxc_dxtn 1.0.1-6
libxfont 1.5.2-1
log4cxx 0.10.0-4
logmein-hamachi 2.1.0.198-1
minecraft latest-29
minikube-bin 0.26.1-1
minimodem 0.24-1
numix-icon-theme-git 0.r1890.45878a119-1
nvm 0.33.2-1
nwjs-bin 0.34.2-1
package-query 1.9-3
pcmciautils 018-7
pikaur 1.2.25-1
python-catkin_pkg 0.4.8-1
python-empy 3.3.3-1
python-rosdep 0.12.2-1
python-rosdistro 0.6.9-1
python-rospkg 1.1.7-1
python-vcstool 0.1.36-1
quamachi 0.8.0-1
realvnc-vnc-viewer 6.18.625-1
robo3t-bin 1.2.1-1
ros-build-tools 0.2.0-1
ros-melodic-actionlib 1.11.14-1
ros-melodic-actionlib-msgs 1.12.6-1
ros-melodic-actionlib-tutorials 0.1.11-1
ros-melodic-angles 1.9.11-1
ros-melodic-bond 1.8.2-1
ros-melodic-bondcpp 1.8.2-1
ros-melodic-catkin 0.7.14-1
ros-melodic-class-loader 0.4.1-1
ros-melodic-cmake-modules 0.4.1-1
ros-melodic-common-tutorials 0.1.11-1
ros-melodic-control-msgs 1.4.0-1
ros-melodic-cpp-common 0.6.11-1
ros-melodic-executive-smach 2.0.1-1
ros-melodic-filters 1.8.1-1
ros-melodic-gencpp 0.6.0-1
ros-melodic-geneus 2.2.6-1
ros-melodic-genlisp 0.4.16-1
ros-melodic-genmsg 0.5.11-1
ros-melodic-gennodejs 2.0.1-1
ros-melodic-genpy 0.6.7-1
ros-melodic-geometry-msgs 1.12.6-1
ros-melodic-kdl-parser-py 1.13.1-1
ros-melodic-message-filters 1.14.3-1
ros-melodic-message-generation 0.4.0-1
ros-melodic-message-runtime 0.4.12-1
ros-melodic-nodelet 1.9.16-1
ros-melodic-nodelet-tutorial-math 0.1.11-1
ros-melodic-orocos-kdl 1.4.0-1
ros-melodic-pluginlib 1.12.1-1
ros-melodic-pluginlib-tutorials 0.1.11-1
ros-melodic-python-orocos-kdl 1.4.0-1
ros-melodic-ros-environment 1.2.1-1
ros-melodic-rosbag 1.14.3-1
ros-melodic-rosbag-migration-rule 1.0.0-1
ros-melodic-rosbag-storage 1.14.3-1
ros-melodic-rosbuild 1.14.4-1
ros-melodic-rosclean 1.14.4-1
ros-melodic-rosconsole 1.13.7-1
ros-melodic-rosconsole-bridge 0.5.2-1
ros-melodic-roscpp 1.14.3-1
ros-melodic-roscpp-serialization 0.6.11-1
ros-melodic-roscpp-traits 0.6.11-1
ros-melodic-rosgraph 1.14.3-1
ros-melodic-rosgraph-msgs 1.11.2-1
ros-melodic-roslang 1.14.4-1
ros-melodic-roslaunch 1.14.3-1
ros-melodic-roslib 1.14.4-1
ros-melodic-roslz4 1.14.3-1
ros-melodic-rosmaster 1.14.3-1
ros-melodic-rosout 1.14.3-1
ros-melodic-rospack 2.5.2-1
ros-melodic-rosparam 1.14.3-1
ros-melodic-rospy 1.14.3-1
ros-melodic-rostest 1.14.3-1
ros-melodic-rostime 0.6.11-1
ros-melodic-rostopic 1.14.3-1
ros-melodic-rosunit 1.14.4-1
ros-melodic-sensor-msgs 1.12.6-1
ros-melodic-smach 2.0.1-1
ros-melodic-smach-msgs 2.0.1-1
ros-melodic-smach-ros 2.0.1-1
ros-melodic-smclib 1.8.2-1
ros-melodic-std-msgs 0.5.11-1
ros-melodic-std-srvs 1.11.2-1
ros-melodic-tf2 0.6.3-1
ros-melodic-tf2-kdl 0.6.3-1
ros-melodic-tf2-msgs 0.6.3-1
ros-melodic-tf2-py 0.6.3-2
ros-melodic-tf2-ros 0.6.3-1
ros-melodic-topic-tools 1.14.3-1
ros-melodic-trajectory-msgs 1.12.6-1
ros-melodic-urdf 1.13.1-1
ros-melodic-urdf-parser-plugin 1.13.1-1
ros-melodic-urdfdom-py 0.4.0-1
ros-melodic-xmlrpcpp 1.14.3-1
run_scaled-git r18.fa71b3c-1
snapd 2.33.1-3
tbtfwucli-git r13.1797ab5-1
thunderbolt-icm-dkms-git r10.ca5a1a6-1
thunderboltd-git r13.1797ab5-1
tor-browser-en 6.5.1-1
unity-editor 1:2018.2.5f1+20180828-1
unity-editor-android 2018.2.13f1-1
unityhub 1.1.0-2
urdfdom 1.0.0-2
urdfdom-headers 1.0.0-2
visual-studio-code-bin 1.25.0-1
vte3-ng 0.48.3.a-1
vysor r132.fe16088-1
xboxdrv 0.8.8-4
xflux 20130901-5
xflux-gui-git v1.1.10.r28.ga3b55da-1
xrectsel 0.3.2-1
yaourt 1.8.1-1
eschwartz wrote:

But you're not going to show the output of lddtree?

Didn't think it would be helpful, but here it is:

$ lddtree /usr/bin/convert   
/usr/bin/convert (interpreter => /lib64/ld-linux-x86-64.so.2)
    libMagickCore-7.Q16HDRI.so.6 => /usr/lib/libMagickCore-7.Q16HDRI.so.6
        liblcms2.so.2 => /usr/lib/liblcms2.so.2
        libraqm.so.0 => /usr/lib/libraqm.so.0
            libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0
                libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0
                    libpcre.so.1 => /usr/lib/libpcre.so.1
                libgraphite2.so.3 => /usr/lib/libgraphite2.so.3
            libfribidi.so.0 => /usr/lib/libfribidi.so.0
        liblqr-1.so.0 => /usr/lib/liblqr-1.so.0
        libxml2.so.2 => /usr/lib/libxml2.so.2
            libdl.so.2 => /usr/lib/libdl.so.2
            libicuuc.so.63 => /usr/lib/libicuuc.so.63
                libicudata.so.63 => /usr/lib/libicudata.so.63
                libstdc++.so.6 => /usr/lib/libstdc++.so.6
            liblzma.so.5 => /usr/lib/liblzma.so.5
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1
            libexpat.so.1 => /usr/lib/libexpat.so.1
            libuuid.so.1 => /usr/lib/libuuid.so.1
        libfreetype.so.6 => /usr/lib/libfreetype.so.6
            libpng16.so.16 => /usr/lib/libpng16.so.16
        libXext.so.6 => /usr/lib/libXext.so.6
        libX11.so.6 => /usr/lib/libX11.so.6
            libxcb.so.1 => /usr/lib/libxcb.so.1
                libXau.so.6 => /usr/lib/libXau.so.6
                libXdmcp.so.6 => /usr/lib/libXdmcp.so.6
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0
        libz.so.1 => /usr/lib/libz.so.1
        libltdl.so.7 => /usr/lib/libltdl.so.7
        libm.so.6 => /usr/lib/libm.so.6
        libgomp.so.1 => /usr/lib/libgomp.so.1
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1
    libMagickWand-7.Q16HDRI.so.6 => /usr/lib/libMagickWand-7.Q16HDRI.so.6
    libpthread.so.0 => /usr/lib/libpthread.so.0
    libc.so.6 => /usr/lib/libc.so.6

Last edited by mattkelseymk (2019-01-10 16:36:32)

Offline

#6 2019-01-10 17:00:58

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,074
Website

Re: [SOLVED] Package not installing correct version of libIlmImf.so

So in what way does that lddtree output confirm that the correct library is not installed?  As suspected, no version of libIlmImf-2_2.so is in that output at all!

So what was that command that generated the error in your first post?  It wasn't a call to /usr/bin/convert.  Do you have 'convert' as a shell function or alias, or another 'convert' higher in your path?  Show the full command and full output.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2019-01-10 20:01:05

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED] Package not installing correct version of libIlmImf.so

mattkelseymk wrote:

Didn't think it would be helpful, but here it is:

See, this is the classic problem faced by a help forum.

You do not know what is wrong, and you're seeking for help from the people who you implicitly acknowledged were more equipped to do so. That's literally the definition of visiting a help forum and asking for help.

This being the case: what on earth made you think your debugging skills were so amazingly unparalleled that you could confirm beyond a doubt that the lddtree output would not be useful? Because in fact it was incredibly useful.

If you're going to ask for help, it behooves you to be proactive about providing the information that we need. Don't make us fight you to get this information in bits and pieces and dribbles just because you don't *know* that we need it.

Give us the lddtree output.
Give us the full, uncensored command and output when running the program itself.
Give us the output of `type -a convert` so we can verify that you're actually running the same command that you are testing with lddtree.

At the very least, give us any information that was useful enough that you thought to check for yourself.

This will stop us from getting frustrated at you, and it will ensure that you get answers faster. Trilby's advice to check your $PATH could have been the very first reply to this thread, long before four different people started suspiciously interrogating you, had you thought to do so.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#8 2019-01-10 21:56:24

mattkelseymk
Member
Registered: 2019-01-10
Posts: 3

Re: [SOLVED] Package not installing correct version of libIlmImf.so

Trilby wrote:

Do you have 'convert' as a shell function or alias, or another 'convert' higher in your path?

That was indeed the issue, I feel pretty stupid now. Wasn't a problem in $PATH, but `which convert` revealed what might be an older version that didn't get removed correctly in `/usr/local/bin/`. Thank you!

eschwartz wrote:

what on earth made you think your debugging skills were so amazingly unparalleled that you could confirm beyond a doubt that the lddtree output would not be useful?

I am aware my debugging skills are not amazingly unparalleled, that's why I'm asking for help, always trying to improve tongue
My bad for not including the lddtree, I included everything else I checked.

Thanks for the help.

Offline

#9 2019-01-10 22:18:46

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,074
Website

Re: [SOLVED] Package not installing correct version of libIlmImf.so

I'm glad it worked out.  And while I agree with Eschwartz, I must also acknowledge you accepted that rebuke quite gracefully.  Please consider his points in future threads.  You may find value in the document linked below on asking effective questions in tech communities:

http://catb.org/~esr/faqs/smart-questions.html

Last edited by Trilby (2019-01-10 22:20:32)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB