You are not logged in.

#1 2019-01-11 00:48:56

backawhile92
Member
Registered: 2019-01-02
Posts: 5

[SOLVED] openGL problem with graphics on Thinkpad T500

I have an AMD ATI Radeon HD 3650 discrete graphics card in my Thinkpad T500. Everything worked well until Catalyst (the proprietary driver for AMD) was not supported anymore for newer Xorg versions. So I moved to the
open source variant Mesa and this is where I'm having problems. I've tried with my integrated graphics as well as with my discrete graphics card and the issue is the same on both. Whenever I try to
open a game/application/etc. that I'm guessing requires openGL I get this error:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  87
  Current serial number in output stream:  88

I can run Xorg and some apps work well but others won't run and produce this error. I've tried on live distros and there are no issues and I usually get better fps in games and its a lot snappier. I'm
quite inexperienced when it comes to this, so sorry if this is a stupid question. If you need more info (which you probably will) just ask. Here is some quickly:

distro: Arch Linux 64-bit
kernel: 4.20.0-arch1-1-ARCH
CPU: Intel Core 2 Duo T9400
integrated graphics: Intel Mobile 4 Series Chipset
discrete graphics: AMD ATI Radeon HD 3650

Thanks in advance smile

Last edited by backawhile92 (2019-01-12 07:32:30)


the more you know :^)

Offline

#2 2019-01-11 08:02:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,723

Re: [SOLVED] openGL problem with graphics on Thinkpad T500

Do you still have any remnant Xorg config from the catalyst driver or similar? Post a xorg.log, as well as

pacman -Qs libgl
pacman -Qs mesa
pacman -Qs catalyst

Offline

#3 2019-01-12 07:24:09

backawhile92
Member
Registered: 2019-01-02
Posts: 5

Re: [SOLVED] openGL problem with graphics on Thinkpad T500

I don't think so, I'm pretty sure I removed all catalyst packages.

Xorg log:
https://pastebin.com/wwhZPe4A

pacman -Qs libgl

local/lib32-libglvnd 1.1.0-1
    The GL Vendor-Neutral Dispatch library
local/lib32-mesa 18.3.1-1
    An open-source implementation of the OpenGL specification (32-bit)
local/lib32-nvidia-340xx-utils 340.107-3
    NVIDIA drivers utilities (32-bit)
local/libglade 2.6.4-6
    Allows you to load glade interface files in a program at runtime
local/libglvnd 1.1.0-1
    The GL Vendor-Neutral Dispatch library
local/mesa 18.3.1-1
    An open-source implementation of the OpenGL specification
local/nvidia-340xx-utils 340.107-3
    NVIDIA drivers utilities

pacman -Qs mesa

local/glu 9.0.0-5
    Mesa OpenGL Utility library
local/glxinfo 8.4.0-1
    Display info about a GLX extension and OpenGL renderer. Standalone binary
    from the mesa-demos project.
local/lib32-glu 9.0.0-4
    Mesa OpenGL utility library (32 bits)
local/lib32-mesa 18.3.1-1
    An open-source implementation of the OpenGL specification (32-bit)
local/mesa 18.3.1-1
    An open-source implementation of the OpenGL specification
local/mesa-vdpau 18.3.1-1
    Mesa VDPAU drivers
local/opencl-mesa 18.3.1-1
    OpenCL support for AMD/ATI Radeon mesa drivers

No output for pacman -Qs catalyst

Thanks for the help smile

Last edited by backawhile92 (2019-01-12 07:24:38)


the more you know :^)

Offline

#4 2019-01-12 07:30:22

backawhile92
Member
Registered: 2019-01-02
Posts: 5

Re: [SOLVED] openGL problem with graphics on Thinkpad T500

I'm actually retarded. Holy shit I just had to remove one package. The nvidia one, I've been having this problem for over 6 months. Whoops. Thanks you so much.


the more you know :^)

Offline

Board footer

Powered by FluxBB