You are not logged in.

#1 2019-01-16 13:32:21

jddantes
Member
Registered: 2013-07-28
Posts: 39

How to downgrade to OpenCV 3.4?

I needed to downgrade to an earlier version of OpenCV since some frameworks that use it are not compatible with the newer ones.

Looking at this and the wiki,

I did:

sudo pacman -U opencv-3.4.2-1-x86_64.pkg.tar.xz

which installed it, but it cannot be found.

Python 3.7.2 (default, Jan 10 2019, 23:51:51) 
[GCC 8.2.1 20181127] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import cv2
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'cv2'

It does get imported when I upgrade it back to OpenCV 4.

Alternatively, should I just go with pip instead?

Last edited by jddantes (2019-01-16 13:34:09)

Offline

#2 2019-01-16 16:02:50

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,580

Re: How to downgrade to OpenCV 3.4?

opencv 3.4.2-1 was built with python 3.6, so current python is obviously not going to find it. You're better off recompiling the latest 3.4 version yourself

Offline

Board footer

Powered by FluxBB