You are not logged in.

#1 2019-01-19 11:59:49

X1aomu
Member
Registered: 2018-04-08
Posts: 9

[SOLVED]Unable to restart mariadb after upgrading to version 10.3

The pacman's logs:

[2019-01-19 19:25] [ALPM] upgraded mariadb (10.1.37-1 -> 10.3.12-2)
[2019-01-19 19:25] [ALPM-SCRIPTLET] :: MariaDB was updated to a new feature release. To update the data run:
[2019-01-19 19:25] [ALPM-SCRIPTLET]    systemctl restart mariadb.service && mysql_upgrade -u root -p

And journald:

Jan 19 19:29:23 hpArch systemd[1]: Starting MariaDB 10.3.12 database server...
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] /usr/bin/mysqld (mysqld 10.3.12-MariaDB) starting as process 6770 ...
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Using Linux native AIO
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Uses event mutexes
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Number of pools: 1
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Using SSE2 crc32 instructions
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Completed initialization of buffer pool
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Creating shared tablespace for temporary tables
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Waiting for purge to start
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: 10.3.12 started; log sequence number 31024717547; transaction id 2110983
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [ERROR] /usr/bin/mysqld: unknown variable 'innodb_file_format=barracuda'
Jan 19 19:29:23 hpArch mysqld[6770]: 2019-01-19 19:29:23 0 [ERROR] Aborting
Jan 19 19:29:25 hpArch systemd[1]: mariadb.service: Main process exited, code=exited, status=7/NOTRUNNING
Jan 19 19:29:25 hpArch systemd[1]: mariadb.service: Failed with result 'exit-code'.
Jan 19 19:29:25 hpArch systemd[1]: Failed to start MariaDB 10.3.12 database server.

The setting innodb_file_format=barracuda was added in /etc/mysql/my.cnf, which is introduced from https://wiki.archlinux.org/index.php/Ma … cter_limit

My question is how can I successfully upgrade to the new version and don't lose my data at the same time? And how to keep the feature Increase character limit in the new version?

Last edited by X1aomu (2019-01-20 16:06:10)

Offline

#2 2019-01-19 17:34:44

Potomac
Member
Registered: 2011-12-25
Posts: 475

Re: [SOLVED]Unable to restart mariadb after upgrading to version 10.3

remove the line "innodb_file_format=*****" in /etc/mysql/my.cnf,

because the option "innodb_file_format" has been removed in mariadb 10.3, and barracuda is now the default value :

https://community.centminmod.com/thread … ved.14242/

Last edited by Potomac (2019-01-19 17:35:49)

Offline

#3 2019-01-20 16:05:07

X1aomu
Member
Registered: 2018-04-08
Posts: 9

Re: [SOLVED]Unable to restart mariadb after upgrading to version 10.3

Potomac wrote:

remove the line "innodb_file_format=*****" in /etc/mysql/my.cnf,

because the option "innodb_file_format" has been removed in mariadb 10.3, and barracuda is now the default value :

https://community.centminmod.com/thread … ved.14242/

Thanks a lot smile

I removed it and everything seems good. Additionally, innodb_large_prefix = 1 also isn't supported.

Offline

Board footer

Powered by FluxBB