You are not logged in.

#1 2019-01-24 13:40:19

doronc
Member
Registered: 2019-01-24
Posts: 6

Wifi stopped working

Hi,

I am on a Dell laptop with using connman to connect to Wifi networks. lately (I believe this happened after an upgrade) I cannot get to the point where wlan0 is UP. I tried numerous solutions from this forum but it didn't help.

Whenever I start my laptop rfkill tells me all of my devices are soft blocked, this never happened before:

> rfkill
ID TYPE      DEVICE            SOFT      HARD
 0 wlan      dell-wifi      blocked unblocked
 1 bluetooth dell-bluetooth blocked unblocked
 2 wlan      phy0           blocked unblocked

unblocking the devices works:

> sudo rfkill unblock all
[sudo] password for doronc: 
> rfkill                              
ID TYPE      DEVICE              SOFT      HARD
 0 wlan      dell-wifi      unblocked unblocked
 1 bluetooth dell-bluetooth unblocked unblocked
 2 wlan      phy0           unblocked unblocked

but ip a shows wlan0 is down

3: wlan0: <BROADCAST,MULTICAST,DYNAMIC> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 28:16:ad:57:73:fd brd ff:ff:ff:ff:ff:ff

ip link  set wlan0 up returns ok and wlan0 is now UP

> sudo ip link set wlan0 up
> ip link
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 28:16:ad:57:73:fd brd ff:ff:ff:ff:ff:ff

dmesg says the link is not ready when I try to ip set UP

[Jan24 15:34] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

and connman complains about no carrier

connmanctl> scan wifi
Error /net/connman/technology/wifi: No carrier

Some info:

> uname -r
4.20.1-arch1-1-ARCH

> lspci -vvvs 01:00   
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
        Subsystem: Intel Corporation Wireless 8260
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 129
        Region 0: Memory at e1100000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

> lsmod | grep wifi
iwlwifi               348160  1 iwlmvm
cfg80211              778240  3 iwlmvm,iwlwifi,mac80211

> sudo systemctl list-unit-files --state enabled           
UNIT FILE              STATE  
org.cups.cupsd.path    enabled
autovt@.service        enabled
connman.service        enabled
docker.service         enabled
getty@.service         enabled
org.cups.cupsd.service enabled
org.cups.cupsd.socket  enabled
remote-fs.target       enabled

8 unit files listed.

> sudo systemctl list-units | grep -iE 'net|dhcp|wicd|conn'
sys-devices-pci0000:00-0000:00:1c.0-0000:01:00.0-net-wlan0.device                         loaded active plugged   Wireless 8260                                                                
sys-devices-pci0000:00-0000:00:1f.6-net-eth0.device                                       loaded active plugged   Ethernet Connection I219-LM (Latitude E7470)                                 
sys-devices-virtual-net-docker0.device                                                    loaded active plugged   /sys/devices/virtual/net/docker0                                             
sys-subsystem-net-devices-docker0.device                                                  loaded active plugged   /sys/subsystem/net/devices/docker0                                           
sys-subsystem-net-devices-eth0.device                                                     loaded active plugged   Ethernet Connection I219-LM (Latitude E7470)                                 
sys-subsystem-net-devices-wlan0.device                                                    loaded active plugged   Wireless 8260                                                                
run-docker-netns-default.mount                                                            loaded active mounted   /run/docker/netns/default                                                    
connman-vpn.service                                                                       loaded active running   ConnMan VPN service                                                          
connman.service                                                                           loaded active running   Connection service                                                           
network-online.target                                                                     loaded active active    Network is Online                                                            
network.target                                                                            loaded active active    Network 

Thank you for the work you do here

Last edited by doronc (2019-01-24 15:34:55)

Offline

#2 2019-01-24 14:05:20

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,393
Website

Re: Wifi stopped working

doronc wrote:

ip link  set wlan0 up returns ok but does nothing

It didn't "do nothing" it did exactly as it was supposed to.  The interface itself was down before the command, and after it was up.  You need to unblock with rfkill first, then put the interface up with `ip link set wlan0 up`, and then connect with connman or similar tools.

If it still fails, check the output of `dmesg | grep firmware`.

Last edited by Trilby (2019-01-24 14:07:31)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2019-01-24 14:51:18

doronc
Member
Registered: 2019-01-24
Posts: 6

Re: Wifi stopped working

it is not UP after ip link set wlan0 up as you can see in the output I added after the command. as I said, I unblocked rfkill, tried ip set UP, link is still down and connman doesn't work.

> dmesg | grep firmware
[    0.337366] Spectre V2 : Enabling Restricted Speculation for firmware calls
[   18.003367] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   18.133111] iwlwifi 0000:01:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
[   18.357305] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)

Offline

#4 2019-01-24 14:54:35

doronc
Member
Registered: 2019-01-24
Posts: 6

Re: Wifi stopped working

ok now I see that it does show UP but state is still DOWN

3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc mq state DOWN

I also dont understand why are these interfaces blocked on startup?

Last edited by doronc (2019-01-24 14:55:25)

Offline

#5 2019-01-24 14:57:29

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,393
Website

Re: Wifi stopped working

Yes, the interface is up, but you do not have an active connection yet.  This is why I said the steps need to be done in the right order.  Your second-to-last post does seem to suggest there are deeper firmware issues, but I'd still like to first rule out the simpler explanation: connman gave an error do to the interface not being up, then you put the interface up ...  but did you retry connman after that?

As in post #2, first unblock with rfkill, then put up the interface with ip link, then try connman.  The order matters, and it's not clear it you've attempted the steps in this order yet as the only error from connman was from when it ran before putting the interface up.

If this works, we can fine tune it and get to the bottom of why these steps were necessary.  So consider these steps diagnostic.  If this still fails, then we can shift our attention to potential firmware problems.

Last edited by Trilby (2019-01-24 14:58:33)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#6 2019-01-24 15:33:25

doronc
Member
Registered: 2019-01-24
Posts: 6

Re: Wifi stopped working

I did try it the order you suggested I just didn't write it in that order. I edited the first post to be more clear.

> ip link      
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 28:16:ad:57:73:fd brd ff:ff:ff:ff:ff:ff

> sudo connmanctl
[sudo] password for doronc: 
connmanctl> technologies 
/net/connman/technology/ethernet
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = True
  Tethering = False
/net/connman/technology/bluetooth
  Name = Bluetooth
  Type = bluetooth
  Powered = True
  Connected = False
  Tethering = False
/net/connman/technology/wifi
  Name = WiFi
  Type = wifi
  Powered = True
  Connected = False
  Tethering = False
connmanctl> agent on
Agent registered
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Error /net/connman/technology/wifi: No carrier

Last edited by doronc (2019-01-24 15:34:14)

Offline

#7 2019-01-24 15:51:19

seth
Member
Registered: 2012-09-03
Posts: 16,528

Re: Wifi stopped working

Do you have wpa_supplicant installed?

pacman -Qs '(wpa|iwd)'

Offline

#8 2019-01-24 16:04:23

doronc
Member
Registered: 2019-01-24
Posts: 6

Re: Wifi stopped working

yes I do

> pacman -Qs '(wpa|iwd)'
local/wpa_actiond 1.4-3
    Daemon that connects to wpa_supplicant and handles connect and disconnect events
local/wpa_supplicant 2:2.6-2
    A utility providing key negotiation for WPA wireless networks

Offline

#9 2019-01-24 16:08:22

seth
Member
Registered: 2012-09-03
Posts: 16,528

Re: Wifi stopped working

Skip connman, try to explicitly get a carrier using wpa_supplicant directly (after unblocking & up'ing the interface): https://wiki.archlinux.org/index.php/WPA_supplicant
Post any error messages in case of failure.

Offline

#10 2019-01-25 20:51:41

doronc
Member
Registered: 2019-01-24
Posts: 6

Re: Wifi stopped working

wifi is suddenly working now. I have no idea what has changed. thank you for the help and sorry for the trouble

Last edited by doronc (2019-01-25 20:51:55)

Offline

Board footer

Powered by FluxBB