You are not logged in.

#1 2006-08-23 22:16:33

From: Holland
Registered: 2006-05-06
Posts: 14

Can't mount encrypted partition (manually).


I have an encrypted partition (not my root partition btw), I only need it once and a while. It's been weeks since I last needed to mount the partition. Unfortunately, I'm not able to mount it anymore :?

For the sake of my debug run, I created a second encrypted partition (dm-crypt, luks)  on /dev/hda6, like so:

root:[3425]# cryptsetup luksFormat /dev/hda6                                                                                                                                  [krux]

This will overwrite data on /dev/hda6 irrevocably.

Are you sure? (Type uppercase yes): YES
Enter LUKS passphrase: 
Verify passphrase: 
Command successful.
 root:[3426]# cryptsetup luksOpen /dev/hda6 test                                                                                                                               [krux]
Enter LUKS passphrase: 
key slot 0 unlocked.
Command successful.
 root:[3427]# mkreiserfs /dev/mapper/test                                                                                                                                      [krux]
mkreiserfs 3.6.19 (2003

A pair of credits:
Elena Gryaznova performed testing and benchmarking.

Joshua Macdonald wrote the first draft of the transaction manager. Yuri Rupasov
did testing  and benchmarking,  plus he invented the r5 hash  (also used by the
dcache  code).  Yura  Rupasov,  Anatoly Pinchuk,  Igor Krasheninnikov,  Grigory
Zaigralin,  Mikhail  Gilula,   Igor  Zagorovsky,  Roman  Pozlevich,  Konstantin
Shvachko, and Joshua MacDonald are former contributors to the project.

Guessing about desired format.. Kernel 2.6.17-beyond is running.
Format 3.6 with standard journal
Count of blocks on the device: 2588336
Number of blocks consumed by mkreiserfs formatting process: 8290
Blocksize: 4096
Hash function used to sort names: "r5"
Journal Size 8193 blocks (first block 18)
Journal Max transaction length 1024
inode generation number: 0
UUID: 481a3fe4-bef9-48b6-992d-d6bc247003a5
    ALL DATA WILL BE LOST ON '/dev/mapper/test'!
Continue (y/n):y
Initializing journal - 0%....20%....40%....60%....80%....100%

Tell your friends to use a kernel based on 2.4.18 or later, and especially not a
kernel based on 2.4.9, when you use reiserFS. Have fun.

ReiserFS is successfully created on /dev/mapper/test.

So far, nothing out of the ordinary. Then this:

 root:[3428]# mount /dev/mapper/test /mnt/hid                                                                                                                                  [krux]
zsh: permission denied: /dev/mapper/test

Weird, heh? A permission problem, stating the obvious here.

HAL is running, so is DBUS, /etc/fstab is still the same as it always has been.

Here's my partition table:

/dev/hda1 swap
/dev/hda2 /home/krux/storage
/dev/hda3 extended
/dev/hda4 (not part of the extended partition) / (root)
/dev/hda5 /home/ftp
/dev/hda6 (empty, a test partition)
/dev/hda7 (original encrypted partition)
/dev/hda8 (empty)

I can't mount any of my partitions manually, I'll show you:   

root:[3430]# mount -t ext3 /dev/hda8 /home/krux/test                                                                                                                          [krux]
zsh: command not found: -t

Perhaps I've accidentilly deleted a few critical packages a few weeks ago, I tried to clean up my system by removing a couple of packages I didn't think I had used or didn't think I'd have any use of.  :oops:

gparted did show me something interesting:

(for both /dev/hda6 and /dev/hda7)

dumpe2fs 1.39 (date)
dumpe2fs: Invalid argument while reading journal inode

I don't know what this means, but it could be something important.

Any ideas/thoughts/suggestions?

kruxflux (alpha) | kernels: 2.6.17-beyond3-1 |  Intel(R) Pentium(R) 4 (Northwood) CPU 1.80GHz 1816.984 MHz | SAMSUNG SP2514N (250 GB) (dm-crypt) | Screen: nVidia  NV11DDR [GeForce2 MX 100 DDR/200 DDR] (rev b2) @ 1280x1024 (24 bpp)


Board footer

Powered by FluxBB