You are not logged in.

#1 2019-01-25 21:59:39

chbtakano
Member
From: São Paulo/BR
Registered: 2019-01-25
Posts: 2

[SOLVED]Elisa (kde music player) package missing optional dependencies

The current info for the elisa 0.3.0-1 package list as dependencies:

Depends On      : baloo  qt5-quickcontrols  qt5-quickcontrols2  qt5-graphicaleffects  kcmutils
Optional Deps   : None

But using just that will render the application useless, as it cannot play any audio format (tough I only tested with
mp3, mp4 and flac files).

I have found that it is necessary at least gst-plugins-good and gst-libav installed to play these formats.
Does anyone know what is the procedure to inform the package maintainer to include these packages as
optional dependencies?

Last edited by chbtakano (2019-01-27 04:44:38)

Offline

#2 2019-01-26 08:49:47

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,908
Website

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#3 2019-01-27 04:43:01

chbtakano
Member
From: São Paulo/BR
Registered: 2019-01-25
Posts: 2

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

Okay, thanks

Offline

#4 2019-01-27 04:46:28

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

Don't report a bug since it is not a bug.

pacman -Qi qt5-multimedia

Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2019-01-27 11:31:33

progandy
Member
Registered: 2012-05-17
Posts: 3,331

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

eschwartz wrote:

Don't report a bug since it is not a bug.

pacman -Qi qt5-multimedia

Well, that is hidden deep in unrelated dependencies...

elisa -> baloo -> kio -> kbookmarks -> kxmlgui -> ktextwidgets -> qt5-speech -> qt5-multimedia

| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#6 2019-01-27 14:51:33

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

progandy wrote:
eschwartz wrote:

Don't report a bug since it is not a bug.

pacman -Qi qt5-multimedia

Well, that is hidden deep in unrelated dependencies...

elisa -> baloo -> kio -> kbookmarks -> kxmlgui -> ktextwidgets -> qt5-speech -> qt5-multimedia

What is your point? You think this somehow justifies the idea that every package which uses qt5-multimedia in some way should have a duplicated optdepends on things which are internal implementation details of qt5-multimedia?

You've been a member of this forum for more than long enough to know that that is not how Arch Linux works.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#7 2019-01-27 15:38:53

progandy
Member
Registered: 2012-05-17
Posts: 3,331

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

My point was not very deep or well thought out, just that it can be difficult to find necessary dependencies. I would probably have added qt5-multimedia as an explicit dependency for elisa since that provides the core functionality of the music player, but that is the choice of the maintainer and not a bug.

Last edited by progandy (2019-01-27 15:46:33)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#8 2019-01-27 16:35:24

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: [SOLVED]Elisa (kde music player) package missing optional dependencies

That's... a fair point in this case, and there are maintainers who prefer to list directly linked soname dependencies in the PKGBUILD depends rather than relying on transitive links.

But that is not a general solution: there will be cases where optdepends are pulled in in ways that are legitimately that nested.

The correct solution is to actually use a dependency tree resolver to find such issues, like:

paccheck --recursive --opt-depends --quiet $pkgname

Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB