You are not logged in.

#1 2019-01-26 10:49:18

vandijk93
Member
Registered: 2019-01-26
Posts: 3

[Solved] Arch in UEFI: SDDM only shows when pressing keys

Hello everyone,

I have just installed Arch Linux in UEFI mode, this is my first time installing it in UEFI.
I have installed grub, SDDM and plasma-desktop as my desktop environment, and installed the Nvidia drivers (nvidia nvidia-utils), I also installed the intel-ucode and ran grub-mkconfig -o /boot/grub/grub.cfg again after that.
When I boot the computer, it shows me "Starting version 240 - /dev/sda2 clean etc etc.".
It then flashes the 'cursor' (underscore)

It just hangs there until I press ctrl+alt+fX (doesn't matter which F key I press).
When I do that, SDDM starts and I can enter my password. The system works flawless after that, but I have to press the combination to select a console everytime I boot.

I have installed Arch in BIOS mode multiple times and never saw this problem on any system before, so I have searched the ArchWiki on grub, sddm and kde/plasma but haven't found a solution yet.

I don't think it has something to do with grub, because grub runs fine, and when I select the first Arch Linux option, it stats linux, and then it hangs.

Thanks in advance!

Last edited by vandijk93 (2019-01-26 12:37:36)

Offline

#2 2019-01-26 11:42:38

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: [Solved] Arch in UEFI: SDDM only shows when pressing keys

That's a known issue with the kernel's early boot random entropy generation, if your cpu supports it (lscpu | grep rdrand returns something) add random.trust_cpu=on to your kernel parameters otherwise install and enable haveged

FWIW, though that's of course what one intuitively presses, you don't need any combination, just randomly pressing keys should generate entropy which will eventually fill up the random seed needed for SDDM startup to continue.

Last edited by V1del (2019-01-26 11:45:34)

Offline

#3 2019-01-26 12:29:40

vandijk93
Member
Registered: 2019-01-26
Posts: 3

Re: [Solved] Arch in UEFI: SDDM only shows when pressing keys

V1del wrote:

That's a known issue with the kernel's early boot random entropy generation, if your cpu supports it (lscpu | grep rdrand returns something) add random.trust_cpu=on to your kernel parameters otherwise install and enable haveged

FWIW, though that's of course what one intuitively presses, you don't need any combination, just randomly pressing keys should generate entropy which will eventually fill up the random seed needed for SDDM startup to continue.

Hello,

Thank you so much for your quick reply. My CPU seems to support it, because it returns a value.

I have never heard of that random entropy generation. If I understand correctly, SDDM needs some kind of random data to start?
Does this only apply to UEFI installs, of can the same happen to BIOS installs?

Offline

#4 2019-01-26 12:36:48

vandijk93
Member
Registered: 2019-01-26
Posts: 3

Re: [Solved] Arch in UEFI: SDDM only shows when pressing keys

I have added the random.trust_cpu=on to the kernel parameters, and ran grub-mkconfig again so it is persistent.
It reboots just fine now, so the problem is solved!

I would still like to learn a little more about the random entropy generation, as I don't really get the concept. Do you have any information or maybe a website where it is explained?

Thanks in advance!

Offline

#5 2019-01-26 12:59:27

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,238

Re: [Solved] Arch in UEFI: SDDM only shows when pressing keys


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB