You are not logged in.

#1 2019-02-05 18:02:20

eyenseo
Member
Registered: 2014-12-20
Posts: 6

Asus B450-I USB issue

Hello,

I build a new pc with the B450-I motherboard from Asus. My issue is the following: When I plug in a usb stick next to the unifying receiver from logitech (same motherboard hub I guess) then the mouse stops working. Meaning no movement, clicking or scrolling is registered.
My only lead sofar is the following section from dmsg (full https://ptpb.pw/IjsW):

[    1.305323] xhci_hcd 0000:02:00.0: hcc params 0x0200ef81 hci version 0x110 quirks 0x0000000000000410
[    1.305617] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.00
[    1.305618] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.305619] usb usb1: Product: xHCI Host Controller
[    1.305620] usb usb1: Manufacturer: Linux 5.0.0-rc5-mainline xhci-hcd
[    1.305621] usb usb1: SerialNumber: 0000:02:00.0
[    1.305707] hub 1-0:1.0: USB hub found
[    1.305718] hub 1-0:1.0: 10 ports detected
[    1.305801] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT5._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.305890] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT6._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.305970] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT7._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306051] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT8._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306130] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT9._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306207] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.PO10._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306285] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.PO11._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306362] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.PO12._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306441] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.PO13._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306519] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.PO14._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306688] xhci_hcd 0000:02:00.0: xHCI Host Controller
[    1.306690] xhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 2
[    1.306693] xhci_hcd 0000:02:00.0: Host supports USB 3.10 Enhanced SuperSpeed
[    1.306727] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    1.306740] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.00
[    1.306741] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.306742] usb usb2: Product: xHCI Host Controller
[    1.306743] usb usb2: Manufacturer: Linux 5.0.0-rc5-mainline xhci-hcd
[    1.306744] usb usb2: SerialNumber: 0000:02:00.0
[    1.306801] hub 2-0:1.0: USB hub found
[    1.306808] hub 2-0:1.0: 4 ports detected
[    1.306865] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT1._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.306948] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT2._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.307031] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT3._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.307114] ACPI Error: Method parse/execution failed \_SB.PCI0.GPP2.PTXH.RHUB.POT4._PLD, AE_AML_UNINITIALIZED_ELEMENT (20181213/psparse-531)
[    1.307247] xhci_hcd 0000:0a:00.3: xHCI Host Controller
[    1.307250] xhci_hcd 0000:0a:00.3: new USB bus registered, assigned bus number 3
[    1.307342] xhci_hcd 0000:0a:00.3: hcc params 0x0270f665 hci version 0x100 quirks 0x0000000000000410
[    1.307573] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.00
[    1.307574] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.307575] usb usb3: Product: xHCI Host Controller
[    1.307575] usb usb3: Manufacturer: Linux 5.0.0-rc5-mainline xhci-hcd
[    1.307576] usb usb3: SerialNumber: 0000:0a:00.3
[    1.307634] hub 3-0:1.0: USB hub found
[    1.307639] hub 3-0:1.0: 4 ports detected
[    1.307762] xhci_hcd 0000:0a:00.3: xHCI Host Controller
[    1.307763] xhci_hcd 0000:0a:00.3: new USB bus registered, assigned bus number 4
[    1.307765] xhci_hcd 0000:0a:00.3: Host supports USB 3.0  SuperSpeed
[    1.307774] usb usb4: We don't know the algorithms for LPM for this host, disabling LPM.
[    1.307792] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.00
[    1.307793] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.307794] usb usb4: Product: xHCI Host Controller
[    1.307795] usb usb4: Manufacturer: Linux 5.0.0-rc5-mainline xhci-hcd
[    1.307795] usb usb4: SerialNumber: 0000:0a:00.3
[    1.307852] hub 4-0:1.0: USB hub found
[    1.307857] hub 4-0:1.0: 4 ports detected

What can I do to fix that?

Edit:
Further usage of the system showed that I can use a USB 2.0 HDD next to the mouse without issue - USB sticks and USB HDDs of USB 3.0 disable the mouse though.
Everything tested against linux 4.20.7 and 5.0rc5.

Last edited by eyenseo (2019-02-10 22:06:00)

Offline

#2 2019-02-10 21:02:32

majsterek95
Member
Registered: 2017-03-21
Posts: 4

Re: Asus B450-I USB issue

Same problem on b450 chipset with ryzen 2600.
Ps. iommu=off resolve problem

Last edited by majsterek95 (2019-02-11 09:00:29)

Offline

#3 2019-02-10 22:02:08

eyenseo
Member
Registered: 2014-12-20
Posts: 6

Re: Asus B450-I USB issue

majsterek95 wrote:

Same problem on b450 chipset with ryzen 2600.
Ps. iommu=disable resolve problem

Didn't solve the problem for me, but thanks anyways smile

Offline

Board footer

Powered by FluxBB