You are not logged in.

#1 2019-02-05 22:57:47

chrisco23
Member
Registered: 2017-12-13
Posts: 36

[SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

I get this today when trying to 'pacman -Syu' or 'yay'.

Can anyone advise best course of action please?

Thanks,
Chris

Last edited by chrisco23 (2019-02-06 00:52:19)

Offline

#2 2019-02-05 23:01:44

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,957
Website

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

Please paste the full pacman output.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2019-02-05 23:04:45

chrisco23
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing x265 (3.0-1) breaks dependency 'libx265.so=165-64' required by ffmpeg2.8

Offline

#4 2019-02-05 23:14:18

once
Member
From: Taiwan
Registered: 2006-09-12
Posts: 236

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

they forgot rebuild chromium, and everytime x264 x265 update AUR package are mess.

Offline

#5 2019-02-05 23:15:09

chrisco23
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

Thanks, but do you know what I should do here?

Offline

#6 2019-02-05 23:20:43

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,957
Website

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

AUR packages are your responsibility, not pacman's.


Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#7 2019-02-05 23:47:44

chrisco23
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

OK I understand that, but I do not know how to determine which AUR packages are involved even.  I should post to ffmpeg-git aur?  Actually, there are a lot of ffmpeg AUR packages so I don't even know which AUR place to take it to even if that is what I'm supposed to do.

$ pacman -Q ffmpeg
ffmpeg 1:4.1-1
$ sudo pacman -Rns ffmpeg
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencie
:: chromaprint: removing ffmpeg breaks dependency 'ffmpeg'
:: chromium: removing ffmpeg breaks dependency 'ffmpeg'
:: firefox: removing ffmpeg breaks dependency 'ffmpeg'
:: freerdp: removing ffmpeg breaks dependency 'ffmpeg'
:: guvcview-common: removing ffmpeg breaks dependency 'ffmpeg'
:: kfilemetadata: removing ffmpeg breaks dependency 'ffmpeg'
:: mpd: removing ffmpeg breaks dependency 'ffmpeg'
:: mpv: removing ffmpeg breaks dependency 'ffmpeg'
:: qt5-webengine: removing ffmpeg breaks dependency 'ffmpeg'
:: ring-daemon: removing ffmpeg breaks dependency 'ffmpeg'
:: telegram-desktop: removing ffmpeg breaks dependency 'ffmpeg'
:: vlc: removing ffmpeg breaks dependency 'ffmpeg'
:: x264: removing ffmpeg breaks dependency 'libavcodec.so=58-64'
:: x264: removing ffmpeg breaks dependency 'libavformat.so=58-64'
:: x264: removing ffmpeg breaks dependency 'libavutil.so=56-64'
:: x264: removing ffmpeg breaks dependency 'libswscale.so=5-64'

Offline

#8 2019-02-05 23:50:14

loqs
Member
Registered: 2014-03-06
Posts: 8,475

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

:: installing x265 (3.0-1) breaks dependency 'libx265.so=165-64' required by ffmpeg2.8

Do any packages need ffmpeg2.8

pacman -Qi ffmpeg2.8

Offline

#9 2019-02-06 00:20:48

chrisco23
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

I see now, I think.  I have been using it for spek, which I've been using a lot recently to help me clean up my music library.  I don't need spek to block my ability to update though, can possibly find something other than spek if I have to.

So I should post to the spek AUR maybe?

$ pacman -Qi ffmpeg2.8
Name            : ffmpeg2.8
Version         : 2.8.15-2
Description     : Complete solution to record, convert and stream
                  audio and video
Architecture    : x86_64
URL             : https://ffmpeg.org/
Licenses        : GPL3
Groups          : None
Provides        : libavcodec.so=56-64  libavdevice.so=56-64
                  libavfilter.so=5-64  libavformat.so=56-64
                  libavresample.so=2-64  libavutil.so=54-64
                  libpostproc.so=53-64  libswresample.so=1-64
                  libswscale.so=3-64
Depends On      : alsa-lib  bzip2  fontconfig  fribidi  glibc  gmp
                  gnutls  gsm  jack  lame  libmodplug  libpulse
                  libsoxr  libssh  libtheora  libvdpau  libwebp
                  libx11  libxcb  libxext  libxv  opencore-amr
                  openjpeg  opus  schroedinger  sdl  speex
                  v4l-utils  xz  zlib  libass.so=9-64
                  libbluray.so=2-64  dcadec  libfreetype.so=6-64
                  libva.so=2-64  libvidstab.so=1.1-64
                  libvorbisenc.so=2-64  libvorbis.so=0-64
                  libvpx.so=5-64  libx264.so=155-64
                  libx265.so=165-64  libxvidcore.so=4-64
Optional Deps   : ladspa: LADSPA filters [installed]
Required By     : spek
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 17.48 MiB
Packager        : Unknown Packager
Build Date      : Mon 07 Jan 2019 05:56:13 PM PST
Install Date    : Mon 07 Jan 2019 06:10:05 PM PST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : None

$ sudo pacman -Rns ffmpeg2.8
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: spek: removing ffmpeg2.8 breaks dependency 'ffmpeg2.8'

Thanks,
Chris

Offline

#10 2019-02-06 00:28:14

loqs
Member
Registered: 2014-03-06
Posts: 8,475

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

I would suggest removing ffmpeg2.8 and spek then doing the full system upgrade.  You could then build an updated ffmpeg2.8 and reinstall spek.

Offline

#11 2019-02-06 00:29:17

metak
Member
Registered: 2009-09-27
Posts: 189

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

You need to rebuild your ffmpeg2.8 package for the latest x265 update (libx265.so=169-64). You could also try spek-git which according to the comment on spek aur page, supports latest ffmpeg.

Offline

#12 2019-02-06 00:51:24

chrisco23
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED]installing x265 (3.0-1) breaks dependency 'libx265.so=165-64'

Yes!  spek-git seems to have straightened me out.

Thanks all for the quick responses!

Offline

Board footer

Powered by FluxBB