You are not logged in.

#1 2019-02-06 23:27:45

cluxter
Member
Registered: 2015-08-10
Posts: 11

[SOLVED] lightdm won't start after upgrade

Hi

I upgraded my system with:

pacman -Syu

Since then, lightdm displays a black screen with a blinking cursor at the top left corner.

However, if I go to another console, log in, and run:

startxfce4

xfce4 runs fine. So that tells us that the graphic driver is fine.

I upgraded a second computer also using ArchLinux (and also having an integrated Intel graphic card) and got the same issue right away (xfce4 also running fine).

Here are some logs:


/var/log/lightdm/lightdm.log

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.28.0, UID=0 PID=814
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Monitoring logind for seats
[+0.01s] DEBUG: New seat added from logind: seat0
[+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.01s] DEBUG: Seat seat0: Starting
[+0.01s] DEBUG: Seat seat0: Creating greeter session
[+0.01s] DEBUG: Seat seat0: Creating display server of type x
[+0.01s] DEBUG: posix_spawn avoided (fd close requested) 
[+0.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.01s] DEBUG: Using VT 7
[+0.01s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.01s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.01s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.01s] DEBUG: XServer 0: Launching X Server
[+0.01s] DEBUG: Launching process 820: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.01s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.02s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.02s] DEBUG: User /org/freedesktop/Accounts/User1000 added


/var/log/lightdm/seat0-greeter.log

** Message: 18:34:41.307: Starting lightdm-gtk-greeter 2.0.6 (Sep 30 2018, 09:14:12)
** Message: 18:34:41.311: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf

** (lightdm-gtk-greeter:763): WARNING **: 18:34:42.340: [PIDs] Failed to execute command: /usr/lib/at-spi2-core/at-spi-bus-launcher

** (lightdm-gtk-greeter:763): WARNING **: 18:34:42.341: [PIDs] Failed to execute command: upstart

(lightdm-gtk-greeter:763): Gtk-WARNING **: 18:34:42.470: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:763): Gtk-WARNING **: 18:34:47.826: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:763): Gtk-WARNING **: 18:34:47.840: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)


/var/log/lightdm/x-1.log

X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux thinkpadX1-b 4.20.6-arch1-1-ARCH #1 SMP PREEMPT Thu Jan 31 08:22:01 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/mapper/vgArchLinux-lvSystem rw quiet
Build Date: 25 October 2018  04:42:32PM
 
Current version of pixman: 0.36.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Wed Feb  6 22:56:12 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.


/var/log/Xorg.1.log

[   481.907] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   481.907] 
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[   481.907] Build Operating System: Linux Arch Linux
[   481.907] Current Operating System: Linux thinkpadX1-b 4.20.6-arch1-1-ARCH #1 SMP PREEMPT Thu Jan 31 08:22:01 UTC 2019 x86_64
[   481.907] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/mapper/vgArchLinux-lvSystem rw quiet
[   481.907] Build Date: 25 October 2018  04:42:32PM
[   481.907]  
[   481.907] Current version of pixman: 0.36.0
[   481.907] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   481.907] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   481.907] (==) Log file: "/var/log/Xorg.1.log", Time: Wed Feb  6 22:56:12 2019
[   481.907] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   481.907] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   481.907] (==) No Layout section.  Using the first Screen section.
[   481.907] (==) No screen section available. Using defaults.
[   481.907] (**) |-->Screen "Default Screen Section" (0)
[   481.907] (**) |   |-->Monitor "<default monitor>"
[   481.907] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   481.907] (==) Automatically adding devices
[   481.907] (==) Automatically enabling devices
[   481.907] (==) Automatically adding GPU devices
[   481.907] (==) Automatically binding GPU devices
[   481.907] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   481.907] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[   481.907] (==) ModulePath set to "/usr/lib/xorg/modules"
[   481.907] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   481.907] (II) Module ABI versions:
[   481.907] 	X.Org ANSI C Emulation: 0.4
[   481.907] 	X.Org Video Driver: 24.0
[   481.907] 	X.Org XInput driver : 24.1
[   481.907] 	X.Org Server Extension : 10.0
[   481.908] (++) using VT number 7

[   481.908] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   481.908] (II) xfree86: Adding drm device (/dev/dri/card0)
[   481.908] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[   481.911] (--) PCI:*(0@0:2:0) 8086:5917:17aa:2244 rev 7, Mem @ 0x2ffa000000/16777216, 0x2fa0000000/268435456, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[   481.911] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   481.911] (II) LoadModule: "glx"
[   481.911] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   481.913] (II) Module glx: vendor="X.Org Foundation"
[   481.913] 	compiled for 1.20.3, module version = 1.0.0
[   481.913] 	ABI class: X.Org Server Extension, version 10.0
[   481.913] (==) Matched intel as autoconfigured driver 0
[   481.913] (==) Matched modesetting as autoconfigured driver 1
[   481.913] (==) Matched fbdev as autoconfigured driver 2
[   481.913] (==) Matched vesa as autoconfigured driver 3
[   481.913] (==) Assigned the driver to the xf86ConfigLayout
[   481.913] (II) LoadModule: "intel"
[   481.913] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   481.913] (II) Module intel: vendor="X.Org Foundation"
[   481.913] 	compiled for 1.20.3, module version = 2.99.917
[   481.913] 	Module class: X.Org Video Driver
[   481.913] 	ABI class: X.Org Video Driver, version 24.0
[   481.913] (II) LoadModule: "modesetting"
[   481.913] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   481.924] (II) Module modesetting: vendor="X.Org Foundation"
[   481.924] 	compiled for 1.20.3, module version = 1.20.3
[   481.924] 	Module class: X.Org Video Driver
[   481.924] 	ABI class: X.Org Video Driver, version 24.0
[   481.924] (II) LoadModule: "fbdev"
[   481.924] (WW) Warning, couldn't open module fbdev
[   481.924] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   481.924] (II) LoadModule: "vesa"
[   481.924] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   481.925] (II) Module vesa: vendor="X.Org Foundation"
[   481.925] 	compiled for 1.20.0, module version = 2.4.0
[   481.925] 	Module class: X.Org Video Driver
[   481.925] 	ABI class: X.Org Video Driver, version 24.0
[   481.925] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   481.925] (II) intel: Driver for Intel(R) HD Graphics
[   481.925] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   481.925] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   481.925] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   481.925] (II) VESA: driver for VESA chipsets: vesa
[   481.925] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[   481.934] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180921
[   481.934] (II) intel(0): SNA compiled from 2.99.917-859-g33ee0c3b
[   481.950] (WW) Falling back to old probe method for modesetting
[   484.359] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[   484.359] (II) intel(0): [drm] Contents of '/sys/kernel/debug/dri/0/clients':
[   484.359] (II) intel(0): [drm]              command   pid dev master a   uid      magic
[   484.359] (II) intel(0): [drm]                 Xorg  1004   0   y    y     0          0
[   484.359] (II) intel(0): [drm]                 Xorg 21949   0   n    y     0          0
[   484.359] (EE) intel(0): Failed to claim DRM device.
[   484.359] (II) UnloadModule: "intel"
[   484.359] (EE) Screen(s) found, but none have a usable configuration.
[   484.359] (EE) 
Fatal server error:
[   484.359] (EE) no screens found(EE) 
[   484.359] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   484.359] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[   484.359] (EE) 
[   484.393] (EE) Server terminated with error (1). Closing log file.

Last edited by cluxter (2019-02-07 10:24:09)

Offline

#2 2019-02-07 00:20:02

sammiev
Member
Registered: 2018-12-22
Posts: 13

Re: [SOLVED] lightdm won't start after upgrade

The fix has been release, a quick search would have informed you.
Update again and it should be there. smile

Offline

#3 2019-02-07 09:58:38

cluxter
Member
Registered: 2015-08-10
Posts: 11

Re: [SOLVED] lightdm won't start after upgrade

Thank you for your answer.

I didn't think about going to the ArchLinux bug tracker. Thanks to you I checked it and saw the bug report here: https://bugs.archlinux.org/index.php?do … k_id=61654

However I updated my system but nothing showed up so far. I'll wait until the new version of the package is pushed into the repos.

Thanks again!

EDIT: I used a more up-to-date repo and I immediately got the update smile

Last edited by cluxter (2019-02-07 10:23:42)

Offline

Board footer

Powered by FluxBB