You are not logged in.

#1 2019-02-08 23:05:43

Skripka
Member
From: 2X1280X1024
Registered: 2009-02-19
Posts: 555

[REQUEST] "Das Keyboard 5Q Software"

This software is for a hardware keyboard from Das.  DK supplies an official Debian package of their files here:https://www.daskeyboard.io/get-started/software/ ...Debian not being native at all....A kind Fedora user is packaging an unofficial RPMs (and RPMs are less not native I suppose as there are tutorials for RPM->Arch) here: https://copr.fedorainfracloud.org/coprs … eyboard-q/

Having an RPM already made, and some tutorials available to PKGBUILD RPMs, I stuck to that path.  Not new to Arch...but not having played with PKGBUILDs myself for years...I tried to keep it simple and primitive with the file names hard-coded in the PKGBUILD with my own supplied checksum:

  # Maintainer: XXXXXX <XXXXXX@gmail.com>
pkgname=Das-Keyboard-5Q-Software
pkgver=3.2.1
pkgrel=2
pkgdesc="Drivers and software for Das Keyboard 5Q."
arch=('x86_64')
url=https://www.daskeyboard.io/get-started/software/
license=('unknown')
depends=('libidn')
makedepends=('rpmextract')
options=('emptydirs')
source=("https://copr-be.cloud.fedoraproject.org/results/appelond/das-keyboard/fedora-29-x86_64/00854557-das-keyboard-q/das-keyboard-q-3.2.1-01.x86_64.rpm")
md5sums=('e404a9f176ef36f2a0e0e535ab0008fa')


build() {
    mkdir "$pkgname-$pkgver"
  cd "$pkgname-$pkgver"
    rpmextract.sh ../das-keyboard-q-3.2.1-01.x86_64.rpm
}

package() {
  cd "$pkgname-$pkgver"

  make DESTDIR="$pkgdir/" install
}

Now, I know bsdtar supersedes rpmextract, but I was working off an old post of doing PKGBUILD off an RPM.... Which errors out with the below...I've tried several variations on the above PKGBUILD, but am getting frustrated and shooting in the dark:

[marcus@ScarGlamour_Manjaro DasKeyboardDriver]$ makepkg
==> Making package: Das-Keyboard-5Q-Software 3.2.1-2 (Fri 08 Feb 2019 04:59:55 PM CST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found das-keyboard-q-3.2.1-01.x86_64.rpm
==> Validating source files with md5sums...
    das-keyboard-q-3.2.1-01.x86_64.rpm ... Passed
==> Extracting sources...
  -> Extracting das-keyboard-q-3.2.1-01.x86_64.rpm with bsdtar
==> Starting build()...
==> Entering fakeroot environment...
==> Starting package()...
make: *** No rule to make target 'install'.  Stop.
==> ERROR: A failure occurred in package().
    Aborting...
[marcus@ScarGlamour_Manjaro DasKeyboardDriver]$ 

I'm guessing half of the problem is starting with an RPM.  But I'm not sure how to work around it....and the tuorials I found on doing this were fairly well ancient (2010-2015).  I'm also guessing that the solution is fairly simple and I'm far too rusty to see it.

In an ideal world...I'd not need hard-coded hashes and would grab the latest RPM/code from Das or otherwise rather than a static URL that needs updated everytime a release is made...but I've been trying the easy way before getting fancy.

Thanks all!

Last edited by Skripka (2019-02-08 23:10:20)

Offline

#2 2019-02-08 23:43:21

loqs
Member
Registered: 2014-03-06
Posts: 7,453

Re: [REQUEST] "Das Keyboard 5Q Software"

noextract=('das-keyboard-q-3.2.1-01.x86_64.rpm')

package() {
  bsdtar -xf das-keyboard-q-3.2.1-01.x86_64.rpm -C "${pkgdir}"
}

I am assuming good faith in that you are using arch linux and having ScarGlamour_Manjaro in your prompt does not indicate you are using Manjaro.
pkgname must be all lowercase.  pkgdescription should not include pkgname.  namcap is detecting some missing dependencies.  You can not identify any license from upstream?

Offline

Board footer

Powered by FluxBB