You are not logged in.

#1 2019-03-06 16:15:05

mabvmet
Member
Registered: 2019-03-06
Posts: 7

Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Hi.

I know this is a very common issue, but I haven't fixed it. Actually, is a problem every time that I make an upgrade. I hope you help me to understand how to identify the problem and how to fix it in the future by myself.

- I did #pacman -Syyu and after the full process, I restart my pc and there was not automatic GUI, I only have a basic, black screen, terminal.
- The kernel was updated too, currently I have the version 5.0.0.
- I've reinstalled xorg, gnome, gdm, gnome-session. and there is no change.

I don't have an idea how to solve this. Some help will be appreciated.
Sorry if this a very novel question. Thanks in advance.

Offline

#2 2019-03-06 16:20:02

HalosGhost
Forum Moderator
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,876
Website

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

mabvmet wrote:

Hi.

Hello. Welcome to the BBS.

#pacman -Syyu

Don't do that. It's just mean to the servers; -Syu is plenty.

and after the full process, I restart my pc and there was not automatic GUI, I only have a basic, black screen, terminal

You're saying that, after updating and restarting, you don't get your graphical greeter? Out of interest, if you reboot when you have not just updated, do you get your graphical greeter? I'm betting not.

I've reinstalled xorg, gnome, gdm, gnome-session. and there is no change.

This should not be necessary (really ever).

My guess is that gdm is not enabled or something to that effect.

Can you please provide a few more details?

All the best,

-HG

Offline

#3 2019-03-06 16:37:35

mabvmet
Member
Registered: 2019-03-06
Posts: 7

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Thanks!

I don't have any graphic signal.
- the startx command doesn't work, the message is:

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

- The command sudo gdm gives me an entire black screen, the terminal is not more available and I can't switch to other terminals.

Offline

#4 2019-03-06 16:49:24

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,357
Website

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Not a Pacman issue, moving to NC...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2019-03-06 16:54:16

loqs
Member
Registered: 2014-03-06
Posts: 13,453

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

What is the contents of Xorg.log and the output of dmesg?

Offline

#6 2019-03-10 03:30:09

mrfr0g
Member
Registered: 2016-10-18
Posts: 3

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Same issue here on an Asus EeePC 1215B with CPU AMD C50 and graphics Radeon HD 6250.

No Xorg or dmesg errors.

My workaround was to downgrade to Linux 4.20.4.

Offline

#7 2019-03-10 07:48:49

seth
Member
Registered: 2012-09-03
Posts: 21,180

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

No Xorg or dmesg errors.

If xorg fails to start, the log *will* tell you why.
If the server starts and terminates immediately, the problem is in your session, in that case check your journal (the session keeping process will likely crash)

Offline

#8 2019-03-10 17:04:22

mrfr0g
Member
Registered: 2016-10-18
Posts: 3

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Just found it was a backlight issue: https://bbs.archlinux.org/viewtopic.php?id=244190&p=2.

Offline

#9 2019-03-10 19:56:45

seth
Member
Registered: 2012-09-03
Posts: 21,180

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#10 2019-03-10 22:50:31

mrfr0g
Member
Registered: 2016-10-18
Posts: 3

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

I may ask mabvmet if this solves his/her issue.

Thank you for the advice!

Offline

#11 2019-03-11 08:30:10

seth
Member
Registered: 2012-09-03
Posts: 21,180

Re: Archlinux (kernel 5.0) doesn't start the graphic mode after upgrade

Ah, sorry - you're not the OP. No point in closing this then - the original problem seems not backlight related at all (there's output from startx)

Please don't hijack threads then ;-)

Offline

Board footer

Powered by FluxBB