You are not logged in.

#1 2019-03-18 15:18:56

bertez
Member
Registered: 2016-10-12
Posts: 9

[SOLVED] Gnome: Multimedia keys stopped working

Hi,

volume up/down/mute keys stopped working, nothing happens when I click, no visual feedback or anything similar. I'm using gnome (last version) and I don't know how to investigate further the error.

What I've done so far:

- check if pulseaudio is working (it is)
- edit the keybindings in gnome settings (no effect)
- check vith showkeys if the keys are working (they are, the codes are 115 for volume up, 114 for down and 113 for mute)
- check if other keys are working (they are)
- check journalctl, the only remotely suspicious lines are:

mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 35 with keysym 35 (keycode e).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 32 with keysym 32 (keycode b).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 31 with keysym 31 (keycode a).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 36 with keysym 36 (keycode f).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 38 with keysym 38 (keycode 11).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 33 with keysym 33 (keycode c).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 39 with keysym 39 (keycode 12).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 34 with keysym 34 (keycode d).
mar 18 16:17:28 desktop.ber.to org.gnome.Shell.desktop[1219]: Window manager warning: Overwriting existing binding of keysym 37 with keysym 37 (keycode 10)

Could you help me with the next steps I should take?

Thank you!!

Last edited by bertez (2019-03-18 17:44:29)

Offline

#2 2019-03-18 17:11:27

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,586

Re: [SOLVED] Gnome: Multimedia keys stopped working

This might help you. You can use xev to see what the keys trigger and maybe use xkbcomp for configuration.

Offline

#3 2019-03-18 17:44:03

bertez
Member
Registered: 2016-10-12
Posts: 9

Re: [SOLVED] Gnome: Multimedia keys stopped working

That was it, I dont know why it stopped working but I've mapped the right codes and worked again. Thank you!

Offline

#4 2019-03-20 03:04:16

xsnake
Member
Registered: 2015-11-27
Posts: 11

Re: [SOLVED] Gnome: Multimedia keys stopped working

Can you please provide more info on how you fixed it? I have the exact same symptoms as you described, however the current keymap configuration provided by xkbcomp already seems to include the right assignments for multimedia keys... It stopped working after an update of gnome packages. Also I did notice that the multimedia keys still work in VLC media player.

Last edited by xsnake (2019-03-20 03:09:30)

Offline

#5 2019-03-20 08:22:10

bertez
Member
Registered: 2016-10-12
Posts: 9

Re: [SOLVED] Gnome: Multimedia keys stopped working

It was a keyboard issue, for some reason my volume up/down/mute keycodes were wrong, I checked the right keycodes using the command showkeys:

sudo showkeys -k

And follow this section to set the right keys:

https://wiki.archlinux.org/index.php/X_ … assignment

Offline

#6 2019-03-21 01:25:01

xsnake
Member
Registered: 2015-11-27
Posts: 11

Re: [SOLVED] Gnome: Multimedia keys stopped working

For some reason xev and showkey do not yield the same keycodes for the multimedia keys, however none of them resolve the issue when used with xkbcomp.

Investigating, I noticed the following error in journalctl:

gsd-media-keys[6495]: Failed to grab accelerator: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Type of message, “(suu)”, does not match expected type “(su)”

Since the multimedia keys stopped working after the GNOME 3.32 update, I downgraded the gnome-settings-daemon package back to 3.30 and the multimedia keys work again.

Offline

Board footer

Powered by FluxBB