You are not logged in.

#1 2019-03-30 22:59:34

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

GCC 8 giving assembler errors when building

I recently upgraded gcc to 8 and whenever I try to build a package for example pycharm-professional using yay/yaourt the compilation errors with

{standard input}:10: Error: unknown .loc sub-directive `view'
{standard input}:10: Error: junk at end of line, first unrecognized character is `-'
{standard input}:12: Error: unknown .loc sub-directive `view'
{standard input}:12: Error: unknown pseudo-op: `.lvu1'

and continues x number of times incrementing the number at the end of lvu. I've tried updating my binutils and reinstalling gcc. Has anyone had this issue before?

Offline

#2 2019-03-31 00:03:34

loqs
Member
Registered: 2014-03-06
Posts: 11,047

Re: GCC 8 giving assembler errors when building

s0lar1n wrote:

I recently upgraded gcc to 8

Welcome to the arch linux forums s0lar1n.  gcc 8.1.0-1 was packaged in May 2018.  What exact gcc package version has the issue and which version does not have the issue?
Please do not post snippets of outputs post the full command you used and all the output.  Please also test without using an AUR helper.
For comparisson is the output from a local clean chroot build for pycharm-professional.

clone https://aur.archlinux.org/pycharm-professional.git
Cloning into 'pycharm-professional'...
remote: Enumerating objects: 419, done.
remote: Counting objects: 100% (419/419), done.
remote: Compressing objects: 100% (199/199), done.
remote: Total 419 (delta 220), reused 419 (delta 220)
Receiving objects: 100% (419/419), 104.60 KiB | 1.63 MiB/s, done.
Resolving deltas: 100% (220/220), done.
$ cd pycharm-professional/
# extra-x86_64-build
:: Synchronizing package databases...
 core is up to date
 extra                   1691.1 KiB  5.05M/s 00:00 [######################] 100%
 community                  4.8 MiB  9.03M/s 00:01 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do
==> Building in chroot for [extra] (x86_64)...
==> Synchronizing chroot copy [/var/lib/archbuild/extra-x86_64/root] -> [testuser]...done
==> Making package: pycharm-professional 2019.1.0-1 (Sat Mar 30 23:49:25 2019)
==> Retrieving sources...
  -> Downloading pycharm-professional-2019.1-no-jbr.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   154  100   154    0     0    729      0 --:--:-- --:--:-- --:--:--   729
100  322M  100  322M    0     0  12.4M      0  0:00:25  0:00:25 --:--:-- 11.9M
  -> Found pycharm-professional.desktop
  -> Found pycharm
  -> Found charm.desktop
  -> Found charm
==> Validating source files with sha256sums...
    pycharm-professional-2019.1-no-jbr.tar.gz ... Passed
    pycharm-professional.desktop ... Passed
    pycharm ... Passed
    charm.desktop ... Passed
    charm ... Passed
==> Making package: pycharm-professional 2019.1.0-1 (Sat 30 Mar 2019 11:49:53 PM UTC)
==> Checking runtime dependencies...
==> Installing missing dependencies...
:: There are 10 providers available for ttf-font:
:: Repository extra
   1) noto-fonts  2) ttf-bitstream-vera  3) ttf-caladea  4) ttf-carlito
   5) ttf-croscore  6) ttf-dejavu  7) ttf-freefont
:: Repository community
   8) ttf-droid  9) ttf-liberation  10) ttf-ubuntu-font-family

Enter a number (default=1): 
:: There are 4 providers available for java-runtime:
:: Repository extra
   1) jre-openjdk  2) jre10-openjdk  3) jre7-openjdk  4) jre8-openjdk

Enter a number (default=1): 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (28) freetype2-2.10.0-1  graphite-1:1.3.13-1  harfbuzz-2.4.0-1
              java-runtime-common-3-1  jre-openjdk-headless-11.0.3.u4-1
              lcms2-2.9-1  libjpeg-turbo-2.0.2-1  libnet-1.1.6-3
              libnsl-1.2.0-1  libpng-1.6.36-1  libtiff-4.0.10-1  libx11-1.6.7-1
              libxau-1.0.9-1  libxcb-1.13.1-1  libxdmcp-1.1.3-1
              libxext-1.3.4-1  libxfixes-5.0.3-2  libxi-1.7.9-2  nspr-4.21-1
              nss-3.43-1  xcb-proto-1.13-2  xorgproto-2018.4-1  giflib-5.1.8-1
              jre-openjdk-11.0.3.u4-1  libxslt-1.1.33-1  libxtst-1.2.3-2
              noto-fonts-20190111-1  python-3.7.3-1

Total Download Size:    68.01 MiB
Total Installed Size:  419.59 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 giflib-5.1.8-1-x86_64     78.7 KiB  1573K/s 00:00 [######################] 100%
 python-3.7.3-1-x86_64     35.3 MiB  11.9M/s 00:03 [######################] 100%
 harfbuzz-2.4.0-1-x86_64  676.7 KiB  2.81M/s 00:00 [######################] 100%
 jre-openjdk-headles...    31.8 MiB  9.12M/s 00:03 [######################] 100%
 jre-openjdk-11.0.3....   176.5 KiB  14.4M/s 00:00 [######################] 100%
(28/28) checking keys in keyring                   [######################] 100%
(28/28) checking package integrity                 [######################] 100%
(28/28) loading package files                      [######################] 100%
(28/28) checking for file conflicts                [######################] 100%
:: Processing package changes...
( 1/28) installing giflib                          [######################] 100%
( 2/28) installing noto-fonts                      [######################] 100%
Optional dependencies for noto-fonts
    noto-fonts-cjk: CJK characters
    noto-fonts-emoji: Emoji characters
    noto-fonts-extra: additional variants (condensed, semi-bold, extra-light)
( 3/28) installing xcb-proto                       [######################] 100%
( 4/28) installing xorgproto                       [######################] 100%
( 5/28) installing libxdmcp                        [######################] 100%
( 6/28) installing libxau                          [######################] 100%
( 7/28) installing libxcb                          [######################] 100%
( 8/28) installing libx11                          [######################] 100%
( 9/28) installing libxext                         [######################] 100%
(10/28) installing libxi                           [######################] 100%
(11/28) installing libxfixes                       [######################] 100%
(12/28) installing libxtst                         [######################] 100%
(13/28) installing libxslt                         [######################] 100%
(14/28) installing libnsl                          [######################] 100%
(15/28) installing python                          [######################] 100%
Optional dependencies for python
    python-setuptools
    python-pip
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
(16/28) installing java-runtime-common             [######################] 100%
For the complete set of Java binaries to be available in your PATH,
you need to re-login or source /etc/profile.d/jre.sh
Please note that this package does not support forcing JAVA_HOME as former package java-common did
(17/28) installing nspr                            [######################] 100%
(18/28) installing nss                             [######################] 100%
(19/28) installing libjpeg-turbo                   [######################] 100%
(20/28) installing libtiff                         [######################] 100%
Optional dependencies for libtiff
    freeglut: for using tiffgt
(21/28) installing lcms2                           [######################] 100%
(22/28) installing libnet                          [######################] 100%
(23/28) installing libpng                          [######################] 100%
(24/28) installing graphite                        [######################] 100%
(25/28) installing harfbuzz                        [######################] 100%
Optional dependencies for harfbuzz
    cairo: hb-view program
(26/28) installing freetype2                       [######################] 100%
(27/28) installing jre-openjdk-headless            [######################] 100%
Optional dependencies for jre-openjdk-headless
    java-rhino: for some JavaScript support
(28/28) installing jre-openjdk                     [######################] 100%
when you use a non-reparenting window manager,
set _JAVA_AWT_WM_NONREPARENTING=1 in /etc/profile.d/jre.sh
Optional dependencies for jre-openjdk
    alsa-lib: for basic sound support
    gtk2: for the Gtk+ 2 look and feel - desktop usage
    gtk3: for the Gtk+ 3 look and feel - desktop usage
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (11) python-appdirs-1.4.3-2  python-packaging-19.0-1
              python-pyparsing-2.3.1-1  python-six-1.12.0-1  python2-2.7.16-1
              python2-appdirs-1.4.3-2  python2-packaging-19.0-1
              python2-pyparsing-2.3.1-1  python2-six-1.12.0-1
              python-setuptools-1:40.8.0-1  python2-setuptools-1:40.8.0-1

Total Installed Size:  80.66 MiB

:: Proceed with installation? [Y/n] 
(11/11) checking keys in keyring                   [######################] 100%
(11/11) checking package integrity                 [######################] 100%
(11/11) loading package files                      [######################] 100%
(11/11) checking for file conflicts                [######################] 100%
:: Processing package changes...
( 1/11) installing python2                         [######################] 100%
Optional dependencies for python2
    tk: for IDLE
    python2-setuptools [pending]
    python2-pip
( 2/11) installing python2-appdirs                 [######################] 100%
( 3/11) installing python2-pyparsing               [######################] 100%
( 4/11) installing python2-six                     [######################] 100%
( 5/11) installing python2-packaging               [######################] 100%
( 6/11) installing python2-setuptools              [######################] 100%
( 7/11) installing python-appdirs                  [######################] 100%
( 8/11) installing python-pyparsing                [######################] 100%
( 9/11) installing python-six                      [######################] 100%
(10/11) installing python-packaging                [######################] 100%
(11/11) installing python-setuptools               [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Retrieving sources...
  -> Found pycharm-professional-2019.1-no-jbr.tar.gz
  -> Found pycharm-professional.desktop
  -> Found pycharm
  -> Found charm.desktop
  -> Found charm
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting pycharm-professional-2019.1-no-jbr.tar.gz with bsdtar
==> Starting build()...
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
creating build
creating build/_pydevd_bundle
gcc -pthread -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python2.7 -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
creating _pydevd_bundle_ext
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_bundle/pydevd_cython.o -L/usr/lib -lpython2.7 -o ./_pydevd_bundle_ext/pydevd_cython.so
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_bundle/pydevd_cython.o -L/usr/lib -lpython3.7m -o ./_pydevd_bundle_ext/pydevd_cython.cpython-37m-x86_64-linux-gnu.so
running build_ext
building '_pydevd_frame_eval_ext.pydevd_frame_evaluator' extension
creating build/_pydevd_frame_eval
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c _pydevd_frame_eval/pydevd_frame_evaluator.c -o build/_pydevd_frame_eval/pydevd_frame_evaluator.o
creating _pydevd_frame_eval_ext
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_frame_eval/pydevd_frame_evaluator.o -L/usr/lib -lpython3.7m -o ./_pydevd_frame_eval_ext/pydevd_frame_evaluator.cpython-37m-x86_64-linux-gnu.so
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
strip: Unable to recognise the format of the input file `./opt/pycharm-professional/lib/pty4j-native/linux/ppc64le/libpty.so'
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "pycharm-professional"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: pycharm-professional 2019.1.0-1 (Sat 30 Mar 2019 11:53:57 PM UTC)

Offline

#3 2019-03-31 00:15:51

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

Version:

 >>> gcc --version
gcc (GCC) 8.2.1 20181127
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
>>>sudo pacman -Q --info binutils
Name            : binutils
Version         : 2.31.1-4
Description     : A set of programs to assemble and manipulate binary and object files
Architecture    : x86_64
URL             : http://www.gnu.org/software/binutils/
Licenses        : GPL
Groups          : base-devel
Provides        : None
Depends On      : glibc  zlib
Optional Deps   : None
Required By     : avr-binutils  gcc  gcc7
Optional For    : None
Conflicts With  : binutils-multilib
Replaces        : binutils-multilib
Installed Size  : 31.23 MiB
Packager        : Anatol Pomozov <anatol.pomozov@gmail.com>
Build Date      : Wed 26 Dec 2018 10:27:04 AM EST
Install Date    : Sat 30 Mar 2019 06:15:45 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
>>> makepkg
==> Making package: pycharm-professional 2019.1.0-1 (Sat 30 Mar 2019 08:07:10 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading pycharm-professional-2019.1-no-jbr.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   154  100   154    0     0    175      0 --:--:-- --:--:-- --:--:--   175
100  322M  100  322M    0     0  9818k      0  0:00:33  0:00:33 --:--:-- 11.3M
  -> Found pycharm-professional.desktop
  -> Found pycharm
  -> Found charm.desktop
  -> Found charm
==> Validating source files with sha256sums...
    pycharm-professional-2019.1-no-jbr.tar.gz ... Passed
    pycharm-professional.desktop ... Passed
    pycharm ... Passed
    charm.desktop ... Passed
    charm ... Passed
==> Extracting sources...
  -> Extracting pycharm-professional-2019.1-no-jbr.tar.gz with bsdtar
==> Starting build()...
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
creating build
creating build/_pydevd_bundle
gcc -pthread -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python2.7 -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
creating _pydevd_bundle_ext
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_bundle/pydevd_cython.o -L/usr/lib -lpython2.7 -o ./_pydevd_bundle_ext/pydevd_cython.so
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
{standard input}: Assembler messages:
{standard input}:10: Error: unknown .loc sub-directive `view'
{standard input}:10: Error: junk at end of line, first unrecognized character is `-'
{standard input}:12: Error: unknown .loc sub-directive `view'
{standard input}:12: Error: unknown pseudo-op: `.lvu1'
{standard input}:13: Error: unknown .loc sub-directive `view'
{standard input}:13: Error: unknown pseudo-op: `.lvu2'
{standard input}:14: Error: unknown .loc sub-directive `view'
{standard input}:14: Error: unknown pseudo-op: `.lvu3'
{standard input}:15: Error: unknown .loc sub-directive `view'
{standard input}:15: Error: unknown pseudo-op: `.lvu4'
{standard input}:18: Error: unknown .loc sub-directive `view'
{standard input}:18: Error: unknown pseudo-op: `.lvu5'
{standard input}:21: Error: unknown .loc sub-directive `view'
{standard input}:21: Error: unknown pseudo-op: `.lvu6'
{standard input}:22: Error: unknown .loc sub-directive `view'
{standard input}:22: Error: unknown pseudo-op: `.lvu7'
{standard input}:25: Error: unknown .loc sub-directive `view'
{standard input}:25: Error: unknown pseudo-op: `.lvu8'
{standard input}:29: Error: unknown .loc sub-directive `view'
{standard input}:29: Error: unknown pseudo-op: `.lvu9'
{standard input}:30: Error: unknown .loc sub-directive `view'
{standard input}:30: Error: unknown pseudo-op: `.lvu10'
{standard input}:33: Error: unknown .loc sub-directive `view'
{standard input}:33: Error: unknown pseudo-op: `.lvu11'
{standard input}:35: Error: unknown .loc sub-directive `view'
{standard input}:35: Error: unknown pseudo-op: `.lvu12'
{standard input}:36: Error: unknown .loc sub-directive `view'
{standard input}:36: Error: unknown pseudo-op: `.lvu13'
{standard input}:38: Error: unknown .loc sub-directive `view'
.
.
.
{standard input}:207057: Error: unknown pseudo-op: `.lvu74924'
{standard input}:207058: Error: unknown .loc sub-directive `view'
{standard input}:207058: Error: unknown pseudo-op: `.lvu74925'
{standard input}:207059: Error: unknown .loc sub-directive `view'
{standard input}:207059: Error: unknown pseudo-op: `.lvu74926'
{standard input}:207065: Error: unknown .loc sub-directive `view'
{standard input}:207065: Error: unknown pseudo-op: `.lvu74927'
{standard input}:207068: Error: unknown .loc sub-directive `view'
{standard input}:207068: Error: unknown pseudo-op: `.lvu74928'
{standard input}:207073: Error: unknown .loc sub-directive `view'
{standard input}:207073: Error: unknown pseudo-op: `.lvu74929'
{standard input}:207074: Error: unknown .loc sub-directive `view'
{standard input}:207074: Error: unknown pseudo-op: `.lvu74930'
{standard input}:207076: Error: unknown .loc sub-directive `view'
{standard input}:207076: Error: unknown pseudo-op: `.lvu74931'
{standard input}:207079: Error: unknown .loc sub-directive `view'
{standard input}:207079: Error: unknown pseudo-op: `.lvu74932'
{standard input}:207081: Error: unknown .loc sub-directive `view'
{standard input}:207081: Error: unknown pseudo-op: `.lvu74933'
{standard input}:207084: Error: unknown .loc sub-directive `view'
{standard input}:207084: Error: unknown pseudo-op: `.lvu74934'
{standard input}:207087: Error: unknown .loc sub-directive `view'
{standard input}:207087: Error: unknown pseudo-op: `.lvu74935'
{standard input}:207091: Error: unknown .loc sub-directive `view'
{standard input}:207091: Error: unknown pseudo-op: `.lvu74936'
{standard input}:207095: Error: unknown .loc sub-directive `view'
{standard input}:207095: Error: unknown pseudo-op: `.lvu74937'
{standard input}:207097: Error: unknown .loc sub-directive `view'
{standard input}:207097: Error: unknown pseudo-op: `.lvu74938'
error: command 'gcc' failed with exit status 1
==> ERROR: A failure occurred in build().
    Aborting...

I didn't post the entire output because the entire output is 10MB and is just the same pattern repeated

Last edited by s0lar1n (2019-03-31 00:16:58)

Offline

#4 2019-03-31 00:22:16

loqs
Member
Registered: 2014-03-06
Posts: 11,047

Re: GCC 8 giving assembler errors when building

What is the output of the following

type ld
pacman -Qkk binutils

Additionally if you install devtools can you replicate the output I produced above using extra-x86_64-build?

Offline

#5 2019-03-31 00:42:57

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

>>> type ld
ld is /usr/bin/ld
>>> pacman -Qkk binutils
binutils: 384 total files, 0 altered files
>>>extra-x86_64-build
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                                                4.8 MiB  5.36M/s 00:01 [##############################################] 100%
:: Starting full system upgrade...
 there is nothing to do
==> Building in chroot for [extra] (x86_64)...
==> Synchronizing chroot copy [/var/lib/archbuild/extra-x86_64/root] -> [s0lar1n]...done
==> Making package: pycharm-professional 2019.1.0-1 (Sat Mar 30 20:31:40 2019)
==> Retrieving sources...
  -> Found pycharm-professional-2019.1-no-jbr.tar.gz
  -> Found pycharm-professional.desktop
  -> Found pycharm
  -> Found charm.desktop
  -> Found charm
==> Validating source files with sha256sums...
    pycharm-professional-2019.1-no-jbr.tar.gz ... Passed
    pycharm-professional.desktop ... Passed
    pycharm ... Passed
    charm.desktop ... Passed
    charm ... Passed
==> Making package: pycharm-professional 2019.1.0-1 (Sat 30 Mar 2019 08:31:41 PM EDT)
==> Checking runtime dependencies...
==> Installing missing dependencies...
:: There are 10 providers available for ttf-font:
:: Repository extra
   1) noto-fonts  2) ttf-bitstream-vera  3) ttf-caladea  4) ttf-carlito  5) ttf-croscore  6) ttf-dejavu  7) ttf-freefont
:: Repository community
   8) ttf-droid  9) ttf-liberation  10) ttf-ubuntu-font-family

Enter a number (default=1): 
:: There are 4 providers available for java-runtime:
:: Repository extra
   1) jre-openjdk  2) jre10-openjdk  3) jre7-openjdk  4) jre8-openjdk

Enter a number (default=1): 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (28) freetype2-2.10.0-1  graphite-1:1.3.13-1  harfbuzz-2.4.0-1  java-runtime-common-3-1  jre-openjdk-headless-11.0.3.u4-1
              lcms2-2.9-1  libjpeg-turbo-2.0.2-1  libnet-1.1.6-3  libnsl-1.2.0-1  libpng-1.6.36-1  libtiff-4.0.10-1  libx11-1.6.7-1
              libxau-1.0.9-1  libxcb-1.13.1-1  libxdmcp-1.1.3-1  libxext-1.3.4-1  libxfixes-5.0.3-2  libxi-1.7.9-2  nspr-4.21-1
              nss-3.43-1  xcb-proto-1.13-2  xorgproto-2018.4-1  giflib-5.1.8-1  jre-openjdk-11.0.3.u4-1  libxslt-1.1.33-1
              libxtst-1.2.3-2  noto-fonts-20190111-1  python-3.7.3-1

Total Installed Size:  419.59 MiB

:: Proceed with installation? [Y/n] 
(28/28) checking keys in keyring                                                 [##############################################] 100%
(28/28) checking package integrity                                               [##############################################] 100%
(28/28) loading package files                                                    [##############################################] 100%
(28/28) checking for file conflicts                                              [##############################################] 100%
:: Processing package changes...
( 1/28) installing giflib                                                        [##############################################] 100%
( 2/28) installing noto-fonts                                                    [##############################################] 100%
Optional dependencies for noto-fonts
    noto-fonts-cjk: CJK characters
    noto-fonts-emoji: Emoji characters
    noto-fonts-extra: additional variants (condensed, semi-bold, extra-light)
( 3/28) installing xcb-proto                                                     [##############################################] 100%
( 4/28) installing xorgproto                                                     [##############################################] 100%
( 5/28) installing libxdmcp                                                      [##############################################] 100%
( 6/28) installing libxau                                                        [##############################################] 100%
( 7/28) installing libxcb                                                        [##############################################] 100%
( 8/28) installing libx11                                                        [##############################################] 100%
( 9/28) installing libxext                                                       [##############################################] 100%
(10/28) installing libxi                                                         [##############################################] 100%
(11/28) installing libxfixes                                                     [##############################################] 100%
(12/28) installing libxtst                                                       [##############################################] 100%
(13/28) installing libxslt                                                       [##############################################] 100%
(14/28) installing libnsl                                                        [##############################################] 100%
(15/28) installing python                                                        [##############################################] 100%
Optional dependencies for python
    python-setuptools
    python-pip
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
(16/28) installing java-runtime-common                                           [##############################################] 100%
For the complete set of Java binaries to be available in your PATH,
you need to re-login or source /etc/profile.d/jre.sh
Please note that this package does not support forcing JAVA_HOME as former package java-common did
(17/28) installing nspr                                                          [##############################################] 100%
(18/28) installing nss                                                           [##############################################] 100%
(19/28) installing libjpeg-turbo                                                 [##############################################] 100%
(20/28) installing libtiff                                                       [##############################################] 100%
Optional dependencies for libtiff
    freeglut: for using tiffgt
(21/28) installing lcms2                                                         [##############################################] 100%
(22/28) installing libnet                                                        [##############################################] 100%
(23/28) installing libpng                                                        [##############################################] 100%
(24/28) installing graphite                                                      [##############################################] 100%
(25/28) installing harfbuzz                                                      [##############################################] 100%
Optional dependencies for harfbuzz
    cairo: hb-view program
(26/28) installing freetype2                                                     [##############################################] 100%
(27/28) installing jre-openjdk-headless                                          [##############################################] 100%
Optional dependencies for jre-openjdk-headless
    java-rhino: for some JavaScript support
(28/28) installing jre-openjdk                                                   [##############################################] 100%
when you use a non-reparenting window manager,
set _JAVA_AWT_WM_NONREPARENTING=1 in /etc/profile.d/jre.sh
Optional dependencies for jre-openjdk
    alsa-lib: for basic sound support
    gtk2: for the Gtk+ 2 look and feel - desktop usage
    gtk3: for the Gtk+ 3 look and feel - desktop usage
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (11) python-appdirs-1.4.3-2  python-packaging-19.0-1  python-pyparsing-2.3.1-1  python-six-1.12.0-1  python2-2.7.16-1
              python2-appdirs-1.4.3-2  python2-packaging-19.0-1  python2-pyparsing-2.3.1-1  python2-six-1.12.0-1
              python-setuptools-1:40.8.0-1  python2-setuptools-1:40.8.0-1

Total Installed Size:  80.66 MiB

:: Proceed with installation? [Y/n] 
(11/11) checking keys in keyring                                                 [##############################################] 100%
(11/11) checking package integrity                                               [##############################################] 100%
(11/11) loading package files                                                    [##############################################] 100%
(11/11) checking for file conflicts                                              [##############################################] 100%
:: Processing package changes...
( 1/11) installing python2                                                       [##############################################] 100%
Optional dependencies for python2
    tk: for IDLE
    python2-setuptools [pending]
    python2-pip
( 2/11) installing python2-appdirs                                               [##############################################] 100%
( 3/11) installing python2-pyparsing                                             [##############################################] 100%
( 4/11) installing python2-six                                                   [##############################################] 100%
( 5/11) installing python2-packaging                                             [##############################################] 100%
( 6/11) installing python2-setuptools                                            [##############################################] 100%
( 7/11) installing python-appdirs                                                [##############################################] 100%
( 8/11) installing python-pyparsing                                              [##############################################] 100%
( 9/11) installing python-six                                                    [##############################################] 100%
(10/11) installing python-packaging                                              [##############################################] 100%
(11/11) installing python-setuptools                                             [##############################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Retrieving sources...
  -> Found pycharm-professional-2019.1-no-jbr.tar.gz
  -> Found pycharm-professional.desktop
  -> Found pycharm
  -> Found charm.desktop
  -> Found charm
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting pycharm-professional-2019.1-no-jbr.tar.gz with bsdtar
==> Starting build()...
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
creating build
creating build/_pydevd_bundle
gcc -pthread -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python2.7 -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
creating _pydevd_bundle_ext
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_bundle/pydevd_cython.o -L/usr/lib -lpython2.7 -o ./_pydevd_bundle_ext/pydevd_cython.so
running build_ext
building '_pydevd_bundle_ext.pydevd_cython' extension
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_bundle/pydevd_cython.o -L/usr/lib -lpython3.7m -o ./_pydevd_bundle_ext/pydevd_cython.cpython-37m-x86_64-linux-gnu.so
running build_ext
building '_pydevd_frame_eval_ext.pydevd_frame_evaluator' extension
creating build/_pydevd_frame_eval
gcc -pthread -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.7m -c _pydevd_frame_eval/pydevd_frame_evaluator.c -o build/_pydevd_frame_eval/pydevd_frame_evaluator.o
creating _pydevd_frame_eval_ext
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 build/_pydevd_frame_eval/pydevd_frame_evaluator.o -L/usr/lib -lpython3.7m -o ./_pydevd_frame_eval_ext/pydevd_frame_evaluator.cpython-37m-x86_64-linux-gnu.so
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
strip: Unable to recognise the format of the input file `./opt/pycharm-professional/lib/pty4j-native/linux/ppc64le/libpty.so'
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "pycharm-professional"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: pycharm-professional 2019.1.0-1 (Sat 30 Mar 2019 08:37:14 PM EDT)
==> Installing package pycharm-professional with pacman -U...
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) pycharm-professional-2019.1.0-1

Total Installed Size:  667.42 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                   [##############################################] 100%
(1/1) checking package integrity                                                 [##############################################] 100%
(1/1) loading package files                                                      [##############################################] 100%
(1/1) checking for file conflicts                                                [##############################################] 100%
:: Processing package changes...
(1/1) installing pycharm-professional                                            [##############################################] 100%
Optional dependencies for pycharm-professional
    ipython2: For enhanced interactive Python shell v2 inside Pycharm
    ipython: For enhanced interactive Python shell v3 inside Pycharm
    openssh: For deployment and remote connections
    python2-setuptools: Packages manager for Python 2, for project interpreter [installed]
    python-setuptools: Packages manager for Python 3, for project interpreter [installed]
    python2-coverage: For support code coverage measurement for Python 2
    python-coverage: For support code coverage measurement for Python 3
    cython2: For performance debugger in Python 2
    cython: For performance debugger in Python 3
    docker-machine: For support docker inside Pycharm
    docker-compose: For support docker inside Pycharm
    vagrant: For support virtualized development environments
    python2-pytest: For support testing inside Pycharm with Python 2
    python-pytest: For support testing inside Pycharm with Python 3
    python2-tox: Python environments for testing tool with Python 2
    python-tox: Python environments for testing tool with Python 3,
    jupyter: For support Jupyter Notebook
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
resolving dependencies...
looking for conflicting packages...

Packages (5) elfutils-0.176-1  licenses-20181104-1  pyalpm-0.8.5-2  python-pyelftools-0.25-1  namcap-3.2.8-3

Total Download Size:   0.13 MiB
Total Installed Size:  3.98 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 pyalpm-0.8.5-2-x86_64                                   43.1 KiB   293K/s 00:00 [##############################################] 100%
 namcap-3.2.8-3-any                                      91.3 KiB  1100K/s 00:00 [##############################################] 100%
(5/5) checking keys in keyring                                                   [##############################################] 100%
(5/5) checking package integrity                                                 [##############################################] 100%
(5/5) loading package files                                                      [##############################################] 100%
(5/5) checking for file conflicts                                                [##############################################] 100%
:: Processing package changes...
(1/5) installing pyalpm                                                          [##############################################] 100%
(2/5) installing licenses                                                        [##############################################] 100%
(3/5) installing elfutils                                                        [##############################################] 100%
(4/5) installing python-pyelftools                                               [##############################################] 100%
(5/5) installing namcap                                                          [##############################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Checking PKGBUILD
PKGBUILD (pycharm-professional) W: Reference to arm should be changed to $CARCH
Checking pycharm-professional-2019.1.0-1-x86_64.pkg.tar.xz
pycharm-professional E: ELF files outside of a valid path ('opt/').
pycharm-professional W: ELF file ('opt/pycharm-professional/bin/fsnotifier64') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/bin/libdbm64.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/bin/libyjpagent-linux.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/bin/libyjpagent-linux64.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_bundle/pydevd_cython.o') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_frame_eval/pydevd_frame_evaluator.o') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/pydevd_attach_to_process/attach_linux_amd64.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/pydevd_attach_to_process/attach_linux_x86.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/lib/pty4j-native/linux/ppc64le/libpty.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/lib/pty4j-native/linux/x86/libpty.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/lib/pty4j-native/linux/x86_64/libpty.so') lacks FULL RELRO, check LDFLAGS.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_bundle/pydevd_cython.o') is unstripped.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_frame_eval/pydevd_frame_evaluator.o') is unstripped.
pycharm-professional W: ELF file ('opt/pycharm-professional/lib/pty4j-native/linux/ppc64le/libpty.so') is unstripped.
pycharm-professional W: ELF file ('opt/pycharm-professional/bin/fsnotifier64') lacks PIE.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_bundle/pydevd_cython.o') lacks PIE.
pycharm-professional W: ELF file ('opt/pycharm-professional/helpers/pydev/build/_pydevd_frame_eval/pydevd_frame_evaluator.o') lacks PIE.
pycharm-professional W: Referenced library 'node' is an uninstalled dependency
pycharm-professional W: Referenced library 'python.exe' is an uninstalled dependency
pycharm-professional W: Referenced library 'libdl.so.2' is an uninstalled dependency
pycharm-professional W: Referenced library 'libc.so.6' is an uninstalled dependency
pycharm-professional W: Referenced library 'librt.so.1' is an uninstalled dependency
pycharm-professional W: Referenced library 'libm.so.6' is an uninstalled dependency
pycharm-professional W: Referenced library 'libdbusmenu-glib.so.4' is an uninstalled dependency
pycharm-professional W: Referenced library 'libgcc_s.so.1' is an uninstalled dependency
pycharm-professional W: Referenced library 'ld-linux.so.2' is an uninstalled dependency
pycharm-professional W: Referenced library 'libstdc++.so.6' is an uninstalled dependency
pycharm-professional W: Unused shared library '/usr/lib/libm.so.6' by file ('opt/pycharm-professional/bin/libyjpagent-linux64.so')
pycharm-professional W: Unused shared library '/usr/lib/libpthread.so.0' by file ('opt/pycharm-professional/helpers/pydev/_pydevd_bundle_ext/pydevd_cython.cpython-37m-x86_64-linux-gnu.so')
pycharm-professional W: Unused shared library '/usr/lib/libpthread.so.0' by file ('opt/pycharm-professional/helpers/pydev/_pydevd_bundle_ext/pydevd_cython.so')
pycharm-professional W: Unused shared library '/usr/lib/libpthread.so.0' by file ('opt/pycharm-professional/helpers/pydev/_pydevd_frame_eval_ext/pydevd_frame_evaluator.cpython-37m-x86_64-linux-gnu.so')
pycharm-professional E: Dependency desktop-file-utils detected and not included (needed for update-desktop-database)
pycharm-professional E: Dependency glib2 detected and not included (libraries ['usr/lib/libgobject-2.0.so.0', 'usr/lib/libgio-2.0.so.0', 'usr/lib/libglib-2.0.so.0'] needed in files ['opt/pycharm-professional/bin/libdbm64.so'])
pycharm-professional W: Dependency python2 detected but optional (libraries ['usr/lib/libpython2.7.so.1.0'] needed in files ['opt/pycharm-professional/helpers/pydev/_pydevd_bundle_ext/pydevd_cython.so'])
pycharm-professional W: Dependency included and not needed ('giflib')
pycharm-professional W: Dependency glibc included but already satisfied
pycharm-professional W: Dependency sh included but already satisfied
pycharm-professional W: Dependency included and not needed ('libxtst')
pycharm-professional W: Dependency included and not needed ('libxslt')

I didn't receive the same build error with gcc as before but pycharm still doesn't seem to be installed

Offline

#6 2019-03-31 00:53:18

loqs
Member
Registered: 2014-03-06
Posts: 11,047

Re: GCC 8 giving assembler errors when building

extra-x86_64-build builds the package it does not install it.  `pacman  -U pycharm-professional-2019.1.0-1-x86_64.pkg.tar.xz` to install.

Offline

#7 2019-03-31 00:57:21

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

I was able to install it using pacman and the tar.xz file. Why did that work but when I try to build it through a package manager it fails?

Offline

#8 2019-03-31 01:05:56

loqs
Member
Registered: 2014-03-06
Posts: 11,047

Re: GCC 8 giving assembler errors when building

python3 helpers/pydev/setup_cython.py build_ext --build-temp build --build-lib .

Produces a different result in the clean chroot than on the installed system.  You could check which python3 is being used if that does not provide a lead possibly strace the call.

Offline

#9 2019-03-31 02:57:14

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

I've isolated the problem to be missing files in the site-packages directory in /usr/lib/python3.7 as it completes properly with python2. How would I go about completely reinstalling python3

Offline

#10 2019-03-31 04:17:01

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,939
Website

Re: GCC 8 giving assembler errors when building

run "pacman -Qkk" and you will get a list of packages with missing files.  Reinstall them.

Offline

#11 2019-03-31 14:00:45

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

After reinstalling everything it appears the error is coming from the python3 compilation as opposed to python2 as the python3 setup appends the -g flag to the gcc command. When I remove the -g from the command and run it the command completes successfully. The g flag is used to generate debugging information so why can't the debugging information be compiled in my system but when you build a clean chroot it builds fine

>>>gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -fPIC -I/usr/include/python3.7m -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o

>>>gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fstack-protector-strong -fno-plt -fPIC -I/usr/include/python3.7m -c _pydevd_bundle/pydevd_cython.c -o build/_pydevd_bundle/pydevd_cython.o
{standard input}: Assembler messages:
{standard input}:10: Error: unknown .loc sub-directive `view'
{standard input}:10: Error: junk at end of line, first unrecognized character is `-'
{standard input}:12: Error: unknown .loc sub-directive `view'
{standard input}:12: Error: unknown pseudo-op: `.lvu1'
{standard input}:13: Error: unknown .loc sub-directive `view'
{standard input}:13: Error: unknown pseudo-op: `.lvu2'
{standard input}:14: Error: unknown .loc sub-directive `view'
{standard input}:14: Error: unknown pseudo-op: `.lvu3'
{standard input}:15: Error: unknown .loc sub-directive `view'
{standard input}:15: Error: unknown pseudo-op: `.lvu4'
{standard input}:18: Error: unknown .loc sub-directive `view'
{standard input}:18: Error: unknown pseudo-op: `.lvu5'
{standard input}:21: Error: unknown .loc sub-directive `view'
{standard input}:21: Error: unknown pseudo-op: `.lvu6'
{standard input}:22: Error: unknown .loc sub-directive `view'
{standard input}:22: Error: unknown pseudo-op: `.lvu7'
{standard input}:25: Error: unknown .loc sub-directive `view'
{standard input}:25: Error: unknown pseudo-op: `.lvu8'
{standard input}:29: Error: unknown .loc sub-directive `view'
{standard input}:29: Error: unknown pseudo-op: `.lvu9'
{standard input}:30: Error: unknown .loc sub-directive `view'
{standard input}:30: Error: unknown pseudo-op: `.lvu10'
{standard input}:33: Error: unknown .loc sub-directive `view'
{standard input}:33: Error: unknown pseudo-op: `.lvu11'
{standard input}:37: Error: unknown .loc sub-directive `view'
{standard input}:37: Error: unknown pseudo-op: `.lvu12'
{standard input}:39: Error: unknown .loc sub-directive `view'
{standard input}:39: Error: unknown pseudo-op: `.lvu13'
{standard input}:42: Error: unknown .loc sub-directive `view'
{standard input}:42: Error: unknown pseudo-op: `.lvu14'
{standard input}:44: Error: unknown .loc sub-directive `view'
{standard input}:44: Error: unknown pseudo-op: `.lvu15'
{standard input}:45: Error: unknown .loc sub-directive `view'
{standard input}:45: Error: unknown pseudo-op: `.lvu16'
{standard input}:46: Error: unknown .loc sub-directive `view'
{standard input}:46: Error: unknown pseudo-op: `.lvu17'
{standard input}:47: Error: unknown .loc sub-directive `view'
{standard input}:47: Error: unknown pseudo-op: `.lvu18'
{standard input}:49: Error: unknown .loc sub-directive `view'
{standard input}:49: Error: unknown pseudo-op: `.lvu19'
{standard input}:50: Error: unknown .loc sub-directive `view'
{standard input}:50: Error: unknown pseudo-op: `.lvu20'
{standard input}:51: Error: unknown .loc sub-directive `view'
{standard input}:51: Error: unknown pseudo-op: `.lvu21'
{standard input}:52: Error: unknown .loc sub-directive `view'
{standard input}:52: Error: unknown pseudo-op: `.lvu22'
{standard input}:53: Error: unknown .loc sub-directive `view'
{standard input}:53: Error: unknown pseudo-op: `.lvu23'
{standard input}:55: Error: unknown .loc sub-directive `view'
{standard input}:55: Error: unknown pseudo-op: `.lvu24'
{standard input}:57: Error: unknown .loc sub-directive `view'
{standard input}:57: Error: unknown pseudo-op: `.lvu25'
{standard input}:58: Error: unknown .loc sub-directive `view'
{standard input}:58: Error: unknown pseudo-op: `.lvu26'
{standard input}:59: Error: unknown .loc sub-directive `view'
{standard input}:59: Error: unknown pseudo-op: `.lvu27'
{standard input}:60: Error: unknown .loc sub-directive `view'
{standard input}:60: Error: unknown pseudo-op: `.lvu28'
{standard input}:61: Error: unknown .loc sub-directive `view'
{standard input}:61: Error: unknown pseudo-op: `.lvu29'
{standard input}:63: Error: unknown .loc sub-directive `view'
{standard input}:63: Error: unknown pseudo-op: `.lvu30'
{standard input}:64: Error: unknown .loc sub-directive `view'
{standard input}:64: Error: unknown pseudo-op: `.lvu31'
{standard input}:65: Error: unknown .loc sub-directive `view'
{standard input}:65: Error: unknown pseudo-op: `.lvu32'
{standard input}:66: Error: unknown .loc sub-directive `view'
{standard input}:66: Error: unknown pseudo-op: `.lvu33'
{standard input}:69: Error: unknown .loc sub-directive `view'
{standard input}:69: Error: unknown pseudo-op: `.lvu34'
{standard input}:79: Error: unknown .loc sub-directive `view'
{standard input}:79: Error: unknown pseudo-op: `.lvu35'
{standard input}:80: Error: unknown .loc sub-directive `view'
{standard input}:80: Error: unknown pseudo-op: `.lvu36'
{standard input}:84: Error: unknown .loc sub-directive `view'
{standard input}:84: Error: unknown pseudo-op: `.lvu37'
{standard input}:87: Error: unknown .loc sub-directive `view'
{standard input}:87: Error: unknown pseudo-op: `.lvu38'
{standard input}:90: Error: unknown .loc sub-directive `view'
{standard input}:90: Error: unknown pseudo-op: `.lvu39'
{standard input}:100: Error: unknown .loc sub-directive `view'
{standard input}:100: Error: junk at end of line, first unrecognized character is `-'
{standard input}:102: Error: unknown .loc sub-directive `view'
{standard input}:102: Error: unknown pseudo-op: `.lvu41'
{standard input}:103: Error: unknown .loc sub-directive `view'
{standard input}:103: Error: unknown pseudo-op: `.lvu42'
{standard input}:104: Error: unknown .loc sub-directive `view'
{standard input}:104: Error: unknown pseudo-op: `.lvu43'
{standard input}:105: Error: unknown .loc sub-directive `view'
{standard input}:105: Error: unknown pseudo-op: `.lvu44'
{standard input}:115: Error: unknown .loc sub-directive `view'
{standard input}:115: Error: unknown pseudo-op: `.lvu45'
{standard input}:117: Error: unknown .loc sub-directive `view'
{standard input}:117: Error: unknown pseudo-op: `.lvu46'
{standard input}:120: Error: unknown .loc sub-directive `view'
{standard input}:120: Error: unknown pseudo-op: `.lvu47'
{standard input}:121: Error: unknown .loc sub-directive `view'
{standard input}:121: Error: unknown pseudo-op: `.lvu48'
{standard input}:123: Error: unknown .loc sub-directive `view'
{standard input}:123: Error: unknown pseudo-op: `.lvu49'
{standard input}:125: Error: unknown .loc sub-directive `view'
{standard input}:125: Error: unknown pseudo-op: `.lvu50'
{standard input}:128: Error: unknown .loc sub-directive `view'
{standard input}:128: Error: unknown pseudo-op: `.lvu51'
{standard input}:130: Error: unknown .loc sub-directive `view'
{standard input}:130: Error: unknown pseudo-op: `.lvu52'
{standard input}:132: Error: unknown .loc sub-directive `view'
{standard input}:132: Error: unknown pseudo-op: `.lvu53'
{standard input}:135: Error: unknown .loc sub-directive `view'
{standard input}:135: Error: unknown pseudo-op: `.lvu54'
{standard input}:137: Error: unknown .loc sub-directive `view'
{standard input}:137: Error: unknown pseudo-op: `.lvu55'
{standard input}:139: Error: unknown .loc sub-directive `view'
{standard input}:139: Error: unknown pseudo-op: `.lvu56'
{standard input}:144: Error: unknown .loc sub-directive `view'
{standard input}:144: Error: unknown pseudo-op: `.lvu57'
{standard input}:147: Error: unknown .loc sub-directive `view'
{standard input}:147: Error: unknown pseudo-op: `.lvu58'
{standard input}:150: Error: unknown .loc sub-directive `view'
{standard input}:150: Error: unknown pseudo-op: `.lvu59'
{standard input}:151: Error: unknown .loc sub-directive `view'
{standard input}:151: Error: unknown pseudo-op: `.lvu60'
{standard input}:154: Error: unknown .loc sub-directive `view'
{standard input}:154: Error: unknown pseudo-op: `.lvu61'
{standard input}:155: Error: unknown .loc sub-directive `view'
{standard input}:155: Error: unknown pseudo-op: `.lvu62'
{standard input}:157: Error: unknown .loc sub-directive `view'
{standard input}:157: Error: unknown pseudo-op: `.lvu63'
{standard input}:159: Error: unknown .loc sub-directive `view'
{standard input}:159: Error: unknown pseudo-op: `.lvu64'
{standard input}:161: Error: unknown .loc sub-directive `view'
{standard input}:161: Error: unknown pseudo-op: `.lvu65'
{standard input}:163: Error: unknown .loc sub-directive `view'
{standard input}:163: Error: unknown pseudo-op: `.lvu66'
{standard input}:165: Error: unknown .loc sub-directive `view'
{standard input}:165: Error: unknown pseudo-op: `.lvu67'
{standard input}:168: Error: unknown .loc sub-directive `view'
{standard input}:168: Error: unknown pseudo-op: `.lvu68'
{standard input}:170: Error: unknown .loc sub-directive `view'
{standard input}:170: Error: unknown pseudo-op: `.lvu69'
{standard input}:172: Error: unknown .loc sub-directive `view'
{standard input}:172: Error: unknown pseudo-op: `.lvu70'
{standard input}:177: Error: unknown .loc sub-directive `view'
{standard input}:177: Error: unknown pseudo-op: `.lvu71'
{standard input}:180: Error: unknown .loc sub-directive `view'
{standard input}:180: Error: unknown pseudo-op: `.lvu72'
{standard input}:183: Error: unknown .loc sub-directive `view'
{standard input}:183: Error: unknown pseudo-op: `.lvu73'
{standard input}:184: Error: unknown .loc sub-directive `view'
{standard input}:184: Error: unknown pseudo-op: `.lvu74'
{standard input}:187: Error: unknown .loc sub-directive `view'
{standard input}:187: Error: unknown pseudo-op: `.lvu75'
{standard input}:188: Error: unknown .loc sub-directive `view'
{standard input}:188: Error: unknown pseudo-op: `.lvu76'
{standard input}:190: Error: unknown .loc sub-directive `view'
{standard input}:190: Error: unknown pseudo-op: `.lvu77'
{standard input}:192: Error: unknown .loc sub-directive `view'
{standard input}:192: Error: unknown pseudo-op: `.lvu78'
{standard input}:194: Error: unknown .loc sub-directive `view'
{standard input}:194: Error: unknown pseudo-op: `.lvu79'
{standard input}:196: Error: unknown .loc sub-directive `view'
{standard input}:196: Error: unknown pseudo-op: `.lvu80'
{standard input}:198: Error: unknown .loc sub-directive `view'
{standard input}:198: Error: unknown pseudo-op: `.lvu81'
{standard input}:201: Error: unknown .loc sub-directive `view'
{standard input}:201: Error: unknown pseudo-op: `.lvu82'
{standard input}:203: Error: unknown .loc sub-directive `view'
{standard input}:203: Error: unknown pseudo-op: `.lvu83'
{standard input}:205: Error: unknown .loc sub-directive `view'
{standard input}:205: Error: unknown pseudo-op: `.lvu84'
{standard input}:210: Error: unknown .loc sub-directive `view'
{standard input}:210: Error: unknown pseudo-op: `.lvu85'
{standard input}:213: Error: unknown .loc sub-directive `view'
{standard input}:213: Error: unknown pseudo-op: `.lvu86'
{standard input}:216: Error: unknown .loc sub-directive `view'
{standard input}:216: Error: unknown pseudo-op: `.lvu87'
{standard input}:217: Error: unknown .loc sub-directive `view'
{standard input}:217: Error: unknown pseudo-op: `.lvu88'
{standard input}:220: Error: unknown .loc sub-directive `view'
{standard input}:220: Error: unknown pseudo-op: `.lvu89'
{standard input}:221: Error: unknown .loc sub-directive `view'
{standard input}:221: Error: unknown pseudo-op: `.lvu90'
{standard input}:223: Error: unknown .loc sub-directive `view'
{standard input}:223: Error: unknown pseudo-op: `.lvu91'
{standard input}:225: Error: unknown .loc sub-directive `view'
{standard input}:225: Error: unknown pseudo-op: `.lvu92'
{standard input}:227: Error: unknown .loc sub-directive `view'
{standard input}:227: Error: unknown pseudo-op: `.lvu93'
{standard input}:229: Error: unknown .loc sub-directive `view'
{standard input}:229: Error: unknown pseudo-op: `.lvu94'
{standard input}:231: Error: unknown .loc sub-directive `view'
{standard input}:231: Error: unknown pseudo-op: `.lvu95'
{standard input}:234: Error: unknown .loc sub-directive `view'
{standard input}:234: Error: unknown pseudo-op: `.lvu96'
{standard input}:236: Error: unknown .loc sub-directive `view'
{standard input}:236: Error: unknown pseudo-op: `.lvu97'
{standard input}:238: Error: unknown .loc sub-directive `view'
{standard input}:238: Error: unknown pseudo-op: `.lvu98'
{standard input}:243: Error: unknown .loc sub-directive `view'
{standard input}:243: Error: unknown pseudo-op: `.lvu99'
{standard input}:246: Error: unknown .loc sub-directive `view'

Last edited by s0lar1n (2019-03-31 14:03:06)

Offline

#12 2019-03-31 14:10:47

loqs
Member
Registered: 2014-03-06
Posts: 11,047

Re: GCC 8 giving assembler errors when building

Did pacman -Qkk detect any packages with missing files?  Have you installed anything on the system without the use of pacman?

Last edited by loqs (2019-03-31 14:11:20)

Offline

#13 2019-03-31 14:19:19

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

I haven't installed anything on the system without the use of a package manager with the exception of using pip for packages not available through pacman. Here is the output for pacman -Qkk

>>>sudo pacman -Qkk | grep -i "warning"
warning: accountsservice: /var/lib/AccountsService/icons (Permissions mismatch)
warning: amd-ucode: /boot/amd-ucode.img (Permissions mismatch)
warning: intel-ucode: /boot/intel-ucode.img (Permissions mismatch)
warning: intel-ucode: /boot/intel-ucode.img (Modification time mismatch)
warning: linux: /boot/vmlinuz-linux (Permissions mismatch)
warning: linux: /boot/vmlinuz-linux (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.alias (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.alias.bin (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.builtin.bin (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.dep (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.dep (Size mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.dep.bin (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.dep.bin (Size mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.devname (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.softdep (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.symbols (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.symbols (Size mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.symbols.bin (Modification time mismatch)
warning: linux: /usr/lib/modules/5.0.5-arch1-1-ARCH/modules.symbols.bin (Size mismatch)
warning: syslinux: /boot/syslinux/syslinux.cfg (Permissions mismatch)
warning: systemd: /var/log/journal (GID mismatch)

Offline

#14 2019-03-31 14:31:27

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,895

Re: GCC 8 giving assembler errors when building

s0lar1n wrote:

...with the exception of using pip for packages not available through pacman...

Please tell me you never ran pip as root. If you did then it is likely the cause of your issue.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#15 2019-03-31 14:34:03

s0lar1n
Member
Registered: 2019-03-30
Posts: 8

Re: GCC 8 giving assembler errors when building

I wish I could say I didn't but I have....

Edit: I don't think the problem is with python

>>>cat test.c
#include <stdio.h>

int main(){
        printf("Test\n");
        return 0;
}
>>> gcc -O3 -g test.c -o test
/tmp/cc0E0ksN.s: Assembler messages:
/tmp/cc0E0ksN.s:14: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:14: Error: junk at end of line, first unrecognized character is `-'
/tmp/cc0E0ksN.s:16: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:16: Error: unknown pseudo-op: `.lvu1'
/tmp/cc0E0ksN.s:17: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:17: Error: unknown pseudo-op: `.lvu2'
/tmp/cc0E0ksN.s:20: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:20: Error: unknown pseudo-op: `.lvu3'
/tmp/cc0E0ksN.s:24: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:24: Error: unknown pseudo-op: `.lvu4'
/tmp/cc0E0ksN.s:25: Error: unknown .loc sub-directive `view'
/tmp/cc0E0ksN.s:25: Error: unknown pseudo-op: `.lvu5'

Last edited by s0lar1n (2019-03-31 15:59:57)

Offline

Board footer

Powered by FluxBB