You are not logged in.

#1 2019-04-03 20:06:59

Registered: 2019-04-03
Posts: 4

[Solved] MSI GL73 hangs on Shutdown/Reboot

I am posting this solution to my own problem here.

A few days ago I bought an MSI GL73 laptop. I had the problem that my laptop would hang up when shutting down/rebooting. I was then forced to long press the power key in order to turn the laptop off.

There were no error messages visible in the shutdown sequence. Only green "[OK] Stopped ..." messages. The last message before hanging up would be "[OK] Reached target Power-Off" or "[OK] Reached target Shutdown. [OK] Reached target Final Step. Starting Halt..."

Some background information: I disabled UEFI in the bios settings and switched to legacy mode. First I installed Windows 10 and then I installed Arch on another partition. Lastly, I installed grub. I also had troubled with backlight/brightness not working. So it looked very much like a Acpi problem.

Here is how I fixed it after lots of googling and messing around with bios settings and kernel parameters:

1) /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009'"

Now the laptop would shutdown/reboot after a delay of 90 seconds. This can be shorted with this:

2) /etc/systemd/system.conf


#2 2019-10-02 08:29:33

Registered: 2019-10-02
Posts: 1

Re: [Solved] MSI GL73 hangs on Shutdown/Reboot

Thank you for the solution.

Unfortunately, it doesn't work in my case, but thanks anyway!

Fortunately, I resolved the issue with shutdown for my situation :
The full answer is here:

In general the following works for me:
sudo vim /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet noefi"

Last edited by redeyed (2019-10-02 08:31:33)


Board footer

Powered by FluxBB