You are not logged in.

#1 2019-04-24 14:51:06

bred
Member
Registered: 2011-01-04
Posts: 46

CUPS SMB printer suddenly stopped working!

I've correctly installed a printer via SMB.
The printer has always worked: With driver and SMB login.
So my configuration I assume that is correct!

But a few days ago the printer has stopped working and in CUPS I see this message:
Session setup failed: NT_STATUS_ACCESS_DENIED

I've read the wiki regarding CUPS and searched on the web but I've not found any solution!

The used driver is: Canon LBP6780/3580 PXL

Offline

#2 2019-05-03 11:52:33

bred
Member
Registered: 2011-01-04
Posts: 46

Re: CUPS SMB printer suddenly stopped working!

Some notes:

If I list all shared printers with:
> smbclient -L printserver.example.com -U something\\myname

It works and it lists all shared printers.

Note that the username is in the form: something\myname

In the printers.conf the DeviceURI is set to this .....

DeviceURI smb://something\myname:MYpasswd@printserver.example.com/Printer_nn_33

The printer is not yet working .....

Any idea????

Offline

#3 2019-05-03 12:14:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,992

Re: CUPS SMB printer suddenly stopped working!

Offline

#4 2019-05-13 07:57:56

mgsCatDev
Member
Registered: 2019-05-12
Posts: 1

Re: CUPS SMB printer suddenly stopped working!

I'm not sure is related with Kerberos problem. The last version that works is 4.10.0-3 which says it's not compiled with Kerberos support. You can test it downgrading to that version the packages samba, smbclient and libwbclient and then executing:

# smbd -b | grep HAVE_LIBKADM5SRV_MIT

Like Samba wiki says: if no output is displayed, Samba was compiled without MIT Kerberos support and uses Heimdal Kerberos

Offline

#5 2019-05-13 10:57:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,459

Re: CUPS SMB printer suddenly stopped working!

Are you using this printer : https://www.canon-europe.com/support/co … n&os=linux ?

If so, post

pacman -Qs cndrvcups

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2019-05-13 11:54:31

bred
Member
Registered: 2011-01-04
Posts: 46

Re: CUPS SMB printer suddenly stopped working!

Lone_Wolf wrote:

Are you using this printer : https://www.canon-europe.com/support/co … n&os=linux ?

If so, post

pacman -Qs cndrvcups

The problem is not related with the driver:
seen also: https://bbs.archlinux.org/viewtopic.php?id=245658

Offline

Board footer

Powered by FluxBB